Welcome to the North American Subaru Impreza Owners Club Sunday September 23, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-15-2018, 08:45 PM   #826
baldwooky
Scooby Newbie
 
Member#: 118926
Join Date: Jun 2006
Chapter/Region: MWSOC
Location: Cleveland
Vehicle:
03 WRX Wagon
Sonic Yellow/Black 2 tone

Default

You'll hate the infotainment system and garbage paint more than the lack of acceleration imo

Holy lord is the paint bad on these. I have 4000 miles and theres at least 20-30 chips already. Thing will look like swiss cheese by the time its paid off.

Wax or clear bra it asap or you'll regret it.
* Registered users of the site do not see these ads.
baldwooky is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-16-2018, 08:38 AM   #827
Angelus911
Scooby Specialist
 
Member#: 89967
Join Date: Jun 2005
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sport
DGM

Default

I should add, when I bought my 2012, I was driving a 2000 Impreza which was pretty under powered, and a manual. I test drove the 2012 and was impressed with the performance over my 2000.

Having owned it for over 6 years now, though, my 2012 leaves a lot to be desired. The 2017s+ are supposed to be a lot better so it all depends.
Angelus911 is offline   Reply With Quote
Old 07-17-2018, 10:40 PM   #828
JimmyD3135
Scooby Newbie
 
Member#: 459519
Join Date: Dec 2016
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2018 Impreza Limited
Magnetite Gray Metallic

Default

Ok finally finished reading this entire thread.

2018 Limited Hatch here, coming from 2015 Sport Limited Hatch. I picked up the car on June 30. They searched high and low for another CWP with black interior for me but could not find any in he Limited trim in the tristate area, just sports and premiums. I ended up settling for the MGM.

Love the new interior, love the rear end on the 18 over the 15 but preferred the look of the 15 front end. Can't win them all I guess haha. Love the output of the new LED headlights and the Steering Responsive Headlights are a cool feature as well. I haven't noticed any problems with my infotainment system getting messed up but I also haven't connected my phone via Carplay yet. Mine came with all weather mats, which actually rise up along the sides to make it more of a tray compared to the 15 which was just a mat. It also came with a trunk tray which was nice as well. I like the tuning of the CVT as well. The 15 used to fall flat on its face as it shifted to 2nd gear. The 18 doesn't seem to do that. Handles great, definite improvement over the 15.

Dislikes include the sun visors. They're very thick. The holders for my garage door fob and gate fob for work barely stretch enough to fit on the visor. I don't like that I cannot change the color theme of the touchscreen as I was able to in the 15. The sound system sounds great but I noticed that its so well balanced front to back and side to side the the sound almost appears to be coming from the center console. It kinda messes with my ears a bit. Same gripe that I had with the 15, I think this car would have been better suited with the 2.5 motor over the 2.0. Not expecting it to be a WRX but a little more power would have been nice.

Edit - oh and another thing I dislike about the radio screen is that the presets don't scroll on the screen when you cycle through them from the button on the wheel. It just stays on the first page. Again, minor details. Overall a solid car.

Last edited by JimmyD3135; 07-18-2018 at 07:19 AM.
JimmyD3135 is offline   Reply With Quote
Old 07-18-2018, 08:35 PM   #829
youngrhetoric
Scooby Newbie
 
Member#: 488474
Join Date: Jul 2018
Location: Orange County, CA
Vehicle:
2018 Impreza Sport
Pearl White

Default

Quote:
Originally Posted by FLY_DMy View Post
I wanted to pass on another one of my initial issues/resolutions.

When I took delivery of my 2017, the dealer had given me a pretty cool (except the color), multi-adapter USB cable because my phone was almost dead.

After leaving the dealership I thought I would use my new USB cable to check out Android Auto.

Wrong!!! After plugging it into my Samsung 7, the icon for Android Auto was just as "Grey" as before.

I checked settings on the phone and Infotainment, but kept coming back to the cable. At one point I had tried (3) different cables!!!

I knew I didn't have (3) bad USB cables, and I was right - I didn't even have (1) bad cable, I just didn't have one cable of the right specification.

I went out and bought a Belkin a Mixit Lightning Charge and Sync cable and voila~ Problem Solved!!!

It would appear based on my troubleshooting that a std 2.0 USB to Micro cable will not work. Would need to be of 3.0 USB spec, there is even a 3.1 USB spec out now (with universal orientation) meaning "not keyed" or ie: you can't plug it in wrong. But we probably won't see many of those devices/cables for a while yet.

Not suggesting Belkin necessarily but found mine at Walgreens for like $9.00 and was glad to have this resolved.

Here is another option (if you a Fry's in your neighborhood):
http://www.frys.com/product/7734058?...q6gaAt0I8P8HAQ

Hopefully I can save someone else the trouble.

Although it seemed like you managed to resolve this issue, I figured I'd give my two cents on this. Did you initially have the Android Auto app installed? I know it seems obviously implied, but that could have caused some issues overall.
youngrhetoric is offline   Reply With Quote
Old 07-18-2018, 08:39 PM   #830
youngrhetoric
Scooby Newbie
 
Member#: 488474
Join Date: Jul 2018
Location: Orange County, CA
Vehicle:
2018 Impreza Sport
Pearl White

Default

Quote:
Originally Posted by baldwooky View Post
You'll hate the infotainment system and garbage paint more than the lack of acceleration imo

Holy lord is the paint bad on these. I have 4000 miles and theres at least 20-30 chips already. Thing will look like swiss cheese by the time its paid off.

Wax or clear bra it asap or you'll regret it.

Subaru is one of the few manufacturers that applies minimal layers of paint (IIRC, 1.) As a daily driver, it's inevitable regardless of what car you drive really. I've thought about it but 1) wax doesn't protect your car from chips, it'll just help preserve your clear coat and keep the car clean overall 2) clear bra and ceramic coating are hard to justify as it's more than 10% of your car's value that you're putting into preservation (unless you're doing clear coat yourself, in which case kudos).
youngrhetoric is offline   Reply With Quote
Old 07-24-2018, 01:06 PM   #831
baldwooky
Scooby Newbie
 
Member#: 118926
Join Date: Jun 2006
Chapter/Region: MWSOC
Location: Cleveland
Vehicle:
03 WRX Wagon
Sonic Yellow/Black 2 tone

Default

Can get enough clear vinyl on Amazon for the bumper, roof, hood lower rockers for under a Franklin. 184" x 55 " is $90.

Ceramic? Yeah not a Porsche so no.
baldwooky is offline   Reply With Quote
Old 08-05-2018, 12:15 PM   #832
ObewanKenobi
Scooby Newbie
 
Member#: 428583
Join Date: Aug 2015
Chapter/Region: Tri-State
Location: All over
Vehicle:
2017 Impreza Sport
Venetian Red Pearl

Default

Getting my son his first Subie this week, 2015 Imp Sedan, some kind of dark grey, only 43 thousand miles on it. $16,400.
ObewanKenobi is offline   Reply With Quote
Old 09-03-2018, 02:06 PM   #833
cosmictruthguru
Scooby Newbie
 
Member#: 490990
Join Date: Sep 2018
Default So far so good

Need three replies before I can post
cosmictruthguru is offline   Reply With Quote
Old 09-05-2018, 01:03 PM   #834
JimmyD3135
Scooby Newbie
 
Member#: 459519
Join Date: Dec 2016
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2018 Impreza Limited
Magnetite Gray Metallic

Default

So I connected my car to my home WiFi and every time it connects I get a prompt on my touchscreen display that says something like "Software update failed. Press to try again" but then nothing happens. Anyone else get this?
JimmyD3135 is offline   Reply With Quote
Old 09-11-2018, 05:53 PM   #835
88horizon5speed
Scooby Newbie
 
Member#: 442868
Join Date: Mar 2016
Vehicle:
2016 Impreza 5D CVT
Ice Silver

Default

I get that sometimes too, every other time I turn on my car and no updates available. I do love the car, I have an 18 likited hatch in mgm and I love eyesight and the rab/ blindspot. Except in the winter when there's ice crusted to it. Overall the car is really awesome my only complaints are the fold down sun visits are a thick plastic, my 16 imlreza base had soft touch and the 18 limited doesn't!? Also the stereo, although not perfect doesn't appear to be as bad as some have had. There's little glitches here and there but they really started after my pixel XL got the Android 9 update. Also the gps occasionally will freeze. The sound system is pretty dam good (hk).

Only real problem which Subaru said they will fix if I want, is the vent to the right of the stereo screen always pops out. I bought the car in January and as soon as it warmed up in the spring it pops out no matter how many times you push it back! My Subaru dealership said they had one other lady have the issue and they had to rip the whole dash out and replace it, I don't think it's worth doing because I'm afraid of introduction of more problems (I know when things are taken apart they never are exactly the same as before). Id rather live with it even though it bugs the hell out of me than to see little pry marks from plastic tools and such. Whatdo you guys think?
88horizon5speed is offline   Reply With Quote
Old 09-16-2018, 06:31 PM   #836
ObewanKenobi
Scooby Newbie
 
Member#: 428583
Join Date: Aug 2015
Chapter/Region: Tri-State
Location: All over
Vehicle:
2017 Impreza Sport
Venetian Red Pearl

Default

Quote:
Originally Posted by Angelus911 View Post
I should add, when I bought my 2012, I was driving a 2000 Impreza which was pretty under powered, and a manual. I test drove the 2012 and was impressed with the performance over my 2000.

Having owned it for over 6 years now, though, my 2012 leaves a lot to be desired. The 2017s+ are supposed to be a lot better so it all depends.
My son has a 2015 Impreza and it feels like a tin can compared to the new Global Platform cars.
ObewanKenobi is offline   Reply With Quote
Old 09-16-2018, 06:36 PM   #837
ObewanKenobi
Scooby Newbie
 
Member#: 428583
Join Date: Aug 2015
Chapter/Region: Tri-State
Location: All over
Vehicle:
2017 Impreza Sport
Venetian Red Pearl

Default

Quote:
Originally Posted by JimmyD3135 View Post
So I connected my car to my home WiFi and every time it connects I get a prompt on my touchscreen display that says something like "Software update failed. Press to try again" but then nothing happens. Anyone else get this?
The ability for owners to do updates is not available yet, you have to bring it to the dealer.
ObewanKenobi is offline   Reply With Quote
Old 09-16-2018, 09:37 PM   #838
Angelus911
Scooby Specialist
 
Member#: 89967
Join Date: Jun 2005
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sport
DGM

Default

Quote:
Originally Posted by ObewanKenobi View Post
My son has a 2015 Impreza and it feels like a tin can compared to the new Global Platform cars.


My sister has an Ď18 Crosstrek but I havenít had a chance to ride in it yet to compare.
Angelus911 is offline   Reply With Quote
Old 09-16-2018, 09:43 PM   #839
88horizon5speed
Scooby Newbie
 
Member#: 442868
Join Date: Mar 2016
Vehicle:
2016 Impreza 5D CVT
Ice Silver

Default

I can agree about the older generation feeling like a tin can. I had a 16 base and now am 18 limited and wow the difference in heft. The 16 if you shut the door remotely hard it feels like you'll break it. The 18 you shut it the same way and you see the image that the door is still open! You need to **** it with more if a firm significance. I'm constantly telling people don't slam it but you didn't shut it hard enough! Same with rattles. My 16 had so many rattles at the same milage than my 18 (only has one that isn't terribly noticable)
88horizon5speed is offline   Reply With Quote
Old 09-17-2018, 02:52 AM   #840
chanomatik
Scooby Guru
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: Mahwah, New Jersey
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

I've been driving a used 14 Crosstrek Premium from Alaska to New York and back through Indiana, Oklahoma, Colorado, Utah and now California. This thing is hot garbage compared to my 17 Impreza Sport. I miss that thing so much.

However in Colorado we camped outside in the backcountry and the Crosstrek handled the off-roading quite well. My Impreza doesn't have enough clearance. A new Crosstrek would be dope.
chanomatik is offline   Reply With Quote
Old Today, 12:47 PM   #841
JimmyD3135
Scooby Newbie
 
Member#: 459519
Join Date: Dec 2016
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2018 Impreza Limited
Magnetite Gray Metallic

Default

Quote:
Originally Posted by ObewanKenobi View Post
The ability for owners to do updates is not available yet, you have to bring it to the dealer.
Well that sucks. They just had it for a recall ECU reflash. I asked if whatever they were doing would fix the radio update too and the lady said "yes I think it should." It didn't, its still doing it. I guess I have to bring it back now.
JimmyD3135 is offline   Reply With Quote
Old Today, 06:29 PM   #842
Harriska2
Scooby Newbie
 
Member#: 464377
Join Date: Mar 2017
Location: Corvallis, OR
Vehicle:
2017 Impreza 5 Dr

Default

Quote:
Originally Posted by baldwooky View Post
You'll hate the infotainment system and garbage paint more than the lack of acceleration imo

Holy lord is the paint bad on these. I have 4000 miles and theres at least 20-30 chips already. Thing will look like swiss cheese by the time its paid off.

Wax or clear bra it asap or you'll regret it.
Iíve waxed mine 4 times in 1.5 years and it is finally not nearly as thirsty. Definitely keep it waxed.
Harriska2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.