Welcome to the North American Subaru Impreza Owners Club Wednesday October 28, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-16-2020, 10:05 AM   #1
cramen425
Scooby Newbie
 
Member#: 294964
Join Date: Sep 2011
Chapter/Region: Tri-State
Location: BUTLER, PENNSYLVANIA
Vehicle:
2005 STi
Black

Unhappy Airbag Module Failure???

Hello everyone. So I picked up a 2005 STi. Its currently in Salvage Title status. In order to get reconstructed or rebuilt title status, none of the warning lights can be on. When I got it, there was no Airbag module in the vehicle, like, it was removed. I found that by first scanning for codes which an array of codes displayed. Checked driver and passenger airbag circuits ultimately leading me to the module itself and viola, its missing. Bought one, installed, cleared codes with an airbag and abs scan tool. The scan tool cant "see" the module. Realized the part number was not correct on the module, returned, got a new module with the correct number. Scan tool still cannot see the module. Does anyone have any insight on this? The scan tool I got is specifically for airbag and abs issues, but I am not having any luck. There is an additional function that would allow me to code in a 4 digit alpha-numeric code for the module but I have no clue what code that could be. Any help would be immensely appreciated.
* Registered users of the site do not see these ads.
cramen425 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-16-2020, 01:31 PM   #2
Cougar4
Scooby Guru
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

I would check the resistance on the bus line to the module to see if you have the proper resistance on the line while the module is connected up. Also check for ground faults on the line.
Cougar4 is offline   Reply With Quote
Old 10-17-2020, 10:21 AM   #3
cramen425
Scooby Newbie
 
Member#: 294964
Join Date: Sep 2011
Chapter/Region: Tri-State
Location: BUTLER, PENNSYLVANIA
Vehicle:
2005 STi
Black

Default

So I have alldatadiy which is absolute trash, do you know where accurate schematics might be posted to I can see pin out references and what the parameters are?
cramen425 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.