Welcome to the North American Subaru Impreza Owners Club Thursday October 19, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-15-2011, 10:29 PM   #1
llb_dll
Scooby Newbie
 
Member#: 273785
Join Date: Feb 2011
Chapter/Region: NWIC
Location: Behind my 3 Goggles in PDX
Vehicle:
2005 Impreza 2.5 RS
PSM

Default Need Help : 05 Impreza 2.5RS Fog light install help

Hi, I am quite a noob to the subarus (just got the RS a month ago). I just installed a set of 04-05 WRX fog lights from ebay (not OEM) and everything was plug and play. However, I didn't know what to do with the fog light relay. To the right of the fuse box, there were 5 relay slots. I think it is a relay; it is a black block with 4 prongs in the back. Anyways, assuming it is called a relay, I saw 5 relay slots on the right of the fuse box underneath the driver's side dash. The 3rd and 5th slots were occupied, so taking an educated guess after TRYING to find some help on the forums, I plugged in the relay into the 4th slot (counting downwards from the top).

In my RS, there are 4 blank buttons on the left side of the dash above the coin tray. The 2nd blank button from the left had a harness plug running to it. I assumed that was for the fog light switch since it was a perfect fit. When have the car running, I push the fog light button and my HIGH-BEAMS come on!? I am very confused. Maybe I plugged in the wrong switch or mis-placed the relay?

Also, For some stupid reason, my passenger's side low-beam head light is not working. I've gone through 3 bulbs today (and they're not very cheap) as I keep finding that they are breaking after I test the headlights. I have no idea what is going on. I have the foglights plugged in properly as well at the bumper. There were 2 harness plugs that I know were for the fog lights as they plugged in perfectly.

Anyways, ANY HELP IS GREATLY APPRECIATED! I have been searching and searching with no results. Thank you.
llb_dll is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Found an 05 impreza 2.5rs need help making sure its a good deal wagonman1111 Newbies & FAQs 7 02-08-2010 02:49 PM
2001 2.5rs fog lights on 06 impreza Brepic06 Interior & Exterior Modification 11 01-26-2007 08:14 PM
Impreza GC8 / 2.5RS Fog Lights w/ PIAA's GC8STIV2 Private 'For Sale' Classifieds 0 12-16-2004 10:14 PM
NEED EXHAUST HELP 03 Subaru Impreza 2.5RS bugeyed bambams247 Normally Aspirated Powertrain 7 11-26-2003 12:29 PM
98 2.5RS fog light question nateconnella North West Impreza Club Forum -- NWIC 13 03-28-2003 01:32 AM

All times are GMT -4. The time now is 06:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.