Welcome to the North American Subaru Impreza Owners Club Sunday January 21, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > FA Series Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-22-2017, 02:37 PM   #376
tANNERRRR
Scooby Newbie
 
Member#: 246620
Join Date: May 2010
Chapter/Region: SCIC
Location: Southern CA
Vehicle:
2017 WRX
CWP

Default

Quote:
Originally Posted by dimaevt View Post
I have a question in regards to not hitting boost until the car is up to temperature:

What if I hit minimal boost, like 2, 3 or 4 psi? I try not to go above 3k RPM when my oil temp is below 180, but I ocasionally shift slightly above 3k and end up hitting a couple psi of boost. Is that at all bad? If so, i'll really try to shift at around 2500, even though its obnoxious for me to shift at such a low rpm
You're fine. I usually shift 3-3.5k before its warmed up but I usually don't even get into boost. As long as youre not going WOT and hitting 18 psi, you're good.
* Registered users of the site do not see these ads.
tANNERRRR is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-22-2017, 07:04 PM   #377
fuegodeth
Scooby Newbie
 
Member#: 65249
Join Date: Jun 2004
Location: Conroe, TX
Vehicle:
2016 WRX Premium
WRC Blue

Default

16 WRX all stock so far. 53,000 miles so far. Only issue I've had is a couple of times it didn't want to start this summer. battery was acting weak, and it was right after driving it, and then had a short stop at a store. No lights left on. Read around and it seems the ECU likes to reduce alternator output when the engine is pulling hard. That sounds about right, as I flog on this car daily. I have since the first miles. Anyway the fix is to run the headlights on all the time as it forces the alternator to keep working. I'll get a new batt in the near future. However, other than that the car has been perfect. I have had all services done at dealership, and kept it stock. Dealer keeps putting different mileage intervals on my sticker. Previous one was 8000, the next was 6,000, and this one is showing 7,000 miles to service. Do they do that on purpose, or are they making an error there. I usually get it done at 6000 regardless, but I have gone 7500 miles between oil changes a couple times. Subaru synthetic oil each time. Every time I've checked it before going in, and the oil level before the change has been full, and the color has looked good. I drive the car pretty hard. I don't speed all that much, but from the range of 0 to 80 I'm usually pushing the gas pretty hard if the opportunity arises. I don't redline it because it does seem to fall off a little over 5000. I try to shift at 5200 but sometimes go a little over or a little under. I drive it pretty hard right from the cold start, but do try to keep it under 4K for the first couple of minutes. So far, I think this car has been great, and it's not showing any issues from my treatment. She just seems to like to be driven, rather than babied in my opinion.
fuegodeth is offline   Reply With Quote
Old 11-26-2017, 04:10 PM   #378
nightcrawler60
Scooby Specialist
 
Member#: 126438
Join Date: Sep 2006
Chapter/Region: SCIC
Location: South Los Angeles/S.D
Default

2015 WRX 46k miles.
Cobb Flash and Fujitsubo exhaust
No problems
nightcrawler60 is offline   Reply With Quote
Old 11-26-2017, 07:31 PM   #379
P-Rod
Scooby Newbie
 
Member#: 447506
Join Date: May 2016
Chapter/Region: South East
Location: Charleston, SC Area
Vehicle:
2016 WRX

Default

2016 Premium. Just rolled 20k on the odometer today

Mods:

MAP cat-less j-pipe and exhaust
ETS Intake
Tgv / egr deletes
EBCS
Some suspension stuff

Tunes:

COBB stage 1 for the break in
MAP stage 2 until about 13k
Protune 13k-present. 323 hp and 319 tq in a mainline dyno.

Driving habits:

Always warm up to about 180 degrees before getting into boost. Redline a few times a week. Will run with whoever whenever I can.

Maintenance:

Oil changes every 3k.

Outcome:

Zero issues since owning the car. Bought brand new In March of 2016.
P-Rod is offline   Reply With Quote
Old 11-29-2017, 03:51 PM   #380
ernestns
Scooby Newbie
 
Member#: 475337
Join Date: Sep 2017
Vehicle:
2018 WRX
White

Default

2018 WRX Base, 2 months, 1.2k miles

Feels great, no issues. Although I do feel a noticeable power loss between ~4k-5k RPMs, but from searching online this seems common. One of my co-workers also mentioned shifting in the 18' felt noticeably smoother than his 15'
ernestns is offline   Reply With Quote
Old 11-29-2017, 03:57 PM   #381
joedreamliner787
NASIOC Supporter
 
Member#: 462457
Join Date: Feb 2017
Vehicle:
2016 WRX Limited
WR Blue

Default

Quote:
Originally Posted by ernestns View Post
2018 WRX Base, 2 months, 1.2k miles

Feels great, no issues. Although I do feel a noticeable power loss between ~4k-5k RPMs, but from searching online this seems common. One of my co-workers also mentioned shifting in the 18' felt noticeably smoother than his 15'
This is typical is stock WRX. Even just doing an AP and a protune you will notice a big difference. I remember when mine was stock and hitting the nose dive in power in the upper rpm range. I kept saying to myself who tunes a car like this . I swear the OEM tune is what breaks things as I remember the OEM made the car very zippy in the low end instead of smooth power throughout the power band. I wish you luck with your car!
joedreamliner787 is offline   Reply With Quote
Old 11-29-2017, 05:05 PM   #382
Boggie1688
Scooby Specialist
 
Member#: 165955
Join Date: Dec 2007
Location: California
Vehicle:
2015 WRX Base
WRB

Default

2015 WRX
350WHP/350WTQ on E62 (mustang dyno)
M1 ESP every ~ 5k
EGR/TGV Del
KB J/I
Nameless Mid
Stock axle back
IAG AOS

A few other tid bits, but else related to the engine.

Car is at 55k and running just as strong as the first day. Yes it makes some funny noises sometimes, but it starts when I crank, and goes like hell when I put my foot down. I've changed the battery and done a few other things, but when it comes to whether or not the car gets me from point a to b, I cannot fault it. Nothing I would consider a problem.
Boggie1688 is online now   Reply With Quote
Old 11-29-2017, 05:27 PM   #383
DonDonDon
Scooby Newbie
 
Member#: 476596
Join Date: Oct 2017
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2015 WRX

Default

2015 WRX (build date Dec 2014)
Engine stock @ 55,000 miles
Subaru oil and filter change every 6000 miles. First oil change was after 1000 miles.

No issues so far. Going stage 2 in December since the warranty is almost up.
DonDonDon is offline   Reply With Quote
Old 11-29-2017, 11:46 PM   #384
D3luxe
Scooby Newbie
 
Member#: 416300
Join Date: Mar 2015
Chapter/Region: MWSOC
Vehicle:
2015 WRX
DGM

Default

Adding mine to the list.

Currently at about 31k miles. Stage 1 OTS tune at 800. Stage 2 (just catless j-pipe) at 2000, with a Bren tune. Periodically added additional parts as they became available.

Current mod list:
3-port Grimmspeed EBCS
Grimmspeed Stealthbox
Mishimoto charge pipe
EGR & TGV deletes
Invidia catless J-pipe
ETS Quiet catback

I think that's about it for power adders.. Only minor issue I've seen was my pitch-stop bracket started getting the ever so slightest crack (running a Kartboy pitchstop mount). Threw the pitchstop bracket on it and haven't noticed it getting any worse, with a couple track days on it too. Handful of other mounts and bushings done to tighten up the drivetrain.

Running Mobil1 Euro blend 0w40 since the first oil change at ~1k miles. Changing oil every 3-4k or so.
D3luxe is offline   Reply With Quote
Old 12-10-2017, 12:32 PM   #385
az16wrx
Scooby Newbie
 
Member#: 436579
Join Date: Dec 2015
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2016 WRX
Lapis Blue

Thumbs up Checking In

2016 CVT Premium
Purchased New two years ago
46,000 miles
Stage 1 (Cobb)
27 MPG is S-Mode

No mechanical issues. Will be adding a CVT cooler, TGV/EGR Deletes, a Grimmspeed TMIC and then getting an e-tune.

I just replaced the factory battery but that is common in the desert after two summers. My blower motor relay sounds like it is failing or will fail so I will be replacing that shortly.

Only "annoyances" is the in-cabin noise and the rattle.
az16wrx is offline   Reply With Quote
Old 12-10-2017, 12:41 PM   #386
joedreamliner787
NASIOC Supporter
 
Member#: 462457
Join Date: Feb 2017
Vehicle:
2016 WRX Limited
WR Blue

Default

2016 WRX Limited
Purchased new.
At 10k miles I went from stock to full stage 2+ and straight to the dyno for a protune.

Currently 23K miles on the odometer. Car runs great, no issues besides the smoking from the tail pipe which is becoming typical for stage 2 cars. Hits target boost no problem.

Change oil (Rotella T6 5w-40) every 3500 miles and use the OEM filter, new crush washer every time.

MODS:
Cobb stage 2+ Catted package (AP, Catted J-Pipe, Intake, Full Exhaust)
EBCS
Grimmspeed TMIC
EGR/TGV Deletes
Boomba short shifter and plate
joedreamliner787 is offline   Reply With Quote
Old 12-10-2017, 12:47 PM   #387
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2016 Forester XT CWP
2002 WRX SRP

Default

I love how people are posting in the "zero issues" thread and listing issues lol.
Celery GT-5 is offline   Reply With Quote
Old 12-25-2017, 06:10 PM   #388
nathant
Scooby Newbie
 
Member#: 448400
Join Date: Jun 2016
Default

2017 WRX
I bought my car brand new and it is currently at 20k miles. I've been running this setup for about 15k miles and have had zero problems. It's my daily driver and beat on it pretty hard on a regular basis. I went through the stock tires at 18k miles lol.
Mod List:
GS TMIC
GS Chargepipe
ETS intake
Invidia Catless Jpipe
PRL TGV & EGR Deletes
E-tune from Torqued Performance
nathant is offline   Reply With Quote
Old 12-26-2017, 02:40 PM   #389
climate
Scooby Newbie
 
Member#: 434960
Join Date: Nov 2015
Default

Got my 2015 WRX in Jan 2015, almost exactly 3 years ago.
Now at 95k miles with absolutely zero minor or major issues. (might be one of the highest mileage WRX of 2015 MY in the US)
Pro tune, Cobb full turboback, GrimSpeed EBCS since 20k miles
ETS FMIC, TGV-EGFR delete since 50k miles
Many other non-powetrain related mods
Oil changes at the dealer every 5k. Walnut blasting at 70k

Last edited by climate; 12-26-2017 at 02:48 PM.
climate is offline   Reply With Quote
Old 12-26-2017, 02:45 PM   #390
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: Bucks County, PA
Vehicle:
2016 WRX Premium
Rock Chip Metallic

Default

Quote:
Originally Posted by az16wrx View Post
2016 CVT Premium
Purchased New two years ago
46,000 miles
Stage 1 (Cobb)
27 MPG is S-Mode
How many miles on Stage 1? And is it 91 or 93?

Thinking about taking this route soon but I've heard some people are having trans slipping issues even on Stage 1.

Could be how they treat the car, too, but I'm just gathering opinions and info.
Obviously Tyler is offline   Reply With Quote
Old 12-28-2017, 08:53 AM   #391
fastkx125
Scooby Newbie
 
Member#: 184022
Join Date: Jul 2008
Default

I think every car forum needs a thread like this lol. If you only read what people post usually you'll think every car is a pile. Looking forward to getting into a 2018 WRX
fastkx125 is offline   Reply With Quote
Old 12-28-2017, 03:36 PM   #392
Backroad Rex
Scooby Newbie
 
Member#: 414188
Join Date: Feb 2015
Chapter/Region: MWSOC
Location: SE Michigan
Vehicle:
2015 WRX
Silver

Default

Quote:
Originally Posted by climate View Post
Got my 2015 WRX in Jan 2015, almost exactly 3 years ago.
Now at 95k miles with absolutely zero minor or major issues. (might be one of the highest mileage WRX of 2015 MY in the US)
Pro tune, Cobb full turboback, GrimSpeed EBCS since 20k miles
ETS FMIC, TGV-EGFR delete since 50k miles
Many other non-powetrain related mods
Oil changes at the dealer every 5k. Walnut blasting at 70k
Thought I was high at 83,000, but yea, no issues at all here. Stock except for IAG AOS installed at 15,000, and other little tidbits (mudflaps, alum skid plate, shifter bearings). Oil changes every 5,000.
Backroad Rex is offline   Reply With Quote
Old 12-28-2017, 08:31 PM   #393
VelosoWrex
Scooby Newbie
 
Member#: 439220
Join Date: Jan 2016
Location: New Jersey
Vehicle:
2016 WRX
CWP

Default 2016 WRX Premium

2016 WRX
CWP

Tuned by ProCom Racing by Lou @ Toms River, NJ
332AWHP/349AWTQ
***Hit them up if you are in Jersey, great guys other there***

Engine Modifications:
ETS Front Mount Intercooler
3.5" Core/TiAL Flange Upgrade
ETS Air Intake w/ Intake Box
TiAL QR Recirculating BPV 10PSI Spring
IAG TGV Deletes
PRL EGR Deletes
ETS CatLess J-Pipe
Grimmspeed EBCS
AEM320 Fuel Pump
IAG AOS

Transmission:
Boomba Short Throw Shifter
Boomba Transmission Plate
Perrin Shifter Bushing
Perrin Shifter Stop
Perrin SS Braided Clutch Line

Suspension/Handling:
Perrin Pitch Stop Mount
Perrin Pitch Stop Mount Bracket
Perrin Master Cylinder Brace
Tanabe Tower Strut Brace

Current Mileage: 15k
Oil Changed: Every 3k
First Oil Change 1K: Subaru OEM 5W-30
Second Oil Change 3K: Subaru OEM 5W-30
ALL Other Oil Changes (3K Intervals): Motul 8100 5W-30 X-Clean; switched to Motul 8100 EFE 5W-30 @15k since Motul discontinued X-Clean

Cabin Air Filter: Every 10k (OEM Filter)

Diff/Gear/Transmission Fluid: Every 12k; Motul Gear 300 75W90

Spark Plugs Swapped @ 14k; OEM Plugs

Compression Test Performed: (Health Checks): CYL1: 230 CYL2: 210 CYL3: 210 CYL4: 200 (15k)

BlackStone Oil Lab Analysis Perform Every Oil Change.

No problems other than recalls and a fuel tank swap since I broke two studs when installing the fuel pump.

Last edited by VelosoWrex; 12-28-2017 at 08:41 PM.
VelosoWrex is offline   Reply With Quote
Old 12-29-2017, 06:54 PM   #394
noobultimatum
Scooby Newbie
 
Member#: 431550
Join Date: Oct 2015
Location: South Florida
Vehicle:
2016 WRX
Ice Silver

Default

Quote:
Originally Posted by VelosoWrex View Post
2016 WRX
CWP

Tuned by ProCom Racing by Lou @ Toms River, NJ
332AWHP/349AWTQ
***Hit them up if you are in Jersey, great guys other there***

Engine Modifications:
ETS Front Mount Intercooler
3.5" Core/TiAL Flange Upgrade
ETS Air Intake w/ Intake Box
TiAL QR Recirculating BPV 10PSI Spring
IAG TGV Deletes
PRL EGR Deletes
ETS CatLess J-Pipe
Grimmspeed EBCS
AEM320 Fuel Pump
IAG AOS

Transmission:
Boomba Short Throw Shifter
Boomba Transmission Plate
Perrin Shifter Bushing
Perrin Shifter Stop
Perrin SS Braided Clutch Line

Suspension/Handling:
Perrin Pitch Stop Mount
Perrin Pitch Stop Mount Bracket
Perrin Master Cylinder Brace
Tanabe Tower Strut Brace

Current Mileage: 15k
Oil Changed: Every 3k
First Oil Change 1K: Subaru OEM 5W-30
Second Oil Change 3K: Subaru OEM 5W-30
ALL Other Oil Changes (3K Intervals): Motul 8100 5W-30 X-Clean; switched to Motul 8100 EFE 5W-30 @15k since Motul discontinued X-Clean

Cabin Air Filter: Every 10k (OEM Filter)

Diff/Gear/Transmission Fluid: Every 12k; Motul Gear 300 75W90

Spark Plugs Swapped @ 14k; OEM Plugs

Compression Test Performed: (Health Checks): CYL1: 230 CYL2: 210 CYL3: 210 CYL4: 200 (15k)

BlackStone Oil Lab Analysis Perform Every Oil Change.

No problems other than recalls and a fuel tank swap since I broke two studs when installing the fuel pump.
You seriously change your diff and tranny oil every 12k? Do you not drive much??? Because that is hella frequent...
noobultimatum is offline   Reply With Quote
Old 12-29-2017, 09:13 PM   #395
VelosoWrex
Scooby Newbie
 
Member#: 439220
Join Date: Jan 2016
Location: New Jersey
Vehicle:
2016 WRX
CWP

Default

Quote:
Originally Posted by noobultimatum View Post
You seriously change your diff and tranny oil every 12k? Do you not drive much??? Because that is hella frequent...
Had the car for two years only put 15k but yeah, like to have a good maintenance history is all
VelosoWrex is offline   Reply With Quote
Old 01-02-2018, 02:10 PM   #396
Dirty Bucket
Scooby Newbie
 
Member#: 292682
Join Date: Aug 2011
Chapter/Region: NESIC
Location: Maine
Vehicle:
2015 Impreza WRX
WR Blue

Default

2015 WRX Premium

Bren Tuning 323WHP/322WTQ

Engine Mods:
TGV Delete
EGR Delete
Grimmspeed 3-port
Killer B Dual EWG Header
MAP Intake
MAP Catless J-pipe
Stock catback

Other Mods:
Rear LSD out of Forester XT (Best Mod I've done)
Perrin Shift Stop
Trailer Hitch

Currently I have 36,000 miles on it with no major issues as of yet. I did have the battery die about 1.5 years in, but that's not a big deal. The only other problem I have so far is the slight oil burning. I've read that is a common problem with these cars once you go catless, but other than that I can't complain. Prior to going catless, not a drop of oil was burnt between my 5000 mile oil changes.
Dirty Bucket is offline   Reply With Quote
Old 01-07-2018, 11:01 AM   #397
Wrxjoe79
Scooby Newbie
 
Member#: 416772
Join Date: Mar 2015
Default

checking in again.

15' WRX, 35,000 miles.

Only problems so far:

Throw out bearing making noise- fixed under warranty

Trunk latch wouldnt catch unless truck was slammed shut- fixed under warranty.


edit: No mods on the car except nameless muffler delete.
Wrxjoe79 is offline   Reply With Quote
Old 01-08-2018, 08:03 PM   #398
mxdude105
Scooby Newbie
 
Member#: 457465
Join Date: Nov 2016
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2017 WRX Base
ISM

Default

Quote:
Originally Posted by climate View Post
Got my 2015 WRX in Jan 2015, almost exactly 3 years ago.
Now at 95k miles with absolutely zero minor or major issues. (might be one of the highest mileage WRX of 2015 MY in the US)
Pro tune, Cobb full turboback, GrimSpeed EBCS since 20k miles
ETS FMIC, TGV-EGFR delete since 50k miles
Many other non-powetrain related mods
Oil changes at the dealer every 5k. Walnut blasting at 70k
How did the valves look at 70k?
mxdude105 is offline   Reply With Quote
Old 01-08-2018, 09:25 PM   #399
n2oiroc
Scooby Specialist
 
Member#: 141952
Join Date: Feb 2007
Chapter/Region: MWSOC
Location: milwaukee'ish
Vehicle:
16 wrx 17 cx-5

Default

Quote:
Originally Posted by Wrxjoe79 View Post
checking in again.

15' WRX, 35,000 miles.

Only problems so far:

Throw out bearing making noise- fixed under warranty

Trunk latch wouldnt catch unless truck was slammed shut- fixed under warranty.


edit: No mods on the car except nameless muffler delete.
throw out bearing going bad isnt "zero problems".
n2oiroc is online now   Reply With Quote
Old 01-09-2018, 11:49 AM   #400
killadawg
Scooby Newbie
 
Member#: 424203
Join Date: Jun 2015
Chapter/Region: NESIC
Location: Boston
Vehicle:
2016 WRX Premium
Grey Metallic

Default

Hmmm I have had zero related issues to the stock parts that came with my OEM car when I got it new..

With that said, most of my car is not stock.. so if **** happens it's on me!! So far only broken bolts, ripped off front bumper and plastic **** under the car. Curbed my Volk wheels really bad and pissed off my neighbors with loud exhaust..

Oil change with motul 10w40 V300 every 3 - 5k depends on the weather.. not changing in minus degree weather. Sti swap with Motul comp oil. Grease and lube all joints with Amsoil hd grease. Has been one tough car, Ive done some very hard snow and ice driving and all good. Ron Watson tune doing great, CT tune also doing great, no cold start issues.. my tune is a WIP yet still a bit afraid to turn it up.

Oh yeah get a new battery stock one is ****! I've replaced knock sensors, plugs, and on my 3rd GS CAI filter..

Also if modded with motor and trans mounts check your bolts.. my headers where missing 3 nuts when I did my swap.. they wiggled out some how..

But yeah Zero OEM issues.. but how would I know :-).. 30+ k miles most on stage 2+ or 3 what ever it is called these days..
killadawg is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:39 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.