Welcome to the North American Subaru Impreza Owners Club Sunday June 16, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-22-2019, 10:06 PM   #1
CaliKid87
Scooby Newbie
 
Member#: 501937
Join Date: May 2019
Unhappy 05 STi throwing CEL for Cat Deficiency

Hello all, new user here!

This is my situation...

I have owned my 05 wrx sti since I purchased it brand new. I slightly modded it with a Helix Cat'ed Downpipe and a Helix Turbo Back Exhaust from Gruppe-S back in 2008-2009? And it came with a Cel Light fix for the o2 sensor I believe (I didnt install it) but reguardless. It seemed to work and I never through a Cel light or anything for years UNTIL now! I had the car maintenanced several times and after the last one BOOM CEL light was thrown, and after reading the code it came up "CAT DEFICIENCY". Can I fix this by purchasing a "BETTER" 02 spacer etc? Like a 90 degree one? And another noob question, how many spacers or 02 sensors do I need to space away from the bung? Is there more than 1 o2 sensor I need to space? And finally, are all 02 sensor spacers I am seeing online capable of fitting? Are they all interchangeable in terms of their threading etc? I cant afford to FLASH the ECU or pro tune is at this point and YEARS ago I made the mistake of selling the OEM exhaust. I tried clearing the CEL and resetting the ECU several times and it will run fine with no code for 1-2 days but inevitably the CEL light returns and it throws the code now for some reason. The vehicle only has 60,000 miles on it and I have only put maybe 30,000 miles on the exhaust so no way is it a bad catalytic converter or sensor. PLEASE HELP! I passed smog with this exact setup 2 years ago when NO CEL light was on and with this exhaust, but I need to pass it for registration in 14 days. I cannot smog it for registration with the Check Engine light on.

Thanks for ANY and ALL help fellas! This forum is a MECCA of advice and excellent help!
* Registered users of the site do not see these ads.
CaliKid87 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-23-2019, 10:25 PM   #2
awfulwaffle
Scooby Newbie
 
Member#: 409332
Join Date: Dec 2014
Location: SE MI/SE WI
Vehicle:
2013 WRX
PBP

Default

Whoever tuned your car for that downpipe can disable that code for you, assuming you got it tuned.
awfulwaffle is online now   Reply With Quote
Old 05-24-2019, 12:03 AM   #3
CaliKid87
Scooby Newbie
 
Member#: 501937
Join Date: May 2019
Default

No I never did a tune bc I was short on money and I still cannot afford one at the moment either. I explained it in my long ramblings above...
CaliKid87 is offline   Reply With Quote
Old 05-24-2019, 12:44 PM   #4
awfulwaffle
Scooby Newbie
 
Member#: 409332
Join Date: Dec 2014
Location: SE MI/SE WI
Vehicle:
2013 WRX
PBP

Default

No answer for you on spacers since I've always just disabled my O2 codes. Maybe you can try finding someone local set up to tune open source (Tactrix or VAG-COM cable) who can pull the ROM from the ECU, disable the code, and then flash it back. May not happen within your timeframe, though. If you want to drive to Detroit I'll do it for you
awfulwaffle is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:40 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.