Welcome to the North American Subaru Impreza Owners Club Sunday December 5, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-06-2021, 02:17 PM   #1
DrTrae
Scooby Newbie
 
Member#: 454659
Join Date: Sep 2016
Chapter/Region: MWSOC
Location: Loves Park, IL
Vehicle:
2004 WRX Wagon
Java Black Pearl

Default DrTrae's 2004 WRX Wagon

Hey guys. I'm Trae, and this'll be my thread chronicling the resurrection of my 2004 BlobWagon. Forewarning, it'll probably be slow.

I'm having a helluva time trying to get an img.nasioc account up and running, or getting a hold of mods to help me with it, so please bear with me.
Going to try google drive hosting first, and if that doesn't work, I'll try something else.



I bought the car about 4 years ago from a guy in Schaumburg, IL. This is my second Subaru, after I sold my 97 Legacy Wagon to a buddy of mine. Since then, my wife has also acquired a 2020 Crosstrek.

Loved the car. Drove it back and forth to work every day, played in the snow, Tokyo Drifted in to a corn field in the rain like a jackass and drove right back out of it, etc.
Never could have done that in any of my Volkswagens that I had before.
Then one day it started pouring white smoke out of the exhaust, got REAL hot a couple times, and it has been parked ever since. I've always assumed it needed head gaskets, but never had the time or money to address it.

We bought a house, had another kid, and now I finally have the time and money (sorta) to start going through everything I can to get it back on the road.

When I bought the car, it already had a COBB catted downpipe, K&N Typhoon intake, Cusco shock tower brace, Whiteline rear end links and sway bar mounts, and the Whiteline ALK up front. It also has 06-07 brakes all around.

On to the pictures. Sadly, I don't have any from when I first got the car.

More recently, before I started collecting parts.


The day that I decided it was time to get to work.


Huge thanks to MrSubaru1387 for helping me get this far.


Yanked.




Started building a pile of parts.
I'm planning on going through most of the mechanical bits of the car, and either upgrade them or refresh them.
This may include sandblasting suspension parts and POR-15'ing them, replacing every single bushing that I can, tearing down the motor, etc.

I bought parts to do a sedan suspension swap a long time ago, so I'll be shining these lateral links up and putting new poly in them, as well as the rest of the rear end. Whiteline Rear Vehicle Essentials kit.


Last edited by DrTrae; 10-06-2021 at 02:23 PM. Reason: Separating thread
DrTrae is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.