Welcome to the North American Subaru Impreza Owners Club Tuesday May 22, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-22-2014, 07:37 PM   #2026
wgr73
Scooby Specialist
 
Member#: 232458
Join Date: Dec 2009
Chapter/Region: SWIC
Location: Las Cruces/El Paso
Vehicle:
2005 & 2008 STi
Cobb 20g & EFR 7670

Default

Nice update Bariga!! Sick SB
* Registered users of the site do not see these ads.
wgr73 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-24-2014, 01:03 AM   #2027
Bariga
Scooby Specialist
 
Member#: 179846
Join Date: May 2008
Chapter/Region: NWIC
Location: Renton, WA
Vehicle:
07 STi Limited
EFR 8374 TS EWG

Default

put down like 20 miles today engine is super quiet, no piston slap at all.
Still on first oil running 5-10 psi and 5k max rpm for little bit. She just screams for boost
Some more pics from rebuild.





Last edited by Bariga; 08-24-2014 at 01:16 AM.
Bariga is offline   Reply With Quote
Old 08-24-2014, 09:16 PM   #2028
MPS-Dom
Scooby Specialist
 
Member#: 204421
Join Date: Mar 2009
Chapter/Region: NWIC
Location: Liberty Lake
Default

Did you get the pistons I recommended?

Sent from my SAMSUNG-SM-G900A using NASIOC mobile app
MPS-Dom is offline   Reply With Quote
Old 08-25-2014, 02:21 AM   #2029
Bariga
Scooby Specialist
 
Member#: 179846
Join Date: May 2008
Chapter/Region: NWIC
Location: Renton, WA
Vehicle:
07 STi Limited
EFR 8374 TS EWG

Default

yep JE,
Bariga is offline   Reply With Quote
Old 08-25-2014, 06:15 AM   #2030
subbi7
Scooby Newbie
 
Member#: 241967
Join Date: Mar 2010
Vehicle:
02 wrx

Default

Which je?
Fsr?

Sent from my GT-I9300 using NASIOC mobile app
subbi7 is offline   Reply With Quote
Old 08-25-2014, 10:34 AM   #2031
Bariga
Scooby Specialist
 
Member#: 179846
Join Date: May 2008
Chapter/Region: NWIC
Location: Renton, WA
Vehicle:
07 STi Limited
EFR 8374 TS EWG

Default

Subaru Ej257 Time Attack "fsr" Stroker Series 296352
Bariga is offline   Reply With Quote
Old 08-25-2014, 11:17 AM   #2032
MPS-Dom
Scooby Specialist
 
Member#: 204421
Join Date: Mar 2009
Chapter/Region: NWIC
Location: Liberty Lake
Default

excellent.
MPS-Dom is offline   Reply With Quote
Old 08-25-2014, 01:22 PM   #2033
Bariga
Scooby Specialist
 
Member#: 179846
Join Date: May 2008
Chapter/Region: NWIC
Location: Renton, WA
Vehicle:
07 STi Limited
EFR 8374 TS EWG

Default

I need to pass goddemn emissions, dom do you remember if your ODB2 port not working will they do sniff test? Because with E85 and straight pipe I think ill pass.
Bariga is offline   Reply With Quote
Old 08-26-2014, 11:52 AM   #2034
Bariga
Scooby Specialist
 
Member#: 179846
Join Date: May 2008
Chapter/Region: NWIC
Location: Renton, WA
Vehicle:
07 STi Limited
EFR 8374 TS EWG

Default

running 20 psi i'm still below 100 mile mark, going to find some big ass hill to do pulls so rings get nice and hot
Bariga is offline   Reply With Quote
Old 09-23-2014, 11:55 AM   #2035
Bariga
Scooby Specialist
 
Member#: 179846
Join Date: May 2008
Chapter/Region: NWIC
Location: Renton, WA
Vehicle:
07 STi Limited
EFR 8374 TS EWG

Default

I'm at 500 mile mark engine runs great, except I lost all my gears and shifter is like computer joystick. Turns out the pin came out that hold link to the tranny rod, but when I inserted a bolt in there it didn't solve the issue. I only have 3d and 4th gear now all the time lol.
Bariga is offline   Reply With Quote
Old 09-23-2014, 01:47 PM   #2036
wgr73
Scooby Specialist
 
Member#: 232458
Join Date: Dec 2009
Chapter/Region: SWIC
Location: Las Cruces/El Paso
Vehicle:
2005 & 2008 STi
Cobb 20g & EFR 7670

Default

Quote:
Originally Posted by Bariga View Post
I only have 3d and 4th gear now all the time lol.
Those are the powerband gears...that's all you need

Dang man, that stinks. Hopefully you get it fixed soon
wgr73 is offline   Reply With Quote
Old 09-23-2014, 02:07 PM   #2037
MPS-Dom
Scooby Specialist
 
Member#: 204421
Join Date: Mar 2009
Chapter/Region: NWIC
Location: Liberty Lake
Default

did you put it back on upside down?
MPS-Dom is offline   Reply With Quote
Old 09-23-2014, 02:14 PM   #2038
Bariga
Scooby Specialist
 
Member#: 179846
Join Date: May 2008
Chapter/Region: NWIC
Location: Renton, WA
Vehicle:
07 STi Limited
EFR 8374 TS EWG

Arrow

Roll pin in U-Joint was gone, installed new one and problem gone.

Last edited by Bariga; 09-25-2014 at 01:00 AM.
Bariga is offline   Reply With Quote
Old 03-03-2015, 02:34 PM   #2039
TheSourOG
Scooby Newbie
 
Member#: 365911
Join Date: Aug 2013
Default

Anything cool happening in here?
TheSourOG is offline   Reply With Quote
Old 03-04-2015, 11:49 AM   #2040
Bariga
Scooby Specialist
 
Member#: 179846
Join Date: May 2008
Chapter/Region: NWIC
Location: Renton, WA
Vehicle:
07 STi Limited
EFR 8374 TS EWG

Default

raping it on daily bases, it becomes a beast every time i fill it with e85
Bariga is offline   Reply With Quote
Old 03-05-2015, 11:11 AM   #2041
Full-Race Geoff
Scooby Specialist
 
Member#: 133386
Join Date: Nov 2006
Chapter/Region: Tri-State
Location: AZ/NJ
Vehicle:
13 F150
ecoboost

Default

last weekend I drove a customers LGT with the same setup as you - twinscroll 7670 with turbosmart 26psi WG, 4 port solenoid, E85, built motor. a LOT of fun
Full-Race Geoff is offline   Reply With Quote
Old 12-05-2015, 06:40 PM   #2042
armyssoldierboy
Scooby Specialist
 
Member#: 109424
Join Date: Mar 2006
Chapter/Region: South East
Location: Fayetteville, NC
Vehicle:
06 AW STI
Twin Scroll HTA gt3076r

Default

Quote:
Originally Posted by Bariga View Post
raping it on daily bases, it becomes a beast every time i fill it with e85
Do you have an updated dyno chart or are you still running the 21psi? I just ordered the ts 7670 but I was advised to go with the 1.05a/r since I'm ewg'd. I wanted the .92a/r. Oh well. I too, have Kelford 264's. It's still going to be better than the HTA 3076 w/ 1.06a/r I had Unfortunately, the closest e85 station is 45 minutes away.
armyssoldierboy is offline   Reply With Quote
Old 12-06-2015, 02:26 AM   #2043
hapahoale
Scooby Newbie
 
Member#: 435596
Join Date: Dec 2015
Default

Looks like a submarine in there!
hapahoale is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Maxwell Power Tuned, 2.35L GT35R 537whp and 9k rpm, 4K rpm power band Maxwell Power Proven Power Bragging 634 06-11-2016 02:34 AM
Maxwell Power Services aka GetaDomTune AwaySooner Vendor Reviews 7 03-11-2010 03:54 PM
+1 for Dom/Maxwell Power Jeff54 Vancouver Impreza Club Forum -- VIC 22 09-02-2009 02:22 PM
My new Maxwell Power Services engine is almost in !!! leonbmx North West Impreza Club Forum -- NWIC 13 03-23-2009 10:28 AM

All times are GMT -4. The time now is 09:08 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.