Welcome to the North American Subaru Impreza Owners Club Saturday September 22, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-29-2009, 08:10 AM   #1
JASWRX
Scooby Specialist
 
Member#: 40742
Join Date: Jul 2003
Location: LA, Ca
Vehicle:
2002 WRX
WRB

Default Just bough Eclipse Navi and can't figure out how to install speed sensor

I have to install the speed sensor which I believe is in the ECU. I do not want to mess this up and short my ECU!

Has anyone done this?

I know the sensor is not 100% required but it is nice to have as it the navi would be exact based on my vehicles speed.

Thanks
Justin
* Registered users of the site do not see these ads.
JASWRX is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-29-2009, 09:27 AM   #2
Uncanny
Scooby Specialist
 
Member#: 133012
Join Date: Nov 2006
Chapter/Region: MWSOC
Location: Kansas City
Vehicle:
2015 STi
Lightning Red

Default

Uncanny is offline   Reply With Quote
Old 03-29-2009, 06:32 PM   #3
JASWRX
Scooby Specialist
 
Member#: 40742
Join Date: Jul 2003
Location: LA, Ca
Vehicle:
2002 WRX
WRB

Default

Thanks!
JASWRX is offline   Reply With Quote
Old 09-29-2010, 03:24 PM   #4
swanjm5
Scooby Newbie
 
Member#: 227015
Join Date: Oct 2009
Location: Winston Salem, NC
Vehicle:
2002 WRX sedan

Default

EDIT: Nobody responded so i tried to answer these myself..and went ahead and installed. I figured i'd update this post with answers to these questions for anybody searching information later. See bold responses.

Digging up an old thread.

Just got a navi (DNX5160) and will be installing it in a 2002 wrx.

For anybody confused...Many if not all nav units come with a metal sleeve that the unit fits into. You will NOT use this during the install into a 02 wrx (and probably any year wrx). When you remove the old stereo you remove the brackets from each side and attach them to your new unit. In my case, only 3 of the 4 screw holes lined up with the brackets.....but it's fine.

I can't install until friday, so i haven't even taken out my stock HU. However, where exactly is this speed sensor wire located (i know it's apparently a gray wire, pin A1)? And what do i need to buy to tap my Nav wire into it w/o disrupting it's connection to the ECU? A link to a picture of the product i should look for would be helpful as i may not be familiar with the eletrical hardware lingo.

The VSS (Vehicle speed sensor) wire can be found behind your gauge cluster (speedometer and what not). There are apparently a few screws in the "roof" of your speedometer cubby. Take them out and remove the plastic piece which will expose a few screws that hold the gauge cluster in. Remove them and the entire cluster should just pull out. The VSS can also be found in the wire bundles somewhere in the foot area of the passenger side. Not really sure about this location (and am too lazy to check....since it turns out that the DNX5160 doesn't even use a VSS!)

You can tap into the wire using a T wire tap. Google "T wire tap" and you'll see the product. Or just ask somebody at home depot if you're not sure.

Also...where is the wire to the light control switch for the dimmer option? Pretty sure it's referring to the headlight control switch. There isn't a listed pinout in the link posted above. I'm actually a bit confused by this aspect of the install. The wiring adaptor that connects to the cars oem wiring harness has an orange wire labeled "Illumination - not dimmed by switch". However, the wiring for the Nav's wiring has an orange/white wire labeled "Dimmer control wire - to car light control switch". I might be mistaken, but if i connect these won't i never get a dimming effect?....which is why i'm asking where the wire to my headlight switch is located with the intent to connect my nav's orange/white wire to it...and leave the wiring harnesses orange wire connected to nothing.

Go ahead and connect the orange/white wire from the nav's wiring harness to the orange wire from the wiring harness that plugs into the OEM wiring harness that is left after you uninstall the stock stereo. It will dim the screen when the headlights come on....but the dimmer dial on the left stick from the steering wheel will not do anything. This particular unit allows you to set different contrast, black level, and brightness when the lights are on/off.

I'll be connecting the Nav's light green wire labeled "parking sensor wire" to a screw to do the whole bypass thing.

You can ground this wire with the black grounding wire...or you can connect it to one of the 6 screws that you use to install your new navigation system (the same 6 you removed to take the old stereo out). Both should work. I grounded it with the black wire from my Nav into the black wire from the harness.

Thanks for any help.

Oh, and i recall reading that people attached their GPS antenna to the top of their HU without any reception issues? Am i mistaken? I'm bascially thinking of just sticking it on top of the mounting sleeve inside the dash...so i don't have to run any wires and what not.

I've read of several people doing this or putting it on a steel tube that sits under the clock pod. I went ahead and did the same and am having good signal strength (4 out of 5 bars) and no issues. The magnet on the antenna is pretty strong. I didn't ziptie it down or anything because it would have been a PITA to work in the small space that is the area behind the stereo. Make sure you attach the magnet left of center...because it will prevent you from being able to reinstall the cup holder if you put it center or to the right.

Last edited by swanjm5; 10-05-2010 at 11:57 AM.
swanjm5 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't figure out how to remove my viscous coupling mk2jettavr6 Transmission (AT/MT) & Driveline 3 01-15-2008 09:58 AM
Can't figure out how to install clutch clips noitseuq Transmission (AT/MT) & Driveline 1 02-25-2007 01:50 PM
Can't figure out how to calibrate tps ?? L80Killa87 UTEC 2 01-02-2007 08:12 AM
I Can't Figure Out How To....(n00b ? inside) binky Off-Topic 19 08-07-2004 06:01 PM
Help: Can't figure out how to install headlight bulb and harness back into headlight Gypsum2 Interior & Exterior Modification 2 07-29-2002 12:25 PM

All times are GMT -4. The time now is 07:25 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.