Welcome to the North American Subaru Impreza Owners Club Monday September 24, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-05-2011, 07:25 AM   #1
demid30
Scooby Newbie
 
Member#: 256620
Join Date: Sep 2010
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2014 WRX 4dr!!
Satin White Pearl

Default 2010 WRX Clutch problem?

I just want to start out by stating that I have been driving nothing but standard cars for 8 years. So I obviously know how to drive stick. No need for the BS remarks. OK, months ago around 6k miles I thought the clutch felt weird and told subaru when I went for that oil change. They said nothing was wrong with it but I don't know how closely they looked into it. It seemed like it wasn't catching right, to me something didn't feel right. Now I'm at almost 14k and it still feels like that. But recently if I accelerate all the way through 1st and 2nd into 3rd the clutch feels like its, I'm going to say grinding but theres no noise and its not the gears. More like rubbing when I push the clutch in or out. It will feel like this for a little while and then return to "normal" how it was before. Yesterday I was at a toll getting on the highway and accelerated through 1st n 2nd to about 4800rpm each. I felt the rubbing into 2nd and all the way to 5th. I thought the clutch was going to break on me. Down shifting off the highway after an hour it still was rubbing. But as soon as I was off the highway it stopped rubbing and seemed to be "normal." I've never done a launch in this car. Yes, sometimes I drive the car like its ment to be driven, but haven't even launched it to try it yet, because of possible problems. I tried searching to find it but I couldn't. Does anyone know what this is?? Its hard to explain but its far from normal.

Thanks
* Registered users of the site do not see these ads.
demid30 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-06-2011, 01:45 AM   #2
demid30
Scooby Newbie
 
Member#: 256620
Join Date: Sep 2010
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2014 WRX 4dr!!
Satin White Pearl

Default

Anyone? Any input??
demid30 is offline   Reply With Quote
Old 04-06-2011, 01:47 AM   #3
XanRules
Scooby Guru
 
Member#: 157348
Join Date: Aug 2007
Chapter/Region: NWIC
Location: Benghazi
Vehicle:
1996 JNCO Jorts
Stonewashed Denim

Default

Keep bugging the dealership.
XanRules is offline   Reply With Quote
Old 04-06-2011, 12:53 PM   #4
imprezaL2345
Scooby Specialist
 
Member#: 108188
Join Date: Feb 2006
Chapter/Region: MAIC
Location: VB yo.
Vehicle:
1993 Impreza L 1.8T
Lotus Storm Titanium

Default

Most likely a defect with the clutch assembly. It's not you its the car. In my 08, the clutch was worn down to the rivets and the flywheel scorned like it had 150k on it, despite having only 17k on it. They ended up replacing the assembly for free under warranty but it may not be that simple for you. Check out the warranty section of nasioc, you'll see you arent the first with this problem.
imprezaL2345 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WRX Clutch Problems ccook Warranty Issues & SOA Problems 15 03-14-2015 10:54 AM
2010 WRX Clutch issues. SWAGER Warranty Issues & SOA Problems 84 09-28-2010 06:57 PM
05 WRX tranny into 02 WRX...clutch problems? HeeroRaven Transmission (AT/MT) & Driveline 3 07-20-2006 03:26 PM
02 wrx clutch problems? wrxxed Warranty Issues & SOA Problems 1 03-10-2004 07:27 PM
wrx clutch problems morphgabbin Transmission (AT/MT) & Driveline 2 07-14-2002 08:18 PM

All times are GMT -4. The time now is 03:31 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.