Welcome to the North American Subaru Impreza Owners Club Friday January 19, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-21-2008, 05:15 PM   #1
White_Rice
Scooby Specialist
 
Member#: 160049
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage, AK
Question iDLE AND AFR ISSUES.

Ok basically my passenger side injector o-rings broke...I replaced them and now my car idles like ass and my idle afrs are anywhere between 16-18.lean lean lean.

Any thoughts?
* Registered users of the site do not see these ads.
White_Rice is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-21-2008, 05:56 PM   #2
Cocoa Beach Bum
Scooby Specialist
 
Member#: 17355
Join Date: Apr 2002
Default

No trouble codes?
Cocoa Beach Bum is offline   Reply With Quote
Old 08-21-2008, 06:22 PM   #3
White_Rice
Scooby Specialist
 
Member#: 160049
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage, AK
Default

yes but at this moment I do not have a reader...or a tactrix cable. til tonight.
White_Rice is offline   Reply With Quote
Old 08-21-2008, 06:47 PM   #4
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Bailey, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

did you get any debris in the injector?
yarrgh is offline   Reply With Quote
Old 08-21-2008, 07:01 PM   #5
MasterKwan
Scooby Guru
 
Member#: 98961
Join Date: Oct 2005
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2003 WRX
Black

Default

Forget to put the donut seals back in? Sounds like a vacuum leak. Get some gumcutter (Carb cleaner) and spray it at the base of the injectors, if your idle smooths out, you found your leak.
MasterKwan is offline   Reply With Quote
Old 10-07-2010, 10:53 AM   #6
Bizko1288
Scooby Newbie
 
Member#: 151260
Join Date: Jun 2007
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
2011 BMW 135i
__________

Default

Quote:
Originally Posted by MasterKwan View Post
Forget to put the donut seals back in? Sounds like a vacuum leak. Get some gumcutter (Carb cleaner) and spray it at the base of the injectors, if your idle smooths out, you found your leak.

Has anyone else tried/proven this method? I was unaware that a vacuum leak could occur around the injectors.

If anyone has some more insight please chime in......

Edit: After a search I found this : http://forums.nasioc.com/forums/show...=injector+leak


Great info on that thread.... thanks for the followup on the OPs part.
Bizko1288 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Modified '08 STI - AFR issue. Logs and chart squashman Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 6 03-16-2009 04:57 PM
Bad IDLE, Bad AFR, but no CELL. CyborgX_CZ Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 41 03-05-2009 02:19 PM
odd issue with idle and driving rigpin Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 10-24-2006 01:50 AM
odd issue with idle and driving 03 WRX rigpin South East Region Forum 10 10-15-2006 09:57 AM
idle issues and boost issues jdgrimm Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 07-05-2006 10:45 PM

All times are GMT -4. The time now is 08:25 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.