Welcome to the North American Subaru Impreza Owners Club Sunday December 16, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-25-2016, 03:37 AM   #26
TrickNipple
moon moon
Moderator
 
Member#: 86213
Join Date: May 2005
Chapter/Region: NWIC
Location: Wild wild Northwest
Default

Quote:
Originally Posted by Beastlydave5 View Post
I have a 2015 impreza. Thinking of getting a cold air intake just to give it a little bit of power. Just wondering if my car is turbo, so I can know what kind of intake to get. Would appreciate your guy's response.



* Registered users of the site do not see these ads.
TrickNipple is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-26-2016, 06:52 PM   #27
Invisible3mpire
Scooby Specialist
 
Member#: 373741
Join Date: Nov 2013
Chapter/Region: TXIC
Location: DFW
Vehicle:
2013 Impreza Hatch
ISM

Default

Quote:
Originally Posted by Beastlydave5 View Post
I have a 2015 impreza. Thinking of getting a cold air intake just to give it a little bit of power. Just wondering if my car is turbo, so I can know what kind of intake to get. Would appreciate your guy's response.
Inb4 the smartass comments...

No, your car does not have a turbo, and a CAI will not give you any significant gains -- in fact, you may actually lose hp unless you get the short ram intake from HPS that retains the factory air duct. For the most part, it'll just increase intake noise and deepen the exhaust note. That's about it, and trust me because I'm speaking from experience. Read this to see how other N/As went about their setup.

A tune would be a much better investment imo. Or if you do decide to get the intake, also get a dyno tune.
Invisible3mpire is online now   Reply With Quote
Old 10-06-2016, 06:46 PM   #28
Slowrx010
Scooby Newbie
 
Member#: 455975
Join Date: Oct 2016
Default

Quote:
Originally Posted by Nick View Post
We realized the categories in here were seriously lacking for cars since around 2004. So today I created prefixes to be used to identify the model year impreza you are talking about when you post your thread.

I have also moved all the threads that were in the two sub-forums back into this main forum.

Any threads that were in the '93-'01 forum were automatically assigned the proper prefix of ('93-'01). The threads in the other sub-forum could not be automatically assigned so they were just moved.

If one of those threads is you you should be able to edit the thread information and add a prefix, otherwise you can contact a moderator or myself and we'll be happy to add the proper prefix to your thread.

About using prefixes, they are now manadatory in this forum, so if you want to post a new thread in here you MUST chose the proper prefix. They are simply arranged by model year, so pick the right one. We've broken them down by MY/facelift, not just model code, since that wasn't specific enough.

The biggest upside to prefixes is that you can use them when using the search function to make your results significantly more accurate.
I'm not really understanding the prefix I'm a new bee on here what do mean by putting a prefix before you post?
Slowrx010 is offline   Reply With Quote
Old 10-29-2016, 10:17 PM   #29
DieselDorf
Scooby Newbie
 
Member#: 454773
Join Date: Sep 2016
Chapter/Region: MWSOC
Location: Traverse City, MI
Vehicle:
2012 Impreza Sport
Pearl White

Default

It would be much easier if each generation had its own sub forum IMO.

I would rather not sort through the prefixes to see things that are pertinent to me. Also not every post has a prefix so again it's annoying to have to look at each post individually to see if it is for my model year.

I've been on other forums that are set up this way and it makes things loads easier. And you can still search based on sub forum.

Also WRX should be separate.
DieselDorf is offline   Reply With Quote
Old 11-01-2016, 01:51 AM   #30
okimar
*** Banned ***
 
Member#: 453683
Join Date: Aug 2016
Default

Agreeing with the last post...

Can there be a new category created for the 2015+ STi/WRX now that they have been separated from the Impreza by Subaru and most of the parts are not compatible with previous years?
okimar is offline   Reply With Quote
Old 12-18-2016, 03:19 AM   #31
Alaskansubaru
Scooby Newbie
 
Member#: 459915
Join Date: Dec 2016
Default Help Help Help

Ok so last night my car threw a check engine light. I ran the codes the next day and it said my O2, cam positioning, mass air flow sensors all went off. As well as the air intake and air outtake sensors ( which I've never heard of). let it over night and now my lights are messed up as well. When the low beams are on you can kinda see that the high beams are too. but the normal low beams are really weak. So far I can def tell the cam positing went out, but I'm at a loss for the rest. Need some suggestions.
05 2.5rs.
Alaskansubaru is offline   Reply With Quote
Old 12-18-2016, 03:32 AM   #32
Alaskansubaru
Scooby Newbie
 
Member#: 459915
Join Date: Dec 2016
Default

really need some help. Tearing the whole engine harness down tomorrow and tracing some stuff. But any ideas would greatly help.
Alaskansubaru is offline   Reply With Quote
Old 12-18-2016, 02:04 PM   #33
drpoop
*** Banned ***
 
Member#: 421858
Join Date: May 2015
Vehicle:
2012 Impreza

Default

Definitely not the right place to ask that question, and you're missing TONS of details.
drpoop is offline   Reply With Quote
Old 02-17-2017, 08:18 AM   #34
mfowler
Scooby Newbie
 
Member#: 461620
Join Date: Jan 2017
Location: Littlestown, PA ( 7 miles sout
Vehicle:
2015 Impreza

Default

So what is the resolution? How are we to identify model years? I have no suggestions, just want the mods to state the plan, please.
mfowler is offline   Reply With Quote
Old 02-21-2017, 12:40 AM   #35
Stopbreakindown
Scooby Newbie
 
Member#: 454351
Join Date: Sep 2016
Default

Quote:
Originally Posted by DieselDorf View Post
It would be much easier if each generation had its own sub forum IMO.

I would rather not sort through the prefixes to see things that are pertinent to me. Also not every post has a prefix so again it's annoying to have to look at each post individually to see if it is for my model year.

I've been on other forums that are set up this way and it makes things loads easier. And you can still search based on sub forum.

Also WRX should be separate.

Makes everything better this way
Stopbreakindown is offline   Reply With Quote
Old 05-01-2017, 11:01 AM   #36
Joshpeachey
Scooby Newbie
 
Member#: 466890
Join Date: May 2017
Default 2002 subaru

Hi guys, I'm new to the forum so I can't start a thread yet. Sorry if I'm kind of hijacking this one. I'm looking at buying a 2002 wrx with 244000 miles, the body and interior are in good condition and according to the owner it runs great. Is it worth 2500?
Joshpeachey is offline   Reply With Quote
Old 05-21-2017, 08:07 AM   #37
FLAX879
Scooby Newbie
 
Member#: 468029
Join Date: May 2017
Default 02 impreza wagon....bugeye

2002 impreza wagon bugeye( not a wrx or sti model)
Located Australia.
hi just wondering if there is any decent FULL BODY KITs to make my wag look tough an staunch. Been looking for days its very hard finding bumpers ect. i really like liberal kit but it hard to actualyl find for wagon. its like theres no kits fpr the wagons
any help would do . cheers an thank u
FLAX879 is offline   Reply With Quote
Old 07-08-2017, 07:47 PM   #38
Phrogpilot
Scooby Newbie
 
Member#: 470620
Join Date: Jul 2017
Default

Looking to buy a 2012 STI with 72k miles as a daily driver and to drive from Florida to Pennsylvania about once a month. Any thoughts on putting high miles on an STI vers the "normal" WRX model?
Phrogpilot is offline   Reply With Quote
Old 09-28-2017, 01:35 AM   #39
brannigan
NASIOC Supporter
 
Member#: 463783
Join Date: Mar 2017
Chapter/Region: SWIC
Vehicle:
2000 Outback sport
Silver

Default

Quote:
Originally Posted by Stopbreakindown View Post
Makes everything better this way
Agreed!
brannigan is offline   Reply With Quote
Old 10-13-2017, 10:26 PM   #40
brannigan
NASIOC Supporter
 
Member#: 463783
Join Date: Mar 2017
Chapter/Region: SWIC
Vehicle:
2000 Outback sport
Silver

Default

This is a seriously unattended thread. Moderators please help.
brannigan is offline   Reply With Quote
Old 10-13-2017, 10:33 PM   #41
brannigan
NASIOC Supporter
 
Member#: 463783
Join Date: Mar 2017
Chapter/Region: SWIC
Vehicle:
2000 Outback sport
Silver

Default

Quote:
Originally Posted by brannigan View Post
Agreed!
He posted great ideas about this forum restructure.
brannigan is offline   Reply With Quote
Old 11-03-2017, 02:08 AM   #42
Stillblobeye
Scooby Newbie
 
Member#: 477105
Join Date: Nov 2017
Default

Quote:
Originally Posted by toddwilliams View Post
I have a 97 subaru and it will run fine and then it starts to run really rich, now I have a po1104, and a po441 codes. Also I just put 175 miles on 1 tank of gas. Can anyone help
Hey my advise will be. Make sure you've done your spark plugs. Make sure your gas tank cap is working properly. Make sure your intake system and other hoses are on properly and not damaged so you don't have any vacuum leaks, usually you can hear suction. Try cleaning your MASS AIR FLOW sensor which is by the engine air filter, and use the correct cleaner and instructions.
Stillblobeye is offline   Reply With Quote
Old 12-01-2017, 06:37 PM   #43
lymphomaniac
Scooby Specialist
 
Member#: 334451
Join Date: Oct 2012
Chapter/Region: VIC
Location: YVR
Vehicle:
2018 WRX Sport CVT
CBS

Default

Quote:
Originally Posted by Nick View Post
We realized the categories in here were seriously lacking for cars since around 2004. So today I created prefixes to be used to identify the model year impreza you are talking about when you post your thread.

I have also moved all the threads that were in the two sub-forums back into this main forum.

Any threads that were in the '93-'01 forum were automatically assigned the proper prefix of ('93-'01). The threads in the other sub-forum could not be automatically assigned so they were just moved.

If one of those threads is you you should be able to edit the thread information and add a prefix, otherwise you can contact a moderator or myself and we'll be happy to add the proper prefix to your thread.

About using prefixes, they are now manadatory in this forum, so if you want to post a new thread in here you MUST chose the proper prefix. They are simply arranged by model year, so pick the right one. We've broken them down by MY/facelift, not just model code, since that wasn't specific enough.

The biggest upside to prefixes is that you can use them when using the search function to make your results significantly more accurate.
I know this thread was created 7+ years ago, but when you have posts like the ones below spanning the past 7+ years calling for action, it's a little disappointing to see that the thread has reached a state of dereliction and that the sub-forum is still a steaming puddle of regurgitated dinner - lacking coherence or any semblance of order.

And some of these calls for action actually have good suggestions, too!

Quote:
Originally Posted by mike2100 View Post
What's the deal with the 11+ prefix? The new Impreza is 2012
Quote:
Originally Posted by KC View Post
Can we do something for us XV folk?

--kC
Quote:
Originally Posted by AWDfreak View Post
Okay, with two requests regarding the fourth generation Impreza, I would have expected some change to have been made...

Instead of model-year nomenclature, I think it would be SO MUCH EASIER if chassis designations were indicated, as the WRX and WRX STI (based off of the 3rd generation Impreza) overlap with the production of the 4th generation Impreza.

Model years 2012 to 2014 is where the huge confusion begins, as both WRX/WRX STI (3rd gen) and 4th gen Impreza (including the GP chassis Subaru XV "Crosstrek") are produced at the same time.

Unless changes are implemented soon, things are going to get more confusing. Please make a change to it so that those looking for information regarding the GJ/GP (4th gen) Impreza won't be mixing up information with GR/GV (3rd gen WRX/WRX STI sedan and hatch)...





And for clarification:



3rd generation Impreza chassis:

GE = Impreza sedan, non-widebody

GH = Impreza hatch, non-widebody

GR = Impreza WRX (from 2011-2014), Impreza WRX STI (all years), widebody hatch

GV = Impreza WRX (from 2011-2014), Impreza WRX STI (2011-2014), widebody sedan



4th generation Impreza chassis:
GJ = Impreza sedan
GP = Impreza hatch, includes XV Crosstrek
WRX and WRX STI are yet to be released in 4th generation form
Quote:
Originally Posted by sub06tr View Post
Maybe now we can have 2015 page?
Quote:
Originally Posted by 2014subaruwrx View Post
Now that the 2015 WRX and STI are out they are NOT called Impreza anymore, so can you please add a new forum called 2015 WRX and 2015 STI?


Sent from my iPad using NASIOC
Quote:
Originally Posted by HuRRiC4Ne View Post
I agree... We need an WRX Section that's separate from Impreza.
Quote:
Originally Posted by DieselDorf View Post
It would be much easier if each generation had its own sub forum IMO.

I would rather not sort through the prefixes to see things that are pertinent to me. Also not every post has a prefix so again it's annoying to have to look at each post individually to see if it is for my model year.

I've been on other forums that are set up this way and it makes things loads easier. And you can still search based on sub forum.

Also WRX should be separate.
Quote:
Originally Posted by mfowler View Post
So what is the resolution? How are we to identify model years? I have no suggestions, just want the mods to state the plan, please.
Quote:
Originally Posted by brannigan View Post
This is a seriously unattended thread. Moderators please help.
lymphomaniac is offline   Reply With Quote
Old 02-26-2018, 11:33 PM   #44
msprink
Scooby Newbie
 
Member#: 478913
Join Date: Dec 2017
Chapter/Region: South East
Location: Chattanooga, TN
Vehicle:
2018 WRX STI
DGM

Default

So when do we get a 2015+ WRX/STI forum?
msprink is offline   Reply With Quote
Old 04-08-2018, 10:35 PM   #45
Bermenderfer
Scooby Newbie
 
Member#: 484377
Join Date: Apr 2018
Vehicle:
2014 STI hatchback
Black

Default

Any common issues with GR hatchbacks?
Bermenderfer is offline   Reply With Quote
Old 06-04-2018, 07:15 PM   #46
mindykid
Scooby Newbie
 
Member#: 486807
Join Date: Jun 2018
Default

Quote:
Originally Posted by SubaruGoob View Post
So i have a 1998 OBS wagon, 5 spd, and it has 168k on it.

when I pushing in my clutch i can hear the motor and it sounds clear and beautiful when i let out the clutch i start to hear a chatter in the engine bay/clutch area. any ideas at all to what i could be?

i've asked a couple different mechanics and gotten different answers but i don't know which one said my pilot bearing in my transmission, and another said the last guy who did my clutch on 7/6/2012 installed the clutch plate backwards...

so idk but i don't wanna spend ungodly amounts of money on a tranny rebuild if all i need to do is get the clutch fixed thank you very much.
Does it make the noise while you are driving as well?
mindykid is offline   Reply With Quote
Old 06-19-2018, 08:54 PM   #47
Justfasthd24
Scooby Newbie
 
Member#: 487119
Join Date: Jun 2018
Location: North Jersey
Vehicle:
2011 Impreza WRX
Dark Grey Metallic

Default

I have a 2011 wrx with a cracked block so I plan on purchasing a complete engine and turbo. Will this motor be plug and play for the most part?
Justfasthd24 is offline   Reply With Quote
Old 09-03-2018, 03:08 PM   #48
cosmictruthguru
Scooby Newbie
 
Member#: 490990
Join Date: Sep 2018
Default Sounds good.

Thanks!
cosmictruthguru is offline   Reply With Quote
Old 09-28-2018, 07:21 PM   #49
Abdon9110
Scooby Newbie
 
Member#: 492055
Join Date: Sep 2018
Default Brake problems

I have a 2005 Subaru Impreza rs I replaced all rotors to crossed drill slotted disks and I changed all calipers they are brand new and they are red I had to change the front calipers to a wrx caliper because my regular ones didnít fit on the rotor after putting those parts my car wonít brake now I bled them in the correct order I put my car on the lift put it in 1st gear and tried to activate the abs but I still have no breaks I bled my brakes 5 times and nothing
Abdon9110 is offline   Reply With Quote
Old 11-15-2018, 04:49 PM   #50
jarkko90
Scooby Newbie
 
Member#: 494083
Join Date: Nov 2018
Default Subaru Impreza wrx 2001

Sorry my bad english
I have new age impreza wrx wagon and its us model i think its bug eye
Do anybody know does it works Cobb acces port v3 ?
Some dealers says that isisnt work because my car is 2001 and wrx only be in us 2002. I know its us model and its same 2002 ? Try to learn english 😂
jarkko90 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Impreza Forums have been moved... Nick General Community 0 09-16-2003 08:47 PM
Mk1/original Impreza forums? Tyrmeltr General Forum Archive 9 03-24-2001 01:15 AM

All times are GMT -4. The time now is 07:14 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.