Welcome to the North American Subaru Impreza Owners Club Wednesday February 26, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 02-06-2020, 08:34 PM   #1
edsuusde
Scooby Newbie
 
Member#: 479436
Join Date: Dec 2017
Chapter/Region: VIC
Location: Vancouver BC
Vehicle:
2012 STi HB
White

Default Rattling/creaking noise when going over bumpy road or going over bump unevenly.

I searched most of the posts already, didn't exactly find anything that matches my case. I am sorry if I post this to the wrong forum.

My 12 STI hatchback is pretty much stock. It only has the cobb intake and kartboy shifter and bushings.

The noise happen in the following scenarios:

1. when i go over speed bump unevenly at low speed (like left wheel goes on first, then right wheel. Rear left, then rear right). Every time i hear the creaking/squeaking (like the old mattress springs noise). The noise does NOT happen When both wheels go on the speed bump at the same time.

2. It also happen when I drive over bumpy road.

3. After driving like 20 minutes (after work), and turning the engine off, i can hear some rattling (or similar to the noise from #1) 0.5-1 second after the engine completely stop. To me, it feels like exhaust heat shield rattle, but i checked the heat shield from the down pipe already, it's tight. I also checked the exhaust manifold heat shield, it's also tight.) I am not sure if this is the same noise in #1, but it sounds like they are same to me.

the noise does NOT happen at all in normal driving on smooth enough road, accelerating, breaking, changing gears, cornering.

Could you please throw me some ideas? I really appreciate for all the help in advance.
* Registered users of the site do not see these ads.

Last edited by edsuusde; 02-07-2020 at 01:37 PM.
edsuusde is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-07-2020, 11:19 AM   #2
shadowsports
Scooby Newbie
 
Member#: 446364
Join Date: May 2016
Chapter/Region: BAIC
Location: Nor Cal
Vehicle:
'17 STI LMT '08 LGT
DGM / QSM

Default

Greetings,
Tell us more about your suspension. When was the last time you changed your struts/shocks? What condition are your undercarriage bushing in? All if these things work together.
shadowsports is offline   Reply With Quote
Old 02-07-2020, 01:27 PM   #3
edsuusde
Scooby Newbie
 
Member#: 479436
Join Date: Dec 2017
Chapter/Region: VIC
Location: Vancouver BC
Vehicle:
2012 STi HB
White

Default

Stock suspension, never touched them. I am not sure what undercarriage bushing condition is, I never touched them either. They are all stock.
edsuusde is offline   Reply With Quote
Old 02-07-2020, 03:11 PM   #4
AgentScarn
Scooby Newbie
 
Member#: 477230
Join Date: Nov 2017
Location: San Diego, CA
Vehicle:
2007 Impreza WRX STI
UGM

Default

Maybe your strut/shocks, sway bar bushings?
AgentScarn is offline   Reply With Quote
Old 02-07-2020, 05:56 PM   #5
edsuusde
Scooby Newbie
 
Member#: 479436
Join Date: Dec 2017
Chapter/Region: VIC
Location: Vancouver BC
Vehicle:
2012 STi HB
White

Default

I checked the sway bar bushing, and endlinks, they are tight.
If swaybar bushing or endlinks, it should make noise when both wheels get on speed bump at the same time. But mine doesn't, it only happen when you go over the bump at an angle (like going over the bump one wheel at a time)

what do i need to check on the struts?

Last edited by edsuusde; 02-07-2020 at 06:20 PM.
edsuusde is offline   Reply With Quote
Old 02-07-2020, 06:46 PM   #6
AgentScarn
Scooby Newbie
 
Member#: 477230
Join Date: Nov 2017
Location: San Diego, CA
Vehicle:
2007 Impreza WRX STI
UGM

Default

Your sway bar bushing may be secure, but they need to be re-greased from time to time. I'm not sure how you would be able to check your struts. Mine would make a loud clunking sound over harsh bumps.
AgentScarn is offline   Reply With Quote
Old 02-11-2020, 05:40 PM   #7
edsuusde
Scooby Newbie
 
Member#: 479436
Join Date: Dec 2017
Chapter/Region: VIC
Location: Vancouver BC
Vehicle:
2012 STi HB
White

Default

if to re-grease the swaybar bushing, should i take them off and re-grease? I did try to spray some WD40 on them. It didn't help.
edsuusde is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:06 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.