Welcome to the North American Subaru Impreza Owners Club Thursday August 24, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-19-2017, 11:20 AM   #4801
Ramone179
Scooby Newbie
 
Member#: 466281
Join Date: Apr 2017
Default


Looks like a cologne ad.
* Registered users of the site do not see these ads.
Ramone179 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-19-2017, 11:31 AM   #4802
crispy2
Scooby Specialist
 
Member#: 405024
Join Date: Oct 2014
Chapter/Region: NESIC
Location: Boston, MA
Vehicle:
'15 WRX Limited
World Rally Blue

Default

Quote:
Originally Posted by Ramone179 View Post

Looks like a cologne ad.


White and black.
Fast and controlled.

- Rex -

The new performance fragrance by Subaru.
crispy2 is offline   Reply With Quote
Old 08-19-2017, 01:33 PM   #4803
olsen2420
Scooby Newbie
 
Member#: 229994
Join Date: Nov 2009
Default

olsen2420 is offline   Reply With Quote
Old 08-19-2017, 01:38 PM   #4804
Mikester
Scooby Newbie
 
Member#: 404043
Join Date: Oct 2014
Chapter/Region: NESIC
Location: Auburn, Mass
Vehicle:
2017 WRX Limited
Blue

Default

Quote:
Originally Posted by olsen2420 View Post


I love this. Where in CT are you ?
Mikester is offline   Reply With Quote
Old 08-19-2017, 02:01 PM   #4805
olsen2420
Scooby Newbie
 
Member#: 229994
Join Date: Nov 2009
Default

I'm in Manchester area, drove by this place this morning and figured I'd pull in for a few shots with the iPhone





olsen2420 is offline   Reply With Quote
Old 08-19-2017, 02:15 PM   #4806
Mikester
Scooby Newbie
 
Member#: 404043
Join Date: Oct 2014
Chapter/Region: NESIC
Location: Auburn, Mass
Vehicle:
2017 WRX Limited
Blue

Default

Quote:
Originally Posted by olsen2420 View Post
I'm in Manchester area, drove by this place this morning and figured I'd pull in for a few shots with the iPhone







Awesome pics. Your bumper paint looks mint. How long have you had it? Mine's got a lot of pits on the bumper from road debris and such after one year. Gonna try to buff them out.
Mikester is offline   Reply With Quote
Old 08-19-2017, 02:22 PM   #4807
olsen2420
Scooby Newbie
 
Member#: 229994
Join Date: Nov 2009
Default

I've had it since early may, I avoid the highway on the way to work to help with the chipping. Overall only have a few marks here and there. I would have done clear film but I don't plan on keeping it more than three years, especially since 2020/21 should be any entirely different STI finally


Last edited by olsen2420; 08-19-2017 at 02:29 PM.
olsen2420 is offline   Reply With Quote
Old 08-19-2017, 02:50 PM   #4808
Mikester
Scooby Newbie
 
Member#: 404043
Join Date: Oct 2014
Chapter/Region: NESIC
Location: Auburn, Mass
Vehicle:
2017 WRX Limited
Blue

Default

Quote:
Originally Posted by olsen2420 View Post
I've had it since early may, I avoid the highway on the way to work to help with the chipping. Overall only have a few marks here and there. I would have done clear film but I don't plan on keeping it more than three years, especially since 2020/21 should be any entirely different STI finally



I hear ya. I will definitely be interested in upgrading to the STI for the next generation as long as they update the engine and hopefully soften the suspension a bit. Have a clear bra on my WRX right now, but only on the front quarter of the hood. My bumper gets a lot of highway abuse. Keep the car looking good! I'm in Worcester area. Give a shout out if you are ever in the area.
Mikester is offline   Reply With Quote
Old 08-20-2017, 01:32 AM   #4809
dichoi
Scooby Newbie
 
Member#: 439085
Join Date: Jan 2016
Default

Shot with a buddy
dichoi is offline   Reply With Quote
Old 08-21-2017, 08:23 AM   #4810
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: Bucks County, PA
Vehicle:
2016 WRX Premium
Ice Silver Metallic

Default

Over the weekend I had my STi headlights opened, cleaned and resealed with Morimoto butyl sealant. While they were open, I had the projector bezel and the high beam bowl painted gloss black.

Unfortunately, the whole point of having them opened and resealed was because of a worsening condensation issue. I don't doubt the abilities of the installer, considering his experience and the other work he's done. But the worse of my two lights, the driver's side, has condensation again this morning after a humid night with no rain. Albeit very slight condensation.

It's extremely frustrating after spending so much just to get these headlights, then even more to have them opened and resealed. I've run out of ideas as to what the cause could be. At this point I don't think it has anything to do with the sealant. Maybe the lens has an invisible hairline crack, or maybe there's an issue with the vent that I couldn't seem to find.

But hey at least my lights look cool when they're clear.

20170820-IMG_0662 by Tyler McGowan, on Flickr
20170820-IMG_0664 by Tyler McGowan, on Flickr
Obviously Tyler is offline   Reply With Quote
Old 08-21-2017, 08:34 AM   #4811
Mikester
Scooby Newbie
 
Member#: 404043
Join Date: Oct 2014
Chapter/Region: NESIC
Location: Auburn, Mass
Vehicle:
2017 WRX Limited
Blue

Default

Quote:
Originally Posted by Obviously Tyler View Post
Over the weekend I had my STi headlights opened, cleaned and resealed with Morimoto butyl sealant. While they were open, I had the projector bezel and the high beam bowl painted gloss black.



Unfortunately, the whole point of having them opened and resealed was because of a worsening condensation issue. I don't doubt the abilities of the installer, considering his experience and the other work he's done. But the worse of my two lights, the driver's side, has condensation again this morning after a humid night with no rain. Albeit very slight condensation.



It's extremely frustrating after spending so much just to get these headlights, then even more to have them opened and resealed. I've run out of ideas as to what the cause could be. At this point I don't think it has anything to do with the sealant. Maybe the lens has an invisible hairline crack, or maybe there's an issue with the vent that I couldn't seem to find.



But hey at least my lights look cool when they're clear.



20170820-IMG_0662 by Tyler McGowan, on Flickr

20170820-IMG_0664 by Tyler McGowan, on Flickr


Lookin really good!
I hope the condensation stays away. They look mint in those pics.
Mikester is offline   Reply With Quote
Old 08-21-2017, 08:37 AM   #4812
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: Bucks County, PA
Vehicle:
2016 WRX Premium
Ice Silver Metallic

Default

Quote:
Originally Posted by Mikester View Post
Lookin really good!
I hope the condensation stays away. They look mint in those pics.
Thanks, appreciate it.

Just had a thought that maybe the new butyl sealant needs a few days to settle and harden to create a proper seal. But, if that were the case I feel my passenger side light should also have a bit of condensation. It's bone dry. Who knows.
Obviously Tyler is offline   Reply With Quote
Old 08-21-2017, 08:41 AM   #4813
SpeedHoles
Scooby Newbie
 
Member#: 339900
Join Date: Dec 2012
Location: Mitten
Default

Should have hidden a dessicant pack in the headlights.
SpeedHoles is offline   Reply With Quote
Old 08-21-2017, 08:46 AM   #4814
Mikester
Scooby Newbie
 
Member#: 404043
Join Date: Oct 2014
Chapter/Region: NESIC
Location: Auburn, Mass
Vehicle:
2017 WRX Limited
Blue

Default

Quote:
Originally Posted by Obviously Tyler View Post
Thanks, appreciate it.



Just had a thought that maybe the new butyl sealant needs a few days to settle and harden to create a proper seal. But, if that were the case I feel my passenger side light should also have a bit of condensation. It's bone dry. Who knows.


That definitely sounds like a mystery. I know if it were me the slightest amount of condensation in the headlight would bug the hell out of me. Keep us posted! Hope it works out for you !
Mikester is offline   Reply With Quote
Old 08-21-2017, 09:53 AM   #4815
ATMINSIDE
Scooby Newbie
 
Member#: 455092
Join Date: Sep 2016
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
2015 WRX Limited 6MT
ISM

Default

How's the high beam light output with the reflector painted black?
ATMINSIDE is offline   Reply With Quote
Old 08-21-2017, 10:13 AM   #4816
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: Bucks County, PA
Vehicle:
2016 WRX Premium
Ice Silver Metallic

Default

Quote:
Originally Posted by ATMINSIDE View Post
How's the high beam light output with the reflector painted black?
Haven't tried yet but my guess would be that it's usable but not as good as the chrome.

My high beam DRLs are unplugged because I have the Subispeed fog bezel DRLs installed. And I rarely need to use my high beams. But if the output is bad I'll look into getting a brighter bulb.
Obviously Tyler is offline   Reply With Quote
Old 08-21-2017, 11:43 AM   #4817
ATMINSIDE
Scooby Newbie
 
Member#: 455092
Join Date: Sep 2016
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
2015 WRX Limited 6MT
ISM

Default

That's what I was thinking as well
ATMINSIDE is offline   Reply With Quote
Old 08-21-2017, 01:17 PM   #4818
Infinite0180
Scooby Newbie
 
Member#: 410716
Join Date: Jan 2015
Location: Buffalo NY
Vehicle:
2016 WRX
CBS

Default

Quote:
Originally Posted by Obviously Tyler View Post
Over the weekend I had my STi headlights opened, cleaned and resealed with Morimoto butyl sealant. While they were open, I had the projector bezel and the high beam bowl painted gloss black.



Unfortunately, the whole point of having them opened and resealed was because of a worsening condensation issue. I don't doubt the abilities of the installer, considering his experience and the other work he's done. But the worse of my two lights, the driver's side, has condensation again this morning after a humid night with no rain. Albeit very slight condensation.



It's extremely frustrating after spending so much just to get these headlights, then even more to have them opened and resealed. I've run out of ideas as to what the cause could be. At this point I don't think it has anything to do with the sealant. Maybe the lens has an invisible hairline crack, or maybe there's an issue with the vent that I couldn't seem to find.



But hey at least my lights look cool when they're clear.



20170820-IMG_0662 by Tyler McGowan, on Flickr

20170820-IMG_0664 by Tyler McGowan, on Flickr


Try pulling out the high beam bulb and leaving the hood open for a hour or two in the sun. Sometimes humid air is trapped inside and it just needs to come to equilibrium with the air outside... then throw the bulb back in and see what happens. Worth a shot...
Infinite0180 is offline   Reply With Quote
Old 08-21-2017, 02:12 PM   #4819
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: Bucks County, PA
Vehicle:
2016 WRX Premium
Ice Silver Metallic

Default

Quote:
Originally Posted by Infinite0180 View Post
Try pulling out the high beam bulb and leaving the hood open for a hour or two in the sun. Sometimes humid air is trapped inside and it just needs to come to equilibrium with the air outside... then throw the bulb back in and see what happens. Worth a shot...
Thanks, I'll keep that in mind.

Since it's warmed up a bit outside now it's about 99% cleared up. I'm gonna wait it out for a few days before trying anything or contacting the guy who did the work for me.
Obviously Tyler is offline   Reply With Quote
Old 08-22-2017, 01:39 AM   #4820
mflip
Scooby Newbie
 
Member#: 445183
Join Date: Apr 2016
Default

[/quote]

I love this
mflip is online now   Reply With Quote
Old 08-22-2017, 03:35 PM   #4821
namr0n
Scooby Newbie
 
Member#: 452695
Join Date: Aug 2016
Chapter/Region: BAIC
Location: San Francisco, CA
Vehicle:
2017 WRX Limited
DGM

Default

Quote:
Originally Posted by Obviously Tyler View Post
Over the weekend I had my STi headlights opened, cleaned and resealed with Morimoto butyl sealant. While they were open, I had the projector bezel and the high beam bowl painted gloss black.

Unfortunately, the whole point of having them opened and resealed was because of a worsening condensation issue. I don't doubt the abilities of the installer, considering his experience and the other work he's done. But the worse of my two lights, the driver's side, has condensation again this morning after a humid night with no rain. Albeit very slight condensation.

It's extremely frustrating after spending so much just to get these headlights, then even more to have them opened and resealed. I've run out of ideas as to what the cause could be. At this point I don't think it has anything to do with the sealant. Maybe the lens has an invisible hairline crack, or maybe there's an issue with the vent that I couldn't seem to find.

But hey at least my lights look cool when they're clear.
please keep us (me) posted! i've run across the same issue with my passenger side. i've even resealed it and all, and the condensation keeps coming back.
namr0n is offline   Reply With Quote
Old 08-22-2017, 06:25 PM   #4822
o2_designs
Scooby Newbie
 
Member#: 434977
Join Date: Nov 2015
Default

Quote:
Originally Posted by Obviously Tyler View Post
Haven't tried yet but my guess would be that it's usable but not as good as the chrome.

My high beam DRLs are unplugged because I have the Subispeed fog bezel DRLs installed. And I rarely need to use my high beams. But if the output is bad I'll look into getting a brighter bulb.

I painted my highbeam and LED buckets black chrome to help w/ light output, so they would still have some reflection. I was concerned w/ the high beam bulb burning the paint so I picked up black JDM AStar LED high beam bulbs.

The light output is ok. Not as good as OEM bulb/setup. But its bright enough to tell when they are on and brightens the corner of the road. I do 95% of my driving in town, so i rarely use high beams.

Just a thought, was'nt sure if you had any concerns about the bulb burning the paint.
o2_designs is offline   Reply With Quote
Old Yesterday, 09:01 AM   #4823
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: Bucks County, PA
Vehicle:
2016 WRX Premium
Ice Silver Metallic

Default

Quote:
Originally Posted by namr0n View Post
please keep us (me) posted! i've run across the same issue with my passenger side. i've even resealed it and all, and the condensation keeps coming back.
I will. But I'll likely post any updates and fixes in the appropriate thread under Electrical so I'm not going off-topic in this thread.

I plan on taking the light back to the guy this Saturday morning and we're both gonna try to diagnose and hopefully fix the issue. As of right now, the light appears to just have a very thin film on the inside. It almost looks like a chemical residue. It's hard for me to even call it condensation but had it been something used to clean the inside, I feel the passenger side would have the same issue(s), but it's clear and dry. Compared to what it looked like before the fix which was actual water droplets and pooling on the front face of the lens. This haziness is just on the side covering the amber marker and some of the C-light.

Quote:
Originally Posted by o2_designs View Post
I painted my highbeam and LED buckets black chrome to help w/ light output, so they would still have some reflection. I was concerned w/ the high beam bulb burning the paint so I picked up black JDM AStar LED high beam bulbs.

The light output is ok. Not as good as OEM bulb/setup. But its bright enough to tell when they are on and brightens the corner of the road. I do 95% of my driving in town, so i rarely use high beams.

Just a thought, was'nt sure if you had any concerns about the bulb burning the paint.
Thanks for the input. I'm honestly not sure if a black chrome was used or just a regular gloss black paint specific to this application.

I didn't think about the heat being an issue with the paint other than the first few days after they were done, he told me not to worry about it. I also rarely use my high beams, and my high beam DRLs are unplugged. So the bulbs themselves are just never on basically. I'll likely pick up JDM Astar high beam bulbs, I'm running their fog lights right now and I'm pretty happy with them.
Obviously Tyler is offline   Reply With Quote
Old Yesterday, 01:53 PM   #4824
o2_designs
Scooby Newbie
 
Member#: 434977
Join Date: Nov 2015
Default

Quote:
Originally Posted by Obviously Tyler View Post
I will. But I'll likely post any updates and fixes in the appropriate thread under Electrical so I'm not going off-topic in this thread.

I plan on taking the light back to the guy this Saturday morning and we're both gonna try to diagnose and hopefully fix the issue. As of right now, the light appears to just have a very thin film on the inside. It almost looks like a chemical residue. It's hard for me to even call it condensation but had it been something used to clean the inside, I feel the passenger side would have the same issue(s), but it's clear and dry. Compared to what it looked like before the fix which was actual water droplets and pooling on the front face of the lens. This haziness is just on the side covering the amber marker and some of the C-light.



Thanks for the input. I'm honestly not sure if a black chrome was used or just a regular gloss black paint specific to this application.

I didn't think about the heat being an issue with the paint other than the first few days after they were done, he told me not to worry about it. I also rarely use my high beams, and my high beam DRLs are unplugged. So the bulbs themselves are just never on basically. I'll likely pick up JDM Astar high beam bulbs, I'm running their fog lights right now and I'm pretty happy with them.
Same here, I'm running a DRL harness for the DiodeDynamic CLight, so my high beams are never on.
I like the JDM Astar since the 'bulb' is black, added bonus
o2_designs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.