Welcome to the North American Subaru Impreza Owners Club Thursday November 15, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-18-2018, 10:37 AM   #1
theevbo
Scooby Newbie
 
Member#: 485290
Join Date: Apr 2018
Location: Greensboro, NC
Vehicle:
2011 WRX
WRB

Default Aftermarket HID headlights issue

Hey guys,
I purchased a 2011 WRX a few months back and the previous owner had installed some sort aftermarket HID headlight kit. I’m not super familiar with these kits but it looks like the stock projector housings with HID bulbs. Drivers side went out yesterday and when I pulled off the rear cap it looks like the wires have been spliced together.

I’ve never been very happy with the light output, probably the worst of any car I’ve ever had. Returning to stock is perfectly acceptable but I worry that since things have been cut and spliced I might run into some issues.

What are the options on replacing these? Any advice appreciated.

https://ibb.co/kuigO0
https://ibb.co/gfrCVf
https://ibb.co/etb1O0
https://ibb.co/fpweAf
* Registered users of the site do not see these ads.

Last edited by theevbo; 10-18-2018 at 02:18 PM. Reason: photos
theevbo is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-18-2018, 02:46 PM   #2
theevbo
Scooby Newbie
 
Member#: 485290
Join Date: Apr 2018
Location: Greensboro, NC
Vehicle:
2011 WRX
WRB

Default

Upon further digging and pulling things aside it looks like there are two plugs that attach further down stream, so to speak. So I reckon they're not actually spliced after all. All I may need are H11 replacement HID kit bulbs. Yes?
theevbo is offline   Reply With Quote
Old 10-18-2018, 03:15 PM   #3
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: Bucks County, PA
Vehicle:
2016 WRX
2018 Crosstrek

Default

If you want to avoid problems with HID bulbs, you should go back to the stock halogen.

Or try LED bulbs, good ones. Less messy and less heat.
Obviously Tyler is offline   Reply With Quote
Old 10-18-2018, 03:40 PM   #4
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Quote:
Originally Posted by Obviously Tyler View Post
If you want to avoid problems with HID bulbs, you should go back to the stock halogen.

Or try LED bulbs, good ones. Less messy and less heat.
Option 1. Toss the HIDs and put the proper halogen bulbs in, done.
Corollary to Option 1- Instead of H11's, install a set of H9's for a true lighting upgrade without the downside of aftermarket HID's.
https://forums.nasioc.com/forums/sho....php?t=2083911
Mulder is offline   Reply With Quote
Old 10-18-2018, 07:57 PM   #5
theevbo
Scooby Newbie
 
Member#: 485290
Join Date: Apr 2018
Location: Greensboro, NC
Vehicle:
2011 WRX
WRB

Default

Quote:
Originally Posted by Mulder View Post
Option 1. Toss the HIDs and put the proper halogen bulbs in, done.

Corollary to Option 1- Instead of H11's, install a set of H9's for a true lighting upgrade without the downside of aftermarket HID's.

https://forums.nasioc.com/forums/sho....php?t=2083911


Is it that easy to just revert to stock? That would be my preference.
theevbo is offline   Reply With Quote
Old 10-18-2018, 08:34 PM   #6
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Quote:
Originally Posted by theevbo View Post
Is it that easy to just revert to stock? That would be my preference.
It depends whether the factory harnesses and connectors are intact and not hacked up. If they are ok you should be able to just unplug the HID's and plug in the halogens. If they're chopped up you'd need to get replacement H11 connectors and properly splice them onto the harnesses. Wiring/electrical not your thing? Find a good local shop and have them do it the right way.

The use of wire nuts on that installation is horrific.
Mulder is offline   Reply With Quote
Old 10-19-2018, 11:03 AM   #7
CRAZYHAWK
Scooby Specialist
 
Member#: 198067
Join Date: Dec 2008
Chapter/Region: Tri-State
Location: RAMSEY, NJ
Vehicle:
2009 IMPREZA 2.5i 4d
WHITE Premium

Default

On my 2009 Impreza, I used an HID kit without problems.
35 watt 4300K H11

http://www.ddmtuning.com/Products/DD...ast-35W-or-55W

$50.51 with shipping
CRAZYHAWK is online now   Reply With Quote
Old 10-20-2018, 06:39 AM   #8
theevbo
Scooby Newbie
 
Member#: 485290
Join Date: Apr 2018
Location: Greensboro, NC
Vehicle:
2011 WRX
WRB

Default

Quote:
Originally Posted by Mulder View Post
It depends whether the factory harnesses and connectors are intact and not hacked up. If they are ok you should be able to just unplug the HID's and plug in the halogens. If they're chopped up you'd need to get replacement H11 connectors and properly splice them onto the harnesses. Wiring/electrical not your thing? Find a good local shop and have them do it the right way.

The use of wire nuts on that installation is horrific.


Looks as if the factory harnesses are no longer there. Iíve got a set of hid bulbs coming tomorrow as a interim fix until I can get them rewired back to stock. Thanks for the advice.
theevbo is offline   Reply With Quote
Old 10-20-2018, 12:28 PM   #9
CRAZYHAWK
Scooby Specialist
 
Member#: 198067
Join Date: Dec 2008
Chapter/Region: Tri-State
Location: RAMSEY, NJ
Vehicle:
2009 IMPREZA 2.5i 4d
WHITE Premium

Default

Quote:
Originally Posted by theevbo View Post
Looks as if the factory harnesses are no longer there. Iíve got a set of hid bulbs coming tomorrow as a interim fix until I can get them rewired back to stock. Thanks for the advice.
You will need AMP bulbs.
CRAZYHAWK is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.