Welcome to the North American Subaru Impreza Owners Club Monday October 21, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-09-2019, 12:29 AM   #1
Poden
Scooby Newbie
 
Member#: 487220
Join Date: Jun 2018
Default Ej 207 Swap Is tuned wonít rev past 6500 rpm please HELP!

So I recently finished an ej 207 out of an old bugeye into a new one, I transferred everything from ecu to intercooler for the tune the car had. The car runs and drives great but when I go WOT it will only rev to 6500 and backfire with a cloud of black smoke, this leads me to believe that Iím running rich. While I had the engine out I rebuilt the turbo, could this be the reason why Iím backfiring at 6500? Do I need to look into getting a new tune, I already tested coils and plugs and theyíre fine. I changed the Idle control valve as well because it went bad. My build is a v7 207 with ID 1000ís, Perrin front mount, generic tdo5 turbo, spark plugs one step colder, tgv deletes, Walbro 255, Megan downpipe and straighpipe exhaust, I had the engine tuned last August at awd tuning.
* Registered users of the site do not see these ads.
Poden is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-09-2019, 12:48 AM   #2
subaru_gc8
Scooby Specialist
 
Member#: 29292
Join Date: Nov 2002
Chapter/Region: SCIC
Location: Orange County CA
Vehicle:
2004 WRX wagon
silver

Default

talk to the one that tuned it.. why the step colder plugs and the big injectors? it would be helpful if you did a wot pull log so we can see whats going on, but Im going to take a big guess that its your o2 sensor or the maf

Last edited by subaru_gc8; 09-09-2019 at 12:55 AM.
subaru_gc8 is offline   Reply With Quote
Old 09-09-2019, 12:58 AM   #3
Poden
Scooby Newbie
 
Member#: 487220
Join Date: Jun 2018
Default

Quote:
Originally Posted by subaru_gc8 View Post
talk to the one that tuned it.. why the step colder plugs and the big injectors? it would be helpful if you did a wot pull log so we can see whats going on, but Im going to take a big guess that its your o2 sensor or the maf
My tuner recommended going one step colder and the engine came with the bigger injectors when I originally bought it, and what program can I use to get a pull log ?
Poden is offline   Reply With Quote
Old 09-09-2019, 01:07 AM   #4
subaru_gc8
Scooby Specialist
 
Member#: 29292
Join Date: Nov 2002
Chapter/Region: SCIC
Location: Orange County CA
Vehicle:
2004 WRX wagon
silver

Default

romraider will do it but you need a tactrix cable. did it ever run correctly?
subaru_gc8 is offline   Reply With Quote
Old 09-09-2019, 08:49 AM   #5
Fozymandias
Scooby Newbie
 
Member#: 504375
Join Date: Jul 2019
Default

Is your speedo working correctly?
Fozymandias is offline   Reply With Quote
Old 09-10-2019, 03:10 AM   #6
D-Rodman
Scooby Specialist
 
Member#: 110078
Join Date: Mar 2006
Chapter/Region: Tri-State
Location: Long Island N.Y.
Vehicle:
05 Saabaru JDM STi
Black Ver 7 VF48 6sp RA

Default

Are there any parts that are different from the way the donor was setup ? Exhaust, intake, etc ?
D-Rodman is offline   Reply With Quote
Old 09-10-2019, 10:05 AM   #7
86Dreams
Scooby Specialist
 
Member#: 385256
Join Date: Mar 2014
Chapter/Region: Tri-State
Location: Harriman NY
Vehicle:
V7 S204
'19 Giulia Q4

Default

did you check fuel pressure?
86Dreams is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.