Welcome to the North American Subaru Impreza Owners Club Friday May 14, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 02-22-2021, 02:57 PM   #1
GeoNV
Scooby Newbie
 
Member#: 518830
Join Date: Sep 2020
Chapter/Region: RMIC
Location: Colorado
Vehicle:
2009 WRX
dark grey metallic

Default Finished building engine- throttle body makes noise

Hey, finished my engine build. started it for the first time last night. before I started it with the key on my throttle body was whining (kind of like a high pitch door buzzer from an old car). I read that that's not abnormal and will go away after starting it. It did change after I started it the first time- now with the key on it sounds almost like clicks and buzzes that remind me of electrical arcing. no smell, and no heat that I can feel- I can't hear it once the engine starts. Is this normal?

Checking the data logs the throttle sensor and motor seem to work fine- just the odd noise with the key on.
* Registered users of the site do not see these ads.
GeoNV is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-22-2021, 06:38 PM   #2
spoolinsti05
Scooby Guru
 
Member#: 108051
Join Date: Feb 2006
Chapter/Region: Tri-State
Location: NY
Vehicle:
2005 TickingTimeBomb
Jr tuned TT Sleeved

Default

It's normal you can adjust the screw if you pull cover off tb and might fix that. Basically throttle isn't in trim. It's a servo. So once you figure out how to set trim the noise will go away.
spoolinsti05 is offline   Reply With Quote
Old 02-22-2021, 07:51 PM   #3
GeoNV
Scooby Newbie
 
Member#: 518830
Join Date: Sep 2020
Chapter/Region: RMIC
Location: Colorado
Vehicle:
2009 WRX
dark grey metallic

Default

Ah, thanks. Appreciate the input.
GeoNV is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:11 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.