Welcome to the North American Subaru Impreza Owners Club Sunday December 17, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-24-2017, 11:49 AM   #4051
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
2015 Forester
SWP

Default

Just ordered a Koyorad.
* Registered users of the site do not see these ads.
infinite012 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-24-2017, 12:36 PM   #4052
docsdaname486
Scooby Newbie
 
Member#: 325535
Join Date: Jul 2012
Chapter/Region: Tri-State
Location: Brooklyn, NY
Vehicle:
2008 Impreza 2.5i
Spark Silver

Default

Help me fix my dumbass mistake. Long story short, I am unable to open the driver rear door from either side. The actuator works fine. I was trying to replace the exterior door handle without taking off the door card and I think I disconnected the rod.

Anyone have any tricks or a person I can go to open it up without having to destroy the door card? I am visiting from NYC and will be here the rest of the week.
docsdaname486 is offline   Reply With Quote
Old 10-24-2017, 12:48 PM   #4053
oreo404
Scooby Newbie
 
Member#: 468397
Join Date: May 2017
Location: DC
Vehicle:
05 IMPREZA 2.5RS

Default

I need a new engine for a 05 impreza 2.5rs, anyone got one for sale, and can point me to a shop that can do the swap? new in town and don't want to have any more headaches than I already have. thanks
oreo404 is offline   Reply With Quote
Old 10-24-2017, 06:00 PM   #4054
DonDonDon
Scooby Newbie
 
Member#: 476596
Join Date: Oct 2017
Default

Getting an E-tune soon. Anyone know where is the best place to do logs around Northern VA? Police everywhere!
DonDonDon is offline   Reply With Quote
Old 10-26-2017, 04:59 PM   #4055
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

- Oil & filter change. Took a sample to send off to Blackstone Labs to check the health of the unknown-mileage EJ22 that the previous owner had swapped into the car at some point.

Quote:
Originally Posted by Patrick Olsen View Post
- Installed some pimpy new DEPO amber corner lamps up front.
- And 9 months later, removed them, because the passenger side one was 1/2 full of water. I'm somewhat surprised/disappointed; I've got DEPO foglight/DRL/turn signal assemblies on my CTS-V and have been very happy with the quality of those.

- Tightened the A/C belt a little, as it has been squealing when the A/C clutch kicks on.

- Popped the center vents out so I could figure out what the bulbs are for the HVAC dials. Only the center one works, so I need some replacements.
Patrick Olsen is online now   Reply With Quote
Old 10-26-2017, 08:37 PM   #4056
carnz-pj-410
Scooby Specialist
 
Member#: 110994
Join Date: Mar 2006
Chapter/Region: MAIC
Location: BALTIMORE
Vehicle:
2x 95 Impreza 2DR
one swapped, one DD

Default

Installed a new headliner and new sunvisors in my project 95 Coupe today, ordered more parts to clean up the interior too.

Been building up a supply of parts to make this car nice again, also planning out my attack on the paint and body work side of things.
carnz-pj-410 is offline   Reply With Quote
Old 10-26-2017, 10:58 PM   #4057
RavensFan7
Scooby Specialist
 
Member#: 346388
Join Date: Feb 2013
Chapter/Region: MAIC
Location: PA
Vehicle:
2001 Ej205 Impreza L
SRP

Default What did you really do to your car today? V3.1

Made some more changes to the tune on my coupe. Messed with warm-up enrichment (for cold starts) and made some slight changes to timing/ignition. Also tossed on a slightly better fitting TMIC elbow, then took it for a quick drive to check for leaks.


Last edited by RavensFan7; 10-26-2017 at 11:29 PM.
RavensFan7 is offline   Reply With Quote
Old 10-30-2017, 08:31 AM   #4058
carnz-pj-410
Scooby Specialist
 
Member#: 110994
Join Date: Mar 2006
Chapter/Region: MAIC
Location: BALTIMORE
Vehicle:
2x 95 Impreza 2DR
one swapped, one DD

Default

Fitted a 2004 STi shift boot to a new 98-01 Impreza shifter trim last night, so i'll finally have a proper 6MT boot for my car. Took a little modification as the STi boot mounting plate is different, and the holes are in different spots. Nothing some simple drilling doesnt fix.






carnz-pj-410 is offline   Reply With Quote
Old 10-30-2017, 09:42 AM   #4059
tramp
Scooby Specialist
 
Member#: 459629
Join Date: Dec 2016
Chapter/Region: International
Location: Knobbley Mountain
Vehicle:
2017 WRX base
WR Blue

Default

Let the poor thing rest for a day. Bouht it December '16 and we're at 37K miles already. At this rate I'll be rebuilding the engine before it's paid for.
tramp is offline   Reply With Quote
Old 10-30-2017, 02:40 PM   #4060
myrt1987
Scooby Specialist
 
Member#: 323103
Join Date: Jun 2012
Chapter/Region: MAIC
Location: Columbia MD
Vehicle:
2018 WRX
Pure der

Default

Installed shift stop. Feels great!
Next is shifter bushing.
myrt1987 is offline   Reply With Quote
Old 11-09-2017, 04:09 PM   #4061
666stars
NASIOC Supporter
 
Member#: 221364
Join Date: Aug 2009
Chapter/Region: MAIC
Location: Baltimore
Vehicle:
2002 Wrx EJ207 Ver 8
Wrb Dccd jdm 6 speed now!

Default

Installed my new shift boot for freshly installed jdm 6 speed

Last edited by 666stars; 11-09-2017 at 04:26 PM.
666stars is offline   Reply With Quote
Old 11-18-2017, 12:56 PM   #4062
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Replaced the bulbs in the HVAC "head unit" on my Impreza. Only the center dial was lit up, so I popped the faceplate off to find the bulbs. Turns out they're type 74; the 1 that was still working had a green bulb condom on it, the other 2 didn't. I ordered some bulbs - some "conventional" green-tinted bulbs, and some green LEDs - and some bulb condoms in case the bulbs didn't work out. The green-tinted bulbs were a bust, barely green at all. The green LEDs were too damn bright, made big hot spots. So on went the green bulb condoms and it's good to go.
Patrick Olsen is online now   Reply With Quote
Old 11-19-2017, 09:22 AM   #4063
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2015 WRB WRX Limited
2007 WRX Limited (sold)

Default

Last Thursday.

Traded my '15 WRX in for a '15 Honda Accord EX-L V6 CPO

96accord is offline   Reply With Quote
Old 11-19-2017, 11:26 AM   #4064
DavC825
Scooby Specialist
 
Member#: 201736
Join Date: Feb 2009
Chapter/Region: MAIC
Location: On the Corner
Vehicle:
12 IS-F..its white
Slowest 07 STi

Default

Quote:
Originally Posted by 96accord View Post
Last Thursday.

Traded my '15 WRX in for a '15 Honda Accord EX-L V6 CPO

Jefe...

WHY would you do this
DavC825 is offline   Reply With Quote
Old 11-19-2017, 06:44 PM   #4065
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2015 WRB WRX Limited
2007 WRX Limited (sold)

Default

Quote:
Originally Posted by DavC825 View Post
Jefe...

WHY would you do this
Because.

Sold my BBS wheels to Rexican yesterday
96accord is offline   Reply With Quote
Old 11-20-2017, 10:54 AM   #4066
j4k3
Scooby Specialist
 
Member#: 262126
Join Date: Oct 2010
Chapter/Region: MAIC
Location: Virginia Beach, Va
Vehicle:
2007 STI
WRB

Default

Rear camber bolts to get out of the negative. Driver side still looks much more sunken in, but my car has s rebuilt title so God only knows what’s going on.

Now to try and pack my shifter with grease. There’s a rattle somewhere driving me insane,I think I’ve narrowed it down to the reverse lockout cable rattling inside the shifter.
j4k3 is offline   Reply With Quote
Old 11-20-2017, 11:48 AM   #4067
tramp
Scooby Specialist
 
Member#: 459629
Join Date: Dec 2016
Chapter/Region: International
Location: Knobbley Mountain
Vehicle:
2017 WRX base
WR Blue

Default

Made an appt. for some new tires on Friday morning. Cooper RS3 G1 stock size for my '17 WRX.
tramp is offline   Reply With Quote
Old 11-20-2017, 08:28 PM   #4068
robschilke
Scooby Newbie
 
Member#: 397553
Join Date: Jul 2014
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2014 GR8 DGM
Subaru Ambassador

Default


Deleted the chrome badges from my GR8 today. Later, I removed the OEM silver/red fender badges and replaced them with black/red badges.
robschilke is offline   Reply With Quote
Old 11-20-2017, 11:05 PM   #4069
Oaf02Z
Scooby Specialist
 
Member#: 263219
Join Date: Nov 2010
Chapter/Region: MAIC
Location: NOVA
Default

I miss my STI ☹️

I need another one bad.
Oaf02Z is online now   Reply With Quote
Old 11-21-2017, 12:14 AM   #4070
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

- Wired up the block heater. The heater itself was installed in the block when I bought the car, but I didn't have the cable. So, I bought another kit so I could get the cable, installed it on the car and routed out the grille for the true, utilitarian look. Obviously I don't really need a block heater - I've never had one prior to now in nearly 20 years of Subaru ownership - but I'm curious to see how well it works. I'll find out tomorrow morning!


(The cable isn't really that close to the header, just looks that way in the picture.)

Patrick Olsen is online now   Reply With Quote
Old 12-12-2017, 01:18 PM   #4071
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Dropped new winter tires (Hankook Winter evo2s) off for mounting & balancing @ Curry's Thursday, put them on the car Friday. Perfect timing - not that the snow storm actually stuck to the pavement at all.

The old snows still had pretty good tread, but I think were just aged out, as they had sat unused for a couple years after I killed my Legacy's engine. Production dates were 2011. Last winter they were fine in the dry, but on cold, wet pavement they were getting very sketchy - I came close to looping the car once, fortunately nobody was in the opposite lane at the time.
Patrick Olsen is online now   Reply With Quote
Old 12-12-2017, 11:02 PM   #4072
DavC825
Scooby Specialist
 
Member#: 201736
Join Date: Feb 2009
Chapter/Region: MAIC
Location: On the Corner
Vehicle:
12 IS-F..its white
Slowest 07 STi

Default

Picked it up from the body shop.
DavC825 is offline   Reply With Quote
Old Yesterday, 09:51 PM   #4073
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Used it to transport a new (junkyard) hood for my niece's '08 Beetle. Got almost all the way up to Crazy Ray's before realizing I had forgotten to grab the ratchet straps out of the garage (thinking I was going to strap the hood to the roof, as I had done with the Impreza hood a while back). Turned out I was able to fit it inside the little coupe - laid the passenger front seat back and slid the hood in on top of that and into the back seat.
Patrick Olsen is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:11 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.