Welcome to the North American Subaru Impreza Owners Club Saturday March 23, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-10-2019, 10:20 PM   #1
ddonaca351
Scooby Newbie
 
Member#: 498874
Join Date: Mar 2019
Chapter/Region: NWIC
Location: PNW
Vehicle:
2012 Impreza 2.0i

Question 2012 imp no heat/def blower output

Hey all,

2012 imp 2.0i :

heater blower quit working.

no air output on any speed 1-4. checked the two 15a fuses marked blower (bottom left of the cabin fuse panel). checked the a/c fuse just because i was already there... fuses are good on a dvm.

checked for power at the blower fan itself, with it unhooked there's 12v (11.86) on the blk/ylw. with it plugged in i've also got 12v on what appears to be the return (blk/red)... looks like an open in the return.

auto parts stores don't have a manual (chilton or haynes) they only go up to 2011. subaru dealer had part numbers for the 10 modules of the factory manuals, but they are "no longer available"

can any of you guys/gals help with some guidance on what comes after the blower motor in the circuit and where I can find it physically, in the pass cabin? (or am I totally on the wrong track?)

(i found some threads on the previous gen heater blower issues... but not for the 2012+)

THANK YOU for taking the time to help.

Dave-
* Registered users of the site do not see these ads.
ddonaca351 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-14-2019, 12:06 PM   #2
ddonaca351
Scooby Newbie
 
Member#: 498874
Join Date: Mar 2019
Chapter/Region: NWIC
Location: PNW
Vehicle:
2012 Impreza 2.0i

Default

Bueller…. Bueller…. anyone.... Bueller…. anyone...

help.
ddonaca351 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:41 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.