Welcome to the North American Subaru Impreza Owners Club Monday October 21, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-19-2019, 05:48 PM   #1
SCurry13
Scooby Newbie
 
Member#: 505467
Join Date: Aug 2019
Default Dealership Bricked ECU

Hey all,
This past December I had picked up a 13' WRX Hatch that I assume to be was running stage 2 as a certified car from Shultz Certified in Pittsburgh. Everything with the car had been amazing (don't need to hear about buying a tuned car it'll have a roll cage and be a track car when i can afford a secondary).
My battery had gone bad when I was visiting my sister in Canada, when i got back it was reading 1.9V. All was perfectly fine until this moment, scheduled a appointment at the dealership to have the stock exhaust thrown back on due to noise complaints with being catless with headers in a smaller town in Vermont.

Was not really a fan of the idea of having them do the work for free as I really didn't think they seemed qualified to be doing the work and tune in order for it to go back to stock-ish with the mods that are still currently on it. Well turns out when they swapped back to the stock exhaust I ended up getting a call from them saying they pretty much fried the ecu, and were sending it out to Cobb for them to rebuild that and the V2 AP. Car has been in the shop for over 11 days now and I'm really not happy with them and how they've handled it. any advice on my end would be greatly appreciated, does going back to the stock exhaust after running a tune for so long eventually cause problems?

When the battery went dead is when I started seeing all the trouble with it, Threw a p0134 CEL, traction control light is currently on and cruise control was also illuminated constantly when I had brought it back to the dealer in Pittsburgh.
SCurry13 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.