Welcome to the North American Subaru Impreza Owners Club Monday October 21, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-15-2008, 07:49 PM   #1
EagleRockWrex
Scooby Specialist
 
Member#: 95780
Join Date: Sep 2005
Chapter/Region: SCIC
Location: Pasadena, CA
Vehicle:
2008 Infinity G37S
Ivory/Black

Default Pulls To Right When Driving

Okay, so, 4th time on the laser alignment machine, every single seting is perfect and according to the techs should drive straight as an arrow, but it doest, it pulls to the right, and fairly aggresivley!

Has anyone had this problem with their Impreza's? Never hit a curb, never in an accident, no bent pieces, steering rack is perfect, the only thing that was off was the SIA (I think) which is the steering something aspect.... but off only by a fraction and according to the techs would have no affect on the steering.

Help!!
* Registered users of the site do not see these ads.
EagleRockWrex is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-15-2008, 07:55 PM   #2
Turn in Concepts
NASIOC Vendor
 
Member#: 93646
Join Date: Aug 2005
Chapter/Region: MWSOC
Vehicle:
Many Track Records
Let us help you go fast!

Default

Rotate tires in the front from side to side and see what happens. Tires can cause this problem. Do you have a print out of the alignment specs?

Tony
Turn in Concepts is offline   Reply With Quote
Old 01-15-2008, 08:19 PM   #3
EagleRockWrex
Scooby Specialist
 
Member#: 95780
Join Date: Sep 2005
Chapter/Region: SCIC
Location: Pasadena, CA
Vehicle:
2008 Infinity G37S
Ivory/Black

Default

Tires were rotated in all directions temporarily and it didnt fix anything, they are directional Goodyear F1 GS-D3 with less than 4,000 miles on them however I developed this problem before the tire change.

Settings are as follows:
Front Left
camber -0.5
caster 3.2
toe 0.03
SAI 15.1
Included angle 14.6

Front Right
camber -0.9
caster 3.2
toe 0.02
SAI 14.5
Included area 13.6

Rear Left
Camber -1.9
Toe -0.12

Rear Right
Camber -1.4
Toe 0.03

Rear Cross Camber -0.5
Total Toe -0.09
Thrust angle -0.08+
EagleRockWrex is offline   Reply With Quote
Old 01-15-2008, 08:34 PM   #4
Butt Dyno
Street's closed, pizza boy
 
Member#: 17301
Join Date: Apr 2002
Chapter/Region: MAIC
Location: NoVA
Vehicle:
2016 FoST ST3
2006 Evo #17 STU

Default

They couldn't get the camber any closer than that? I would not say that "every setting is perfect". I'm not sure whether .5 difference in the rear and .4 in the front is enough to cause what you're describing (I have never had an alignment that far off personally) but I have to think that they can try harder.
Butt Dyno is offline   Reply With Quote
Old 01-15-2008, 08:50 PM   #5
RaceComp Engineering
NASIOC Vendor
 
Member#: 54202
Join Date: Feb 2004
Chapter/Region: MAIC
Location: Elkridge, Maryland
Vehicle:
ASK ABOUT NEW RCE
SWAY BARS FOR STI

Default

Every car is different. How was your alignment before this?...if you had those tires on the car or other tires and needed an alignment prior, they could have some abnormal wear on them PLUS with the fact that this alignment is FAR from perfect,..AND your weight in the car. I used to sit in my car when the final settings were tweeked. I can say having been a service writer for a long time that I got to sit in my cars with a half tank and get a "super anal" alignment and yes with -3.0 plus and dead toe and NEW tires, I could get a straight car with a straight steering wheel on the rare level highway or street.

So there could be MANY reasons why. Sway bar links, rear bar could have flipped and no one noticed( highly unlikely), simple things like tire pressure that I have seen techs NOT check or pay attention to. Point is many things contribute to the alignment and while it seems like they would know and watch out for these things...MANY dont.

Oh and sometimes the rack is WAY OFF.

Myles
RaceComp Engineering is offline   Reply With Quote
Old 01-15-2008, 11:10 PM   #6
EagleRockWrex
Scooby Specialist
 
Member#: 95780
Join Date: Sep 2005
Chapter/Region: SCIC
Location: Pasadena, CA
Vehicle:
2008 Infinity G37S
Ivory/Black

Default

Should I have them tighten up those camber numbers? I will do a search on good setting and have them set it there, I paid for the free alignments for 3 years.

Also, how does the rack get off? That sounds like it could cause it but when they looked under the car for any bent pieces or a loose rack he said he saw nothing looked like it shifted..... This is frustrating!!
EagleRockWrex is offline   Reply With Quote
Old 01-15-2008, 11:20 PM   #7
Web Foot STi
Scooby Guru
 
Member#: 39086
Join Date: Jun 2003
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2004 STi
White

Default

Max balanced camber in the front and 0.00 toe front and back. I ask for a mis alignmet when I go.
Web Foot STi is offline   Reply With Quote
Old 01-16-2008, 04:27 PM   #8
Scooby921
Merci Buckets
Moderator
 
Member#: 88606
Join Date: Jun 2005
Chapter/Region: MWSOC
Location: Michigan
Vehicle:
2018 Grand Cherokee
Velvet Red Pearl

Default

The guy who does my alignments once showed me a document discussing OE setups and settings. I recall there being a quarter to half degree less caster in the right front to compensate for crowned roads. Try taking a quarter degree out and see if it improves things.
Scooby921 is offline   Reply With Quote
Old 01-16-2008, 04:50 PM   #9
EagleRockWrex
Scooby Specialist
 
Member#: 95780
Join Date: Sep 2005
Chapter/Region: SCIC
Location: Pasadena, CA
Vehicle:
2008 Infinity G37S
Ivory/Black

Default

I will keep everyone posted
EagleRockWrex is offline   Reply With Quote
Old 01-17-2008, 04:08 AM   #10
Mecanic07
Scooby Newbie
 
Member#: 126552
Join Date: Sep 2006
Chapter/Region: E. Canada
Location: Shannon, Québec
Vehicle:
2007 STI
Urban Gray

Default

You have more neg camber on the front, so its not supposed to pull on the right since you have the same caster specs on both sides...
Do you have oem wheels? Cheap tires? Why is your thrust angle not at zero? So easy to put at 0, there is the eccentrics bolts in the rear... Swap the front tires with one of your buddy, when I get severe pulling on one side, it`s always the tires ( if all the specs are ok, and all the tie-rords, ball joints, bushings are tight)
Mecanic07 is offline   Reply With Quote
Old 01-17-2008, 11:36 AM   #11
strohausii
Scooby Specialist
 
Member#: 26770
Join Date: Oct 2002
Chapter/Region: South East
Location: Tampa
Vehicle:
'02 WRX
midnight black

Default

Quote:
Originally Posted by Scooby921 View Post
The guy who does my alignments once showed me a document discussing OE setups and settings. I recall there being a quarter to half degree less caster in the right front to compensate for crowned roads. Try taking a quarter degree out and see if it improves things.
Yeah, I thought the OEM suspension had unequal caster from right/ left.
strohausii is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pulling to Right and Resistance Turning to Left OsirisNEB Brakes, Steering & Suspension 2 06-08-2008 03:08 PM
my car 05 STi slightly pulls to the right when driving tom6 Newbies & FAQs 8 07-14-2007 10:26 PM
Slight pull to right after track day chimchimm5 Brakes, Steering & Suspension 3 03-10-2007 03:35 PM
pulling to right under excelaration bill king Transmission (AT/MT) & Driveline 6 01-02-2006 05:07 AM
Swaping left hand drive to right hand drive??? STIpreza Normally Aspirated Powertrain 8 05-23-2001 05:51 AM

All times are GMT -4. The time now is 03:42 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.