Welcome to the North American Subaru Impreza Owners Club Sunday October 20, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 02-26-2019, 12:25 PM   #1
chimchimm5
Scooby Guru
 
Member#: 88501
Join Date: Jun 2005
Chapter/Region: BAIC
Location: NorCal
Vehicle:
2011 WRX Hatch
Dark Grey

Default 2011 WRX: fuse box behind glove compartment is dangling

2011 WRX

Recently discovered the fuse box behind the glove compartment is dangling by the wires. But I cannot see where the thing was originally mounted.

Can someone please snap and post a picture of what their's looks like?

Here's mine (camera on passenger floor looking up at 45 degrees under glove compartment):


I'm gonna zip tie for now but I want to put it back where it originally was
* Registered users of the site do not see these ads.
chimchimm5 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-10-2019, 10:20 PM   #2
ROTORCRAFT230
Scooby Newbie
 
Member#: 385360
Join Date: Mar 2014
Location: Brazoria county,Texas
Vehicle:
2014 Impreza WRX
Plasma Blue

Default

Thatís weird I just found mine like that a few days ago. There are some small discreet clips and channels maybe 3-4 total. Just look closely and you will see them. Kinda awkward but just study a bit and youíll eventually see it.
Mark
ROTORCRAFT230 is offline   Reply With Quote
Old 03-11-2019, 03:25 AM   #3
chimchimm5
Scooby Guru
 
Member#: 88501
Join Date: Jun 2005
Chapter/Region: BAIC
Location: NorCal
Vehicle:
2011 WRX Hatch
Dark Grey

Default

Quote:
Originally Posted by ROTORCRAFT230 View Post
Thatís weird I just found mine like that a few days ago. There are some small discreet clips and channels maybe 3-4 total. Just look closely and you will see them. Kinda awkward but just study a bit and youíll eventually see it.
Mark


Photo please please?
chimchimm5 is offline   Reply With Quote
Old 03-12-2019, 02:05 PM   #4
ROTORCRAFT230
Scooby Newbie
 
Member#: 385360
Join Date: Mar 2014
Location: Brazoria county,Texas
Vehicle:
2014 Impreza WRX
Plasma Blue

Default

Quote:
Originally Posted by chimchimm5 View Post
Photo please please?


Iím at work, when I get home.
ROTORCRAFT230 is offline   Reply With Quote
Old 03-12-2019, 02:44 PM   #5
Charlie-III
Scooby Guru
 
Member#: 30669
Join Date: Dec 2002
Chapter/Region: Tri-State
Location: USA, North NJ, 07456
Vehicle:
1998 Legacy 2.5GT
Silver Sleeper BK, 5MT

Default

Quote:
Originally Posted by ROTORCRAFT230 View Post
Thatís weird I just found mine like that a few days ago. There are some small discreet clips and channels maybe 3-4 total. Just look closely and you will see them. Kinda awkward but just study a bit and youíll eventually see it.
Mark
Quote:
Originally Posted by chimchimm5 View Post
Photo please please?
Hmmmmm......how about......crawl under there, swing fuse box out a bit, look at back of fuse box, look for mating bits on the firewall?
Align and snap back in place?

I think the earlier reply sorta spelled it out and sorta what to look for.
Maybe pay a shop to do it?
I (myself) wouldn't be asking for pictures of what I could go look at when I was sorta given direction of what to look for.
What, you want a mounted picture? What does that tell you?

Good luck OP.
ROTORCRAFT230, thanks for the reply.
Charlie-III is offline   Reply With Quote
Old 03-12-2019, 07:45 PM   #6
chimchimm5
Scooby Guru
 
Member#: 88501
Join Date: Jun 2005
Chapter/Region: BAIC
Location: NorCal
Vehicle:
2011 WRX Hatch
Dark Grey

Default

Quote:
Originally Posted by Charlie-III View Post
Hmmmmm......how about......crawl under there, swing fuse box out a bit, look at back of fuse box, look for mating bits on the firewall?
Align and snap back in place?
You are assuming I did not do that and that assumption is wrong

I have a feeling someone kicked the box and broke the tabs which are not not very identifiable. Hence the picture request.
chimchimm5 is offline   Reply With Quote
Old 08-23-2019, 07:06 PM   #7
dmath
Scooby Newbie
 
Member#: 505432
Join Date: Aug 2019
Location: Wisconsin
Vehicle:
2009 WRX Hatch
Dark Gray

Default

Chimchimm5 - did you figure out how to attach the loose fuse panel? We bought an 09 WRX this week and just discovered that the same panel is dangling. I've looked for how to re-secure it but I suspect that something is broken or missing.
dmath is offline   Reply With Quote
Old 08-24-2019, 01:03 AM   #8
chimchimm5
Scooby Guru
 
Member#: 88501
Join Date: Jun 2005
Chapter/Region: BAIC
Location: NorCal
Vehicle:
2011 WRX Hatch
Dark Grey

Default

Quote:
Originally Posted by dmath View Post
Chimchimm5 - did you figure out how to attach the loose fuse panel? We bought an 09 WRX this week and just discovered that the same panel is dangling. I've looked for how to re-secure it but I suspect that something is broken or missing.


Yes I did. Tabs were not broken. Here's a picture that should help. Note the side where the metal tabs slot into the panel.


Last edited by chimchimm5; 08-31-2019 at 01:13 PM.
chimchimm5 is offline   Reply With Quote
Old 08-24-2019, 04:02 PM   #9
dmath
Scooby Newbie
 
Member#: 505432
Join Date: Aug 2019
Location: Wisconsin
Vehicle:
2009 WRX Hatch
Dark Gray

Default

Thank you, the photo was helpful. I found it much easier to remove the metal bracket and install it before reattaching the fuse block.
dmath is offline   Reply With Quote
Old 08-30-2019, 09:19 PM   #10
Goliat6288
Scooby Newbie
 
Member#: 297080
Join Date: Oct 2011
Location: Pittsburgh, PA
Vehicle:
2008 WRX
Black

Default

i noticed my fuse box was dangling yesterday and i happen to stumble upon this thread today. thanks for the helpful picture
Goliat6288 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:05 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.