Welcome to the North American Subaru Impreza Owners Club Sunday August 19, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-22-2016, 04:19 PM   #1
Jamtill
Scooby Newbie
 
Member#: 436127
Join Date: Dec 2015
Location: Owensboro, KY
Vehicle:
2016 WRX STi
DGM

Default LED control unit - 2016 STi

In June I installed the LED C-lights and multiple times I had issues with condensation in the passenger side headlight. I would open it up and reseal, but that passenger side kept giving me issues.

Well this latest time it knocked out the LED low beam. I took the headlight apart, again, and then tested each of the 2 LED low beams in the headlight, both work fine when connected to a 12V source. I am pretty sure the problem is the CONT ASSY LED HL unit. (Pictured)

I would really appreciate any advice on purchasing just that unit.

I hate the thought of buying a new headlight just to open it up and install the c light for it to match the driver side. I would go back to stock if anything which then I would have to buy 2 headlights, they are 800 a piece, which hurts to even think about.



* Registered users of the site do not see these ads.
Jamtill is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-03-2017, 08:31 PM   #2
uget2seconds
Scooby Newbie
 
Member#: 282476
Join Date: May 2011
Default

Ever find the replacement part for it? I have the same issue and needed to buy another headlamp assembly due to it being my daily driver. Took the old one apart after months of it being in a box and saw the same driver issue. I may rip the metal cover and see what's underneath to see if the damaged component itself may be replaced
uget2seconds is offline   Reply With Quote
Old 02-03-2017, 08:31 PM   #3
uget2seconds
Scooby Newbie
 
Member#: 282476
Join Date: May 2011
Default

And in your pic you can see the rust on one of the inside screw threads lol you must of had a lot of water
uget2seconds is offline   Reply With Quote
Old 02-03-2017, 08:52 PM   #4
uget2seconds
Scooby Newbie
 
Member#: 282476
Join Date: May 2011
Default

Here you can see my burned transistors and marks on the board...

uget2seconds is offline   Reply With Quote
Old 07-02-2018, 04:26 PM   #5
RiCKYSTi
Scooby Newbie
 
Member#: 446304
Join Date: May 2016
Location: Maryland, USA
Vehicle:
2015 WRX STi
Crystal Pearl White

Default

Im having the same issue did you ever get it fixed?
RiCKYSTi is offline   Reply With Quote
Old 08-04-2018, 01:45 PM   #6
Themis_wrx
Scooby Newbie
 
Member#: 442912
Join Date: Mar 2016
Default

Have you ever figured out this issue I just opened up my headlight and found that my control module is Rusted from the inside
Themis_wrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.