Welcome to the North American Subaru Impreza Owners Club Saturday October 31, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-10-2020, 10:19 PM   #1
tannerdc
Scooby Newbie
 
Member#: 437133
Join Date: Dec 2015
Chapter/Region: NWIC
Location: West Richland, WA
Vehicle:
06 WRX Limited
WRB

Default No idle

So I finally got my car back together after a year. Battery has been sitting on the charger outside the car. The car started up just fine cold start. I let it warm up and and didnít touch anything. About 5-8 minutes. I got int he car and touched the gas to idle down and the car just dies. Only way I can keep it started is a bit of gas and it sounds just fine. Just wonít idle. Itís a Ď06 WRX. Ran fine before it was parked. Just suspension work. I read something about an idle control valve and also read it isnít on my model. Another person said it goes away after a few miles. Any help is appreciated
* Registered users of the site do not see these ads.
tannerdc is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-10-2020, 11:16 PM   #2
truck7575
Scooby Newbie
 
Member#: 516780
Join Date: Jul 2020
Location: Georgetown Kentucky
Vehicle:
2008 Subaru wrx sti
WRB

Default

Maybe a vacuum leak?
truck7575 is offline   Reply With Quote
Old 10-11-2020, 07:15 AM   #3
Jay11STI
Scooby Newbie
 
Member#: 492422
Join Date: Oct 2018
Chapter/Region: Tri-State
Location: North Jersey
Vehicle:
2011 STI

Default

Does it change if you un plug the MAF?
Jay11STI is offline   Reply With Quote
Old 10-11-2020, 12:55 PM   #4
tannerdc
Scooby Newbie
 
Member#: 437133
Join Date: Dec 2015
Chapter/Region: NWIC
Location: West Richland, WA
Vehicle:
06 WRX Limited
WRB

Default

Quote:
Originally Posted by Jay11STI View Post
Does it change if you un plug the MAF?


I havenít tried that yet.
tannerdc is offline   Reply With Quote
Old 10-12-2020, 09:40 AM   #5
klinebau
Scooby Newbie
 
Member#: 122383
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Troy, MI
Vehicle:
2006 WRX Wagon
Silver

Default

'06 does not have an idle air control valve. These exist only on the cable operated throttle valves and the '06 was the first year for drive by wire. I would try this procedure.

https://forums.nasioc.com/forums/sho...ght=idle+learn
klinebau is offline   Reply With Quote
Old 10-12-2020, 09:47 AM   #6
BlackFighter
Scooby Specialist
 
Member#: 193940
Join Date: Nov 2008
Location: Philly
Vehicle:
2004 WRX STI Black
RalliSpec Shortblock

Default

My 04 STi TB was not cable operated and i had a idle air control valve on top of my TB.
BlackFighter is offline   Reply With Quote
Old 10-13-2020, 09:05 AM   #7
klinebau
Scooby Newbie
 
Member#: 122383
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Troy, MI
Vehicle:
2006 WRX Wagon
Silver

Default

Quote:
Originally Posted by BlackFighter View Post
My 04 STi TB was not cable operated and i had a idle air control valve on top of my TB.
I forgot about the STI. 2006 was the first WRX with the 2.5l engine, drive by wire and no IACV.
klinebau is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.