Welcome to the North American Subaru Impreza Owners Club Saturday October 31, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-16-2020, 08:25 PM   #1
Db1991
Scooby Newbie
 
Member#: 512297
Join Date: Mar 2020
Default Help. .

Help... 15 STi won't make more than 5lbs of boost. Ran a smoke test no visible leaks. Car was fine one day sat over night got in the next day and it is noticably quieter. No exhaust pops nothing almost like a non turbo car. No weird noises, no cel, dam is at 1.0. could the BCS taken a ****? I'm lost my mechanic and I can't figure it out. Stock car with muffler deletes. 60k miles. Anyone had this issue any help would be appreciated. Thanks.
* Registered users of the site do not see these ads.
Db1991 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-17-2020, 07:40 AM   #2
Jay11STI
Scooby Newbie
 
Member#: 492422
Join Date: Oct 2018
Chapter/Region: Tri-State
Location: North Jersey
Vehicle:
2011 STI

Default

You said no check engine light but have you scanned the car to see if there are any faults stored? Its possible the boost control solenoid may have failed, try swapping it out with another one.

Are you sure there are no air leaks? All the vacuum lines are good along with turbo inlet and bov gasket?
Jay11STI is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:24 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.