Welcome to the North American Subaru Impreza Owners Club Monday April 12, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-05-2021, 09:29 AM   #1
jjpaul
Scooby Newbie
 
Member#: 474355
Join Date: Sep 2017
Default Clutch Advice

I had a bad throw out bearing at 100k and because of the labor cost decided to replace the clutch and pressure plate at the same time by a local transmission shop. I didn't know it was the TOB at the time but I had heard a noise for quite a while and was able to drive it to the shop when the noise got really bad. Now 165k on car.

2 days ago i began hearing a noise when pushing in the clutch in, in the am. In the PM I took the car out and didn't hear the noise. Yesterday morning heard it again and drove out and back maybe 15 miles. Started making a lot of noise a mile from home when pushing in the clutch and petal didn't feel right and car would stall at stop signs. Made it home and the petal feels almost no resistance and will stay depressed but can bring it back with my toe.
Fluid is clean and in reservoir, no leaks seen at slave cyl, master cyl or hose or line. There is slight tacky substance at bottom of boot on slave cyl. I pulled boot back and didn't notice any fluid inside of boot.
My questions:
Is there any was to diagnose what the problem is and if not opinion on what it might most likely be?
What pressure bleeder would you recommend to bleed slave cyl?
Car is not driveable and I plan on repairing myself car is a 2010.

Thank you for any help.
* Registered users of the site do not see these ads.
jjpaul is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-07-2021, 11:16 PM   #2
AliBenn
Scooby Guru
 
Member#: 487
Join Date: Nov 1999
Chapter/Region: TXIC
Location: Greatwood/Sgrlnd
Vehicle:
1998 /2005 STunIcorn
Acadia Green RS-T

Default

Clutch Master Cylinder
$50 part
Maybe 2 bolts and 2 fluid lines
Will need to bleed thou
100 times easier than bleeding brakes
Long time ago but think was only 5-7 presses on clutch pedal to bleed bc of such small
system
Now I dont know if u have intercooler bc no profile but IC would need to be removed if u have
GL
AliBenn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:05 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.