Welcome to the North American Subaru Impreza Owners Club Tuesday August 3, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-18-2007, 09:27 AM   #1
IllNastyImpreza
Scooby Guru
 
Member#: 36333
Join Date: May 2003
Chapter/Region: NESIC
Location: East Kingston NH
Vehicle:
98 RS
GT30R, closed deck madnes

Default Where does my knock sensor go ???

ok I've got my entire engine back together !
I finaly cranked it up last night (no exhaust at all )

But I've got my knock sensor just grounded to the top of the motor (only ran for about 3 seconds)



I need to put the knock sensor back where it belongs... can someone place fill me in here. Thanks !
* Registered users of the site do not see these ads.
IllNastyImpreza is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-18-2007, 09:51 AM   #2
shaw169
Scooby Newbie
 
Member#: 120088
Join Date: Jul 2006
Chapter/Region: MAIC
Location: SoMD
Vehicle:
2001 Z3
Silver

Default

Search a bit for more:

shaw169 is offline   Reply With Quote
Old 10-18-2007, 10:25 AM   #3
IllNastyImpreza
Scooby Guru
 
Member#: 36333
Join Date: May 2003
Chapter/Region: NESIC
Location: East Kingston NH
Vehicle:
98 RS
GT30R, closed deck madnes

Default

where is that diagram from ?


thanks !
IllNastyImpreza is offline   Reply With Quote
Old 10-18-2007, 10:33 AM   #4
shaw169
Scooby Newbie
 
Member#: 120088
Join Date: Jul 2006
Chapter/Region: MAIC
Location: SoMD
Vehicle:
2001 Z3
Silver

Default

club wrx, thread on knock sensor location. Pic originally probly out of one of the manuals.
shaw169 is offline   Reply With Quote
Old 10-18-2007, 10:43 AM   #5
IllNastyImpreza
Scooby Guru
 
Member#: 36333
Join Date: May 2003
Chapter/Region: NESIC
Location: East Kingston NH
Vehicle:
98 RS
GT30R, closed deck madnes

Default

cool.... must be a newer style motor than mine...cuz I only have 1 cam sensor... and its on the front driver side

I'm throwin the knock sensor in the right spot now.... thanks!

Can't wait to get her up and running !
IllNastyImpreza is offline   Reply With Quote
Old 10-18-2007, 01:36 PM   #6
SAIKOU
Scooby Newbie
 
Member#: 92718
Join Date: Aug 2005
Chapter/Region: Tri-State
Location: Jersey
Vehicle:
04 WRX 2.5 Hybrid
Aspen White

Default

torque it, i don't know the exact but mine is at 25lbs and works. anyone got the right value?
SAIKOU is offline   Reply With Quote
Old 10-18-2007, 03:43 PM   #7
afmardve
Scooby Newbie
 
Member#: 57698
Join Date: Mar 2004
Location: bloomfield NJ
Vehicle:
03 wrx
silver

Default

torque to 17.4 foot pounds. The sensor wire needs to be on a 60 degree angle relative to the rear of the engine. to the right.
afmardve is offline   Reply With Quote
Old 10-19-2007, 07:01 PM   #8
bboy
Scooby Specialist
 
Member#: 56468
Join Date: Mar 2004
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
04 Improved STI
Dirty White

Default

^^^Lots of people move it, but those are the directions.
bboy is offline   Reply With Quote
Old 10-19-2007, 07:08 PM   #9
IllNastyImpreza
Scooby Guru
 
Member#: 36333
Join Date: May 2003
Chapter/Region: NESIC
Location: East Kingston NH
Vehicle:
98 RS
GT30R, closed deck madnes

Default

Quote:
Originally Posted by afmardve View Post
torque to 17.4 foot pounds. The sensor wire needs to be on a 60 degree angle relative to the rear of the engine. to the right.
does this really matter?

I'm having a problem getting her running right.

I start her up, and she runs PERFECT for about 3 minutes.

Then it starts bogging and bucking and spuddering, and the CEL comes on...

it does the exact same thing 3 times in a row(after I reset the ECU)

I thought it might have been a ground problem so I moved some grounds around... but to no use.

I would check the code, but my code reader doesn't detect alot of the Subaru codes

anyone have any ideas ??
IllNastyImpreza is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
where is the knock sensor on 03/04 impreza? qtr_wrx Normally Aspirated Powertrain 5 10-26-2007 03:23 PM
What does a Knock Sensor do? brianecarlson Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 3 07-14-2005 05:40 PM
Where is the knock sensor? SubaruGenki Normally Aspirated Powertrain 5 08-18-2004 12:07 PM
Where does my brake fluid go? Rusty the Scoob Brakes, Steering & Suspension 2 07-12-2002 02:17 PM
Where does my O2 sensor go? scootr Normally Aspirated with bolt-on Forced Induction Powertrain 10 11-12-2001 03:31 PM

All times are GMT -4. The time now is 08:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.