Welcome to the North American Subaru Impreza Owners Club Wednesday November 14, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Closed Thread
 
Thread Tools Display Modes
Old 01-29-2013, 04:33 PM   #1
paskeezy2000
Scooby Newbie
 
Member#: 345315
Join Date: Jan 2013
Vehicle:
2013 WRX
Silver

Default posted this on the newb board and didnt get any answers

Im new here and im sure this question has been asked a ton of times but i just cant find it...

I bought my new 2013 WRX about 3 weeks ago and, with under 1500 miles on it, the fender flare/lower rear door is sandblasted from sand/gravel being kicked up by the front wheels. The plastic film is chewed up and the paint all around it is getting jacked. Needless to say, this sucks pretty bad considering the car is new and i didnt do anything wrong whatsoever.

I know im not the only one so my question is; Will Subaru help me out with this? What do i do? I know i need some mud flaps but what do i do about repairing the existing damage?

Any help is appreciated.
* Registered users of the site do not see these ads.
paskeezy2000 is offline  
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-29-2013, 04:36 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Sorry we don't allow crossposting on NASIOC (please re-read the rules). Anyway it looks like your other thread has gotten responses.
Mulder is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:50 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.