Welcome to the North American Subaru Impreza Owners Club Saturday December 7, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > FA Series Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-28-2019, 11:20 PM   #1
glenmo
Scooby Newbie
 
Member#: 467826
Join Date: May 2017
Vehicle:
2017 WRX
WRB

Default Process West Verticooler and my air intake system

I recently installed the Process West Verticooler, and it seems like I can't use my stock air intake snorkel anymore...

The part I'm talking about is the one labeled #14 in the diagram below. I have the ETS air box, and the snorkel used to fit perfectly and keep my intake temps really low.

Has anybody else had a similar experience? Did I make a mistake during install? It seemed like everything is tight & inserted properly...

https://i.imgur.com/DD7gkMB.gif
* Registered users of the site do not see these ads.
glenmo is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-29-2019, 03:22 PM   #2
Joey B 18c
Scooby Newbie
 
Member#: 472075
Join Date: Aug 2017
Location: Chicago
Vehicle:
2017 WRX
Black

Default

picture from their own website shows that part installed, I think it should still work...

https://processwest.com.au/product/2...duct-gallery-7

Unless I'm looking at the wrong part?
Joey B 18c is offline   Reply With Quote
Old 10-29-2019, 03:27 PM   #3
Sillo
Scooby Specialist
 
Member#: 423270
Join Date: Jun 2015
Chapter/Region: Tri-State
Location: Long Island
Vehicle:
2015 WRX (sold)

Default

Worked fine on mine when I had it installed.
Sillo is online now   Reply With Quote
Old 10-29-2019, 03:51 PM   #4
glenmo
Scooby Newbie
 
Member#: 467826
Join Date: May 2017
Vehicle:
2017 WRX
WRB

Default

I asked on the fb page for 2015+ WRX owners and they said just wiggle and massage the chargepipe... the most likely culprit is that the pipe isn't properly seated in place. So I'll get on that and report back, I guess.
glenmo is offline   Reply With Quote
Old 11-03-2019, 12:02 AM   #5
glenmo
Scooby Newbie
 
Member#: 467826
Join Date: May 2017
Vehicle:
2017 WRX
WRB

Default

Well, they were right-- loosening the clamps, wiggling and pushing it around gave me enough clearance to fit the snorkel. Cool temps and ram air, here I come!
glenmo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:11 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.