Welcome to the North American Subaru Impreza Owners Club Wednesday October 21, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-09-2002, 09:11 AM   #1
Lightning Jack
Scooby Specialist
 
Member#: 8585
Join Date: Jul 2001
Location: Ubon
Vehicle:
2002 WRX
Rally Blue!

Default Check Engine light came on

This morning as i was warming up the car then i drove passed a b lock i notice "check engine" light is on

4845 miles

oil changed once at 2000 miles

any idea?

i just called a dealer and i'm taking my car in tomorrow
* Registered users of the site do not see these ads.

Last edited by Lightning Jack; 07-09-2002 at 09:17 AM.
Lightning Jack is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-09-2002, 10:59 AM   #2
cnk
Scooby Guru
 
Member#: 10757
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2013 BRZ Limited 6MT
DGM

Default

No idea. . have the dealer pull the code. Could just be the gas cap thing. Make sure it's on tight. . .at least 3-5 clicks.

Calvin
cnk is offline   Reply With Quote
Old 07-09-2002, 05:37 PM   #3
Lightning Jack
Scooby Specialist
 
Member#: 8585
Join Date: Jul 2001
Location: Ubon
Vehicle:
2002 WRX
Rally Blue!

Default

dealer will fix this for free right?
Lightning Jack is offline   Reply With Quote
Old 07-09-2002, 06:12 PM   #4
ciper
Scooby Guru
 
Member#: 15543
Join Date: Feb 2002
Location: san francisco, ca
Vehicle:
90BJ Legacy LS ABS
AWD 946 Rio Red Jpn built

Default

If the light stays on it means there is a reocurring problem. Usually it means something is wrong and needs fixed. If you under warranty and you havnt intentionally broke something it should be free.

But I have a suggestion for you.

Are you sure you tightened the fuel cap all the way?
ciper is offline   Reply With Quote
Old 07-12-2002, 07:25 PM   #5
MAGMORE
Scooby Newbie
 
Member#: 16146
Join Date: Mar 2002
Vehicle:
2002 WRX
SILVER

Default o2 sensor

Have em check the gascap sensor to .
It is a fairly common problem. My sensor hose came off and set the ce light off . dealer replaced the whole gascap assembly under warranty.
MAGMORE is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
('93-'01) Check Engine Light came on 96Imprezer Impreza Forum 1 04-16-2001 10:25 AM
check engine light came on. go go go Normally Aspirated Powertrain 4 01-26-2001 02:28 AM
Installed S-AFC, Check Engine light came on... HELP! JP Money Technical Forum Archive 14 09-06-2000 09:52 AM

All times are GMT -4. The time now is 01:23 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.