Welcome to the North American Subaru Impreza Owners Club Saturday December 16, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-20-2008, 10:42 PM   #1
07Limited0306
Scooby Newbie
 
Member#: 179247
Join Date: May 2008
Chapter/Region: Tri-State
Location: CT
Vehicle:
2007 WRX Limited
SWP

Default So i WAS going to get a tune today...

I went to xxtuning to finally get my car tuned

its an 07 wrx with

cobb downpipe
borla hush
sti tmic
blouch 18g turbo
hallman manual boost controller
megan headers
cobb AP

so we threw it on the dyno and it made 237 whp with the ots map???
the boost curve was all messed up
It went to 18 pounds at like 4000 rpm then just dropped to 15 out of no where.
They said it was because of the boost controller, so we took it off.
the map w/o a controller is suppossed to make 18 lbs, it only made 11
they said this was either my boost control solenoid, my actuator, or vacum lines.
They're checking it out today and tomorrow, i left the car with them.
any ideas or suggestions?

it seemed to be running fine?
* Registered users of the site do not see these ads.
07Limited0306 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-20-2008, 11:01 PM   #2
gabedude
Scooby Guru
 
Member#: 10108
Join Date: Sep 2001
Chapter/Region: TXIC
Location: Killeen, TX
Vehicle:
2016 Bicycle

Default

Did you remove the factory t when you installed your MBC? If you don't put the pill back in, it won't boost right (low). That 18 to 15 taper is normal for running an MBC on a 18G. I bet the lines, but you should really just get a 3 port blocking solenoid for the stock ECU to control and run it in interrupt mode to get your MBC like response. You don't need the pill then.
gabedude is offline   Reply With Quote
Old 11-20-2008, 11:03 PM   #3
07Limited0306
Scooby Newbie
 
Member#: 179247
Join Date: May 2008
Chapter/Region: Tri-State
Location: CT
Vehicle:
2007 WRX Limited
SWP

Default

hmm, i don't really understand everything you said right there, but i am trying. what exactly is a 3 port blocking system? and now that i think about it, i dont have the factory t in it anymore... the hallman one was a lot bigger too...
07Limited0306 is offline   Reply With Quote
Old 11-20-2008, 11:08 PM   #4
gabedude
Scooby Guru
 
Member#: 10108
Join Date: Sep 2001
Chapter/Region: TXIC
Location: Killeen, TX
Vehicle:
2016 Bicycle

Default

Yeah that is the problem, you need the stock lines. There are 2 types of 3 port solenoids (stock is a 2 port) that are popular on subarus. Many companies sell kits. Just get a 3 port.
gabedude is offline   Reply With Quote
Old 11-20-2008, 11:18 PM   #5
07Limited0306
Scooby Newbie
 
Member#: 179247
Join Date: May 2008
Chapter/Region: Tri-State
Location: CT
Vehicle:
2007 WRX Limited
SWP

Default

alright i just looked them up, prodrive makes one for $100, that sound reasonable?
07Limited0306 is offline   Reply With Quote
Old 11-20-2008, 11:25 PM   #6
gabedude
Scooby Guru
 
Member#: 10108
Join Date: Sep 2001
Chapter/Region: TXIC
Location: Killeen, TX
Vehicle:
2016 Bicycle

Default

Quote:
Originally Posted by 07Limited0306 View Post
alright i just looked them up, prodrive makes one for $100, that sound reasonable?
See if xxtuning has one in stock that they prefer to use.
gabedude is offline   Reply With Quote
Old 11-20-2008, 11:29 PM   #7
jagstyle
R.I.P.
 
Member#: 155186
Join Date: Jul 2007
Chapter/Region: BAIC
Location: NorCal
Vehicle:
2007 STI

Default

Quote:
Originally Posted by gabedude View Post
Did you remove the factory t when you installed your MBC? If you don't put the pill back in, it won't boost right (low). That 18 to 15 taper is normal for running an MBC on a 18G. I bet the lines, but you should really just get a 3 port blocking solenoid for the stock ECU to control and run it in interrupt mode to get your MBC like response. You don't need the pill then.
huh? I don't run the factory lines or pill with my Hallman MBC and it works just fine
jagstyle is offline   Reply With Quote
Old 11-21-2008, 12:02 AM   #8
gabedude
Scooby Guru
 
Member#: 10108
Join Date: Sep 2001
Chapter/Region: TXIC
Location: Killeen, TX
Vehicle:
2016 Bicycle

Default

Quote:
Originally Posted by jagstyle View Post
huh? I don't run the factory lines or pill with my Hallman MBC and it works just fine
Yeah he took off his MBC though and hooked the stock BCS to the non factory lines. He described a normal taper for an MBC.
gabedude is offline   Reply With Quote
Old 11-21-2008, 10:14 AM   #9
ThreeEleven
Scooby Specialist
 
Member#: 157894
Join Date: Aug 2007
Chapter/Region: MWSOC
Location: Saint Peters, MO
Vehicle:
2007 WRB WRX
EJ257

Default

Quote:
Originally Posted by 07Limited0306 View Post
alright i just looked them up, prodrive makes one for $100, that sound reasonable?
GM BCS is cheaper and quality
ThreeEleven is offline   Reply With Quote
Old 11-21-2008, 11:06 AM   #10
Ranatsu
Scooby Specialist
 
Member#: 87314
Join Date: May 2005
Chapter/Region: TXIC
Location: San Antonio
Vehicle:
2013 BRZ
Crystal Black Silica

Default

Gabe is referring to the stock 2 port system as a "bleed" system
the aftermarket 3 port systems can do bleed or whats called interrupt(blocking)

But honestly if you have the MBC hooked up properly and you have completely removed the stock solenoid from the loop, you shouldn't be really having any problems.. the turbo is going to taper it just can't spin fast enough.
Now if you have eratic type boost response where it goes up and down, then you have a problem.
Ranatsu is offline   Reply With Quote
Old 11-30-2008, 11:30 AM   #11
EFI Logics
Vendor
 
Member#: 193180
Join Date: Nov 2008
Chapter/Region: Tri-State
Location: Bethel, CT
Default

All I want to say, is be careful.. Since I left, those guys have almost no clue how to use the dyno, let alone diagnose a Subaru.. Anybody who was worth anything there, has left since the new ownership. If they set the dyno up improperly, then you will look like you have all sorts of issues. If the ramp time on the Dynapak is set too long, the boost will spike REALLY hard, and look like you have all sorts of problems. Also, I had no idea they had anybody to tune there yet? I didn't train anybody.

Please be careful, I know, because I had a day to train them how to use the dyno before I left. I had a friend call, and they are telling people that "Chris is on vacation" and are still booking appointments.. This is not cool at all because they are giving people the impression that I am still tuning out of there, which I haven't been for over a month now.

- Chris


Chris - Owner / Lead Calibrator
XX Tuning's former Tuner / Shop manager


Jack - Shop Foreman / Head of Race Car development / Motorsports division
XX Tuning's former Shop Foreman


EFI Logics.com / MySpace / "New" Interactive Dyno Database
Subaru / Porsche / Mitsubishi / Ford / GM
Mustang AWD500SE - 60mph wind Dyno cell

8 Sympaug Park Road : Bethel, CT 06801
Phone: 203.748.1115


EFI Cars:
2004 STi ST-2 #777 - 3 Time Class Winner / Watkins Glenn ST-2 track record holder.
2004 STi ST-2 #27 - 8 Time Class Winner / 2008 Points leader.
2006 Evo9 ST-2 #42 - 4 Time Class Winner
2005 Evo8 ST-2 #101 - 2 Time Class winner
EFI Logics is offline   Reply With Quote
Old 11-30-2008, 05:44 PM   #12
xxscaxx
Scooby Guru
 
Member#: 86459
Join Date: May 2005
Chapter/Region: Tri-State
Location: Campbell Hall, NY
Vehicle:
2013 BRZ
SWP

Default

^ wow, not cool at all. i was wondering what/who was taking over your place at xx. i actually forgot for a second that you werent at XX anymore and was going to tell the OP that im suprised chris didnt suggest a prodrive unit, and ditch the mbc like you did when i got tuned
xxscaxx is offline   Reply With Quote
Old 11-30-2008, 06:57 PM   #13
northmiler89
*** Banned ***
 
Member#: 157163
Join Date: Aug 2007
Chapter/Region: NESIC
Location: N. Kingstown, RI
Vehicle:
2008 STI
Silvarrrrrrrr!

Default

wow...
northmiler89 is offline   Reply With Quote
Old 12-02-2008, 11:27 PM   #14
EFI Logics
Vendor
 
Member#: 193180
Join Date: Nov 2008
Chapter/Region: Tri-State
Location: Bethel, CT
Default

Any updates?
EFI Logics is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
k so i WAS going to get my valve cover seals replaced... kaisersouse Normally Aspirated Powertrain 6 08-30-2005 08:24 PM
WAS going to get my 01 2.5RS today, but... Sko North West Impreza Club Forum -- NWIC 7 07-18-2005 09:21 AM
So i was going to get pizza and.... RSimport Mid Atlantic Impreza Club -- MAIC 24 01-24-2005 06:00 PM
[PICS] The sheet metal place I was going to get body armor from burned down today! Sean New England Impreza Club Forum -- NESIC 15 07-08-2004 01:21 PM
So...which one of you was going to get this for me? jackwei General Forum Archive 4 03-14-2001 03:34 PM

All times are GMT -4. The time now is 05:38 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.