Welcome to the North American Subaru Impreza Owners Club Friday December 15, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 06-15-2017, 09:36 AM   #26
MantisTobbogan
Scooby Newbie
 
Member#: 467886
Join Date: May 2017
Location: Baltimore
Vehicle:
1999 legacy outback

Default

jsully1130, any progress?
* Registered users of the site do not see these ads.
MantisTobbogan is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-12-2017, 05:11 PM   #27
MantisTobbogan
Scooby Newbie
 
Member#: 467886
Join Date: May 2017
Location: Baltimore
Vehicle:
1999 legacy outback

Default

none.
MantisTobbogan is offline   Reply With Quote
Old 07-12-2017, 05:12 PM   #28
MantisTobbogan
Scooby Newbie
 
Member#: 467886
Join Date: May 2017
Location: Baltimore
Vehicle:
1999 legacy outback

Subaru Stars

im about to junk this POS
MantisTobbogan is offline   Reply With Quote
Old 07-14-2017, 03:20 PM   #29
ouch1011
Scooby Newbie
 
Member#: 213408
Join Date: Jun 2009
Chapter/Region: NWIC
Location: Lynnwood, WA
Default

The ecm will adjust the timing and start cutting cylinders to reduce the idle speed if it cannot get it low enough by closing the iac. This is an old obd2 system so you can't always rely on it to set codes and tell you what is wrong. For testing purposes, I'd see if you can pinch off the IAC air supply hose and see if you can get the idle speed to drop. If the injector pulse comes back when you drop the idle speed, you at least know why it's losing injector pulse. Then just find out why it's idling high. I had this exact problem on my 98 lgt after doing a at>Mt swap. For some reason, the AT ecm would not idle correctly with the manual trans, and it would eventually start cutting cylinders to drop the idle. I believe I could have fixed it by adjusting the iac, but I ended up accidentally damaging the ecm during the process of testing and put in an Mt ecm. Idled fine after that.

Its also worth mentioning that if the timing is a little off between the cam and crank sensors, it will make the fuel injection do very strange things. I diagnosed a 97 outback that was running awful, black smoke out the exhaust and misfiring. I found that it was not firing the injector at all on one cylinder and running like 2-3x the expected injector pulse width on the other cylinder on that bank. The problem was that the timing on the cam that is monitored by the cam sensor (left intake cam I believe) was just a hair off. Put a timing belt on it and all was well (except that it trashed the cats)

Last edited by ouch1011; 07-14-2017 at 03:31 PM.
ouch1011 is offline   Reply With Quote
Old 07-22-2017, 12:46 PM   #30
MantisTobbogan
Scooby Newbie
 
Member#: 467886
Join Date: May 2017
Location: Baltimore
Vehicle:
1999 legacy outback

Default

i see very good information thank you very much. what range is too high for idle?
MantisTobbogan is offline   Reply With Quote
Old 09-04-2017, 10:38 PM   #31
shirako
Scooby Newbie
 
Member#: 346384
Join Date: Feb 2013
Chapter/Region: E. Canada
Location: Canada
Vehicle:
1999 Forester STI
Red Sedona

Default

Same problem here with my sf5 forester turbo.

No injector pulse at idle, i have 3 ecu and 2 set of injectors and same problem on injector 4.

On my jdm wrx ecu, i changed my injectors driver for new ones and same problem.

Can it be related to iacv? My only cel is P0270 (injector 4 low input). When i start the engine, it will run fine on 4 cylinders, but when the rpm drops, im only on 3 cylinders.

When i reset the ecu or swap it, car will run fine for 5 min, until the cel pops.


Last edited by shirako; 09-05-2017 at 07:55 PM.
shirako is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.