Welcome to the North American Subaru Impreza Owners Club Saturday January 16, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-10-2017, 02:44 PM   #1
SacKing23
Scooby Newbie
 
Member#: 78476
Join Date: Dec 2004
Location: Seattle, WA
Vehicle:
18 STI
DGM

Default Help. Brand new 18 STI – pulls to the right under acceleration

Hello! I just picked up my 18 STI yesterday. And I love it. Except one thing… The car seems to pull towards the right under acceleration. Doesn’t really matter the speed or road type. And it only happens while accelerating. The car/wheel will stay completely straight under braking or when cruising off the gas. But anytime the accelerator is applied, the car pulls to the right.

Please advise. Thanks in advance!
SacKing23 is offline   Reply With Quote
Old 07-10-2017, 02:48 PM   #2
bmxhotsauce
Scooby Specialist
 
Member#: 127099
Join Date: Sep 2006
Chapter/Region: BAIC
Vehicle:
02 IMPERZA WRX
BLACK

Default

Quote:
Originally Posted by SacKing23 View Post
Hello! I just picked up my 18 STI yesterday. And I love it. Except one thing… The car seems to pull towards the right under acceleration. Doesn’t really matter the speed or road type. And it only happens while accelerating. The car/wheel will stay completely straight under braking or when cruising off the gas. But anytime the accelerator is applied, the car pulls to the right.

Please advise. Thanks in advance!
you have a brand new car!! take it back to the dealership to fix it.
bmxhotsauce is offline   Reply With Quote
Old 07-10-2017, 03:13 PM   #3
Charlie-III
NASIOC Supporter
 
Member#: 30669
Join Date: Dec 2002
Chapter/Region: Tri-State
Location: USA, North NJ, 07456
Vehicle:
1998 Legacy 2.5GT
Silver Sleeper BK, 5MT

Default

Quote:
Originally Posted by bmxhotsauce View Post
you have a brand new car!! take it back to the dealership to fix it.
After checking tire pressures.
Charlie-III is offline   Reply With Quote
Old 07-10-2017, 04:18 PM   #4
Samurai Jack
Scooby Guru
 
Member#: 21145
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Not in my own time
Vehicle:
2002 Enemy of Aku

Default

Presuming this is still the same issue, ie; the factory hasn't changed anything:

Torque steer like this would occur due to the factory alignment settings. The Dealer will align to the Factory specs.

Once you verify your tire pressures are correct, you may want to find a reputable alignment shop in your area and have the alignment checked and reset.

Typical good alignment specs would be:
-1* camber
0* toe
maxout positive castor
Samurai Jack is offline   Reply With Quote
Old 07-10-2017, 04:47 PM   #5
rtv900
Scooby Guru
 
Member#: 428511
Join Date: Aug 2015
Location: philadelphia
Vehicle:
2016 STI

Default

mine pulls like hell when the tire pressure on a front wheel gets low, and it doesn't even need to be enough to trip the dash light.
But it pulls all the time, not just acceleration
rtv900 is offline   Reply With Quote
Old 07-10-2017, 05:30 PM   #6
SacKing23
Scooby Newbie
 
Member#: 78476
Join Date: Dec 2004
Location: Seattle, WA
Vehicle:
18 STI
DGM

Default

Quote:
Originally Posted by Samurai Jack View Post
Presuming this is still the same issue, ie; the factory hasn't changed anything:

Torque steer like this would occur due to the factory alignment settings. The Dealer will align to the Factory specs.

Once you verify your tire pressures are correct, you may want to find a reputable alignment shop in your area and have the alignment checked and reset.

Typical good alignment specs would be:
-1* camber
0* toe
maxout positive castor
Quote:
Originally Posted by rtv900 View Post
mine pulls like hell when the tire pressure on a front wheel gets low, and it doesn't even need to be enough to trip the dash light.
But it pulls all the time, not just acceleration
Thanks for all the replies. Would the car not pull during coasting and breaking (vs only when accelerating), if it was a pressure or alignment issue?
SacKing23 is offline   Reply With Quote
Old 07-10-2017, 11:00 PM   #7
Samurai Jack
Scooby Guru
 
Member#: 21145
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Not in my own time
Vehicle:
2002 Enemy of Aku

Default

Quote:
Originally Posted by SacKing23 View Post
Thanks for all the replies. Would the car not pull during coasting and breaking (vs only when accelerating), if it was a pressure or alignment issue?
It generally would not pull during coasting but remember that, depending on where you live, most roads are crowned so it could pull either way depending on which side of the road you are on.

Presuming nothing was wrong with the brakes, then it should not pull under braking
Samurai Jack is offline   Reply With Quote
Old 08-09-2017, 03:08 PM   #8
rtv900
Scooby Guru
 
Member#: 428511
Join Date: Aug 2015
Location: philadelphia
Vehicle:
2016 STI

Default

Quote:
Originally Posted by SacKing23 View Post
Thanks for all the replies. Would the car not pull during coasting and breaking (vs only when accelerating), if it was a pressure or alignment issue?
I doubt it.
I know mine pulls 100% of the time if there's a pressure issue.
I just had it for 10 days in a row from a leaky stem so every day the light would come on when I left work, but it would pull non stop.

If yours is just under acceleration it's probably something else.
rtv900 is offline   Reply With Quote
Old 08-09-2017, 03:24 PM   #9
JJay03
Scooby Newbie
 
Member#: 279061
Join Date: Apr 2011
Location: Cincinnati
Vehicle:
2018 WRX STI
Lapis Blue

Default

Mine pulled only under light acceleration with low pressure in one of the front tires. Is was not really that low though maybe 8-10lbs or so and did not trigger the tpms light.

Last edited by JJay03; 08-09-2017 at 03:33 PM.
JJay03 is offline   Reply With Quote
Old 08-10-2017, 12:32 PM   #10
BeantownWRX18
Scooby Newbie
 
Member#: 468095
Join Date: May 2017
Chapter/Region: NESIC
Location: Boston, MA
Vehicle:
2018 STI
CWP

Default

You're not alone. My 18' STI was one of the early ones to hit New England and I have this same problem. Checked tire pressure and it's all good. Taking it back to dealer
BeantownWRX18 is offline   Reply With Quote
Old 07-10-2017, 06:12 PM   #11
MedicDG
Scooby Specialist
 
Member#: 329822
Join Date: Aug 2012
Location: NorCal
Vehicle:
2016 STi
WRB

Default

Quote:
Originally Posted by SacKing23 View Post
Hello! I just picked up my 18 STI yesterday. And I love it. Except one thing… The car seems to pull towards the right under acceleration. Doesn’t really matter the speed or road type. And it only happens while accelerating. The car/wheel will stay completely straight under braking or when cruising off the gas. But anytime the accelerator is applied, the car pulls to the right.



Please advise. Thanks in advance!


Yes check tire pressure for sure! I run 38psi cold in all wheels.

But it's not tire pressure sounds like a alignment problem. Consider a good alignment shop that can make sure your camber is equal side to side and zero toe in all wheels.
MedicDG is offline   Reply With Quote
Old 07-10-2017, 08:27 PM   #12
PERRIN_Thomas
Former Vendor
 
Member#: 423601
Join Date: Jun 2015
Chapter/Region: NWIC
Location: Hillsboro,OR
Vehicle:
2016 WRX
LBP

Default

If the Tire pressure is good, then the belts in the a tire are bad and you need a new tire.
One way to test this is to rotate the tire to the back to see if it goes away,
PERRIN_Thomas is offline   Reply With Quote
Old 08-09-2017, 09:38 AM   #13
JJay03
Scooby Newbie
 
Member#: 279061
Join Date: Apr 2011
Location: Cincinnati
Vehicle:
2018 WRX STI
Lapis Blue

Default

Mine did this when the tire pressure was off even after the dealer assured me they checked it. If thats not it then your tires are probably bad. Someone on youtube with an 18 STI had their tires replaced for this issue.
JJay03 is offline   Reply With Quote
Old 08-09-2017, 02:51 PM   #14
Sarcoughaguy
Scooby Newbie
 
Member#: 472039
Join Date: Jul 2017
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
2018 STi Limited
LBP

Default

Quote:
Originally Posted by JJay03 View Post
Mine did this when the tire pressure was off even after the dealer assured me they checked it. If thats not it then your tires are probably bad. Someone on youtube with an 18 STI had their tires replaced for this issue.
Yep, there are a set of defective tires going around on the early models. You'll know if you move the tire and the problem moves with it. They can check the serial # and determine if it was made in week 13 I think?
Sarcoughaguy is offline   Reply With Quote
Old 08-10-2017, 11:03 PM   #15
sterling8080
Scooby Newbie
 
Member#: 410838
Join Date: Jan 2015
Default

Might be week 13 production tires. If so, your dealer will replace them.

sterling8080 is offline   Reply With Quote
Old 08-10-2017, 11:57 PM   #16
wrx43v3r
Scooby Newbie
 
Member#: 331119
Join Date: Sep 2012
Default

Lift more weights with your left arm only - this will even it out.
wrx43v3r is offline   Reply With Quote
Old 08-11-2017, 12:24 AM   #17
Marvick08GT
Scooby Newbie
 
Member#: 469091
Join Date: Jun 2017
Default

Quote:
Originally Posted by wrx43v3r View Post
Lift more weights with your left arm only - this will even it out.
I'm dying!
Marvick08GT is offline   Reply With Quote
Old 11-13-2017, 07:33 PM   #18
Prowizard
Scooby Newbie
 
Member#: 394682
Join Date: Jun 2014
Angry pulling

Just picked up my 2018 sti and mine is pulling to the left only when accelerating not flooring it just cruising but on the throttle. as soon as i just coast down a hill though it is straight as an arrow. i went to the dealer they did an alignment but it is still happening. Frustrated
Prowizard is offline   Reply With Quote
Old 11-14-2017, 10:06 AM   #19
Samurai Jack
Scooby Guru
 
Member#: 21145
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Not in my own time
Vehicle:
2002 Enemy of Aku

Default

Then take it back and tell them they didn't fix the problem.

That's what any reasonable person would with any shop.

Tell them to keep the car until they fix it properly and to give you a free loaner. After all, it's under a new car warranty.
Samurai Jack is offline   Reply With Quote
Old 11-17-2017, 09:11 AM   #20
rtv900
Scooby Guru
 
Member#: 428511
Join Date: Aug 2015
Location: philadelphia
Vehicle:
2016 STI

Default

is anything different suspension wise on the 18's?
That must be it because my 16 tracks dead nuts.
They were using Dunlop I believe for the stock tires in 16. Sportmaxxx I think they are.
rtv900 is offline   Reply With Quote
Old 11-26-2017, 05:35 AM   #21
enigma94
Scooby Newbie
 
Member#: 143254
Join Date: Mar 2007
Chapter/Region: SWIC
Location: East Mesa
Vehicle:
2007 STi
UGM

Default

I just purchased a 18 STi as well and am having the exact same issue where the car pulls pretty hard to the right under acceleration. So much so where the car feels unpredictable and unstable in turns if you let off the gas.

The odd thing is I test drove another car a couple weeks back at a different dealership and it did the exact same thing! Thinking it was related to that specific car only I didn't even test drive mine before purchasing it...

Has this been confirmed to be the tires??? Going to have to call the dealer Monday and see what they say...
enigma94 is offline   Reply With Quote
Old 11-29-2017, 04:10 PM   #22
some dude
Scooby Specialist
 
Member#: 100300
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: MIC|-|IG/\N
Vehicle:
06 WRX
CGM

Default

Would too much gear backlash in one of the wheels cause any pulling symptoms?
some dude is offline   Reply With Quote
Old 12-01-2017, 08:10 AM   #23
SnowmanCT
Scooby Newbie
 
Member#: 330110
Join Date: Aug 2012
Chapter/Region: Tri-State
Location: Stamford CT
Vehicle:
2017 STI Limited lip
LBP

Default

They should be checking for anything loose in the front suspension (ball joints, endlinks, etc.)... and if it moved when they swapped wheels - it could be a wheel (sounds like they only replaced the tires).
SnowmanCT is offline   Reply With Quote
Old 12-06-2017, 02:40 PM   #24
zzpatzz
Scooby Newbie
 
Member#: 477772
Join Date: Nov 2017
Default

+1 I would take it back to the dealership, but I always hate taking my car to the dealership...
zzpatzz is offline   Reply With Quote
Old 12-14-2017, 10:03 AM   #25
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: Bucks County, PA
Vehicle:
2021 Mazda 3 Turbo
1999 NB Miata

Default

I don't know why Subaru still bothers with the Yokohamas. Nearly everyone takes them off and goes with different tires or to all seasons. Mazda loves the Yokos too, and they're just as bad on them.

If they want to keep up with the competition they should just slap pilot super sports on at least the STi.
Obviously Tyler is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:45 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.