Welcome to the North American Subaru Impreza Owners Club Sunday August 9, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-31-2020, 04:03 PM   #1
Jatimatic
Scooby Newbie
 
Member#: 465830
Join Date: Apr 2017
Default Creaking noise coming from brakes...?

2017 WRX - 23k miles - stock suspension - 18" Hyperblue STI Wheels

Ive been dealing with this clicking sound (see video below) from my front left for some time. I can just sit there with the car parked and itll make that sound all day. Seemed to happen almost right after I put on the STi Wheels. I brought it to the dealer, they replaced the top strut mount and steering rack (after literally begging them to cover it under warranty).

Long story short, I picked it up yesterday after the steering rack was installed, get in it and the sound persists. I go back to the service manager he says "impossible" we go out and it immediately makes the noise. After messing with it for 15 mins, he pushed on the back aluminum plate behind the rotor and it quiets the sound a bit. He gets the tech and he says, "im working on another wrx right now thats doing the exact same thing, put the E brake up, take your foot off the brake and do it". Sure enough the sound went away.

Tech seems to think its something with the wrx calipers. I could take em apart, clean em and they will be back to normal for another 10k miles or so. Its just strange its just the one caliper...Anyone else having this issue?

https://www.reddit.com/r/WRX/comment..._see_comments/
* Registered users of the site do not see these ads.
Jatimatic is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-01-2020, 08:25 PM   #2
Jatimatic
Scooby Newbie
 
Member#: 465830
Join Date: Apr 2017
Default

Bump please help...I'm at wits end and it's making me hate my car
Jatimatic is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 06:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.