Welcome to the North American Subaru Impreza Owners Club Monday October 23, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-18-2013, 05:40 PM   #501
Louie
Scooby Guru
 
Member#: 43393
Join Date: Sep 2003
Chapter/Region: MAIC
Location: Middle River
Vehicle:
2014 Audi a6
Daytona Gray

Default

Quote:
Originally Posted by acumenhokie View Post
Dropped my car off to get a new snail installed.
What did you go with?
* Registered users of the site do not see these ads.
Louie is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-18-2013, 07:35 PM   #502
acumenhokie
Scooby Specialist
 
Member#: 271479
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Talleyville, DE
Vehicle:
2010 LGT
2009 FXT

Default

Quote:
Originally Posted by Louie View Post
What did you go with?
BNR 20G TD05

also doing ic, fuel pump, injectors, aos, ebcs, bpv, etc. etc.
acumenhokie is offline   Reply With Quote
Old 05-18-2013, 10:13 PM   #503
GoRabbit
Scooby Newbie
 
Member#: 251854
Join Date: Jul 2010
Chapter/Region: Tri-State
Location: Baltimore/Pittsburgh
Vehicle:
2013 WRX
SWP

Default

Dropping my car off to have the clear bra installed by Auto Armor Columbia
GoRabbit is offline   Reply With Quote
Old 05-18-2013, 10:19 PM   #504
prashanth
Scooby Specialist
 
Member#: 123534
Join Date: Aug 2006
Chapter/Region: MAIC
Location: Baltimore County
Vehicle:
2004 Forester XT
Gold

Default

Refinished old Volk Racing center caps and installed them on the car

prashanth is offline   Reply With Quote
Old 05-19-2013, 07:41 PM   #505
bluemax189
Scooby Specialist
 
Member#: 137405
Join Date: Jan 2007
Chapter/Region: MAIC
Location: Baltimore
Vehicle:
2011 WRX 6spd
GTX3076r

Default

Cleaned up the interior quite a bit.

bluemax189 is offline   Reply With Quote
Old 05-19-2013, 09:35 PM   #506
HinshawWRX
Medium Frank
Moderator
 
Member#: 140114
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Common Sense, VA
Vehicle:
2013 Audi
A6 3.0T

Default

Wash, wax, oil change. (Essentially)
HinshawWRX is offline   Reply With Quote
Old 05-19-2013, 10:23 PM   #507
needasubie10
Scooby Specialist
 
Member#: 234907
Join Date: Jan 2010
Chapter/Region: MAIC
Location: lexington,VA
Vehicle:
2002 wrx wagon
mbp

Default

Installed my front mount
needasubie10 is offline   Reply With Quote
Old 05-20-2013, 12:02 AM   #508
OrbitalEllipses
Scooby Guru
 
Member#: 178811
Join Date: Apr 2008
Chapter/Region: MAIC
Location: MoCo
Vehicle:
2011 White Corolla
Over 400hp

Default

Finished installing the Koni Yellows with RCE Yellow springs. Also installed rear SPC arms. Andrewtech alignment tomorrow. They can **** with the camber bolts because I'm not.

Last edited by OrbitalEllipses; 05-20-2013 at 12:30 AM.
OrbitalEllipses is offline   Reply With Quote
Old 05-20-2013, 12:15 AM   #509
ResidentR
Scooby Specialist
 
Member#: 281656
Join Date: May 2011
Chapter/Region: MAIC
Location: Centreville, VA
Vehicle:
2011 DGM WRX
5dr limited

Default

Wired in the serial cable to be able to log AFR on my AEM wideband! I think my tune can definitely be leaned out a little bit.
ResidentR is offline   Reply With Quote
Old 05-20-2013, 01:35 PM   #510
RavensFan7
Scooby Specialist
 
Member#: 346388
Join Date: Feb 2013
Chapter/Region: MAIC
Location: PA
Vehicle:
2001 Ej205 Impreza L
SRP

Default

Looked at my suspension.

98% sure I have a front strut leaking.

WTF!!?
RavensFan7 is offline   Reply With Quote
Old 05-20-2013, 03:04 PM   #511
bluemax189
Scooby Specialist
 
Member#: 137405
Join Date: Jan 2007
Chapter/Region: MAIC
Location: Baltimore
Vehicle:
2011 WRX 6spd
GTX3076r

Default

Cleaned up some more of the car. It was calling for rain so i didnt wash the bidy of the car and of course it doesnt rain.



bluemax189 is offline   Reply With Quote
Old 05-20-2013, 03:10 PM   #512
butterflyx3
Scooby Specialist
 
Member#: 293345
Join Date: Sep 2011
Chapter/Region: MAIC
Location: Lehigh Valley, PA
Vehicle:
2005 Forester
RBP

Default

Rolling the fenders on my car ^_^
butterflyx3 is offline   Reply With Quote
Old 05-20-2013, 06:05 PM   #513
yuephoria
NASIOC Supporter
 
Member#: 64624
Join Date: Jun 2004
Chapter/Region: MAIC
Location: Kensington, MD
Vehicle:
2008 FS XT
WR Blue Pearl

Default

Washed it over the weekend, but dressed the exterior trim and tires with Adam's Super VRT today. I also dusted and applied 303 Protectant to the interior.

Last edited by yuephoria; 05-21-2013 at 12:17 AM.
yuephoria is offline   Reply With Quote
Old 05-20-2013, 06:34 PM   #514
GoRabbit
Scooby Newbie
 
Member#: 251854
Join Date: Jul 2010
Chapter/Region: Tri-State
Location: Baltimore/Pittsburgh
Vehicle:
2013 WRX
SWP

Default

Clear bra installed couldn't be happier with the outcome.
GoRabbit is offline   Reply With Quote
Old 05-20-2013, 09:32 PM   #515
needasubie10
Scooby Specialist
 
Member#: 234907
Join Date: Jan 2010
Chapter/Region: MAIC
Location: lexington,VA
Vehicle:
2002 wrx wagon
mbp

Default

installed an 04 sti steering wheel on my 02 wagon
needasubie10 is offline   Reply With Quote
Old 05-21-2013, 10:42 AM   #516
RavensFan7
Scooby Specialist
 
Member#: 346388
Join Date: Feb 2013
Chapter/Region: MAIC
Location: PA
Vehicle:
2001 Ej205 Impreza L
SRP

Default

Checked oil
Added some brake fluid
Diagnosed a headlight issue.

Low beam doesn't work on the drivers side. Voltage at the pins on the plug are correct, and I swapped the passenger bulb which worked fine.

So its the drivers side bulb. Why only the low beam filament died, I have no clue.
RavensFan7 is offline   Reply With Quote
Old 05-21-2013, 10:47 AM   #517
Ahh Vtec
Scooby Newbie
 
Member#: 172456
Join Date: Feb 2008
Chapter/Region: MAIC
Vehicle:
2011 WRX Hatch
SWP

Default

Installed spark plugs last night and encountered a coil pack bolt that had become cross-threaded on the very last plug. It was a very hair-raising experience removing said bolt, but a tap and die later it's all good (fingers crossed).
Ahh Vtec is offline   Reply With Quote
Old 05-21-2013, 02:16 PM   #518
SlverEJ20
Scooby Specialist
 
Member#: 157158
Join Date: Aug 2007
Chapter/Region: MAIC
Location: Fairfax, Va
Vehicle:
05 WRX stage 2
PSM

Default

Quote:
Originally Posted by RavensFan7 View Post
Checked oil
Added some brake fluid
Diagnosed a headlight issue.

Low beam doesn't work on the drivers side. Voltage at the pins on the plug are correct, and I swapped the passenger bulb which worked fine.

So its the drivers side bulb. Why only the low beam filament died, I have no clue.
since low beams are used more often then the high beams, they usually burn out quicker
SlverEJ20 is offline   Reply With Quote
Old 05-21-2013, 02:53 PM   #519
prescottn6ft7
Scooby Specialist
 
Member#: 268918
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Virginia Beach, Virginia
Vehicle:
2007 WRX STi
Obsidian Black Pearl

Default

^ That and, it's very common to burn out just one filament... if both burn out then you've probably got a more serious issue than just the bulb.
prescottn6ft7 is offline   Reply With Quote
Old 05-21-2013, 05:51 PM   #520
RexNoob
Scooby Newbie
 
Member#: 311659
Join Date: Feb 2012
Chapter/Region: MWSOC
Location: Alliance, Oh
Vehicle:
2004 WRX
Java Black Pearl

Default

Painted my stock 16s with vht gold... Now it's pouring rain :/ hope it doesn't mess them up
RexNoob is offline   Reply With Quote
Old 05-21-2013, 06:21 PM   #521
RavensFan7
Scooby Specialist
 
Member#: 346388
Join Date: Feb 2013
Chapter/Region: MAIC
Location: PA
Vehicle:
2001 Ej205 Impreza L
SRP

Default

Quote:
Originally Posted by prescottn6ft7 View Post
^ That and, it's very common to burn out just one filament... if both burn out then you've probably got a more serious issue than just the bulb.
Oh, good to know.

I rewired both headlight plugs a couple months ago, and I almost died when I saw I had a low beam light out. Good thing it's just the bulb, cause there's not much factory wire left to rewire again
RavensFan7 is offline   Reply With Quote
Old 05-21-2013, 06:37 PM   #522
Uncle Tattoo
Scooby Guru
 
Member#: 139542
Join Date: Feb 2007
Chapter/Region: MAIC
Location: OOPHR (Poquoson, VA)
Vehicle:
2007 Civic Sedan
Daily driver status son

Default

Quote:
Originally Posted by RexNoob View Post
Painted my stock 16s with vht gold... Now it's pouring rain :/ hope it doesn't mess them up
Looks great!
Uncle Tattoo is offline   Reply With Quote
Old 05-21-2013, 06:47 PM   #523
RexNoob
Scooby Newbie
 
Member#: 311659
Join Date: Feb 2012
Chapter/Region: MWSOC
Location: Alliance, Oh
Vehicle:
2004 WRX
Java Black Pearl

Default

Quote:
Originally Posted by Uncle Tattoo View Post

Looks great!
Heck of a lot better than they did that's for sure, I just did a quick job though needs more coats. I had to hurry before it dumped rain on me. Now I need to get these wheel spacers to fit :P
RexNoob is offline   Reply With Quote
Old 05-22-2013, 08:07 AM   #524
lilblue619
Scooby Specialist
 
Member#: 288292
Join Date: Jul 2011
Chapter/Region: MAIC
Location: arbutus md
Vehicle:
2004 sti
wrb. the blue one.

Default

Painted my last two torque's yesterday. No rain tho
lilblue619 is offline   Reply With Quote
Old 05-22-2013, 09:23 AM   #525
prescottn6ft7
Scooby Specialist
 
Member#: 268918
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Virginia Beach, Virginia
Vehicle:
2007 WRX STi
Obsidian Black Pearl

Default

Quote:
Originally Posted by Uncle Tattoo View Post
Looks great!

I second this! Looks really clean!
prescottn6ft7 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.