Welcome to the North American Subaru Impreza Owners Club Thursday October 19, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 06-26-2013, 06:52 AM   #776
mhoerath
Scooby Specialist
 
Member#: 131379
Join Date: Nov 2006
Chapter/Region: MAIC
Location: richmond, va
Vehicle:
2003 354 [email protected] rpm
justablue hatch

Default

well last fri, sat and sun

on the way to summit point my wingman noticed smoke coming from my car. checked and found a split cv boot, grease on downpipe. pulled off at next exit and BAM pulled into a tractor supply. purchased lithium grease, blue towels, nitrile gloves and gorilla tape. also bought a pair of muck boots for $19.

we had tool kits/jacks/jackstands with us, standard when going racing. found a shady spot. put grease into cv. cut the boot calf section and wrapped 1.5 times around the green can and hose clamped. gorilla taped all the way to the outer section. hose clamped around axle. rx'd all day sat and sun, drove 200 miles home and the temp is still there.
* Registered users of the site do not see these ads.
mhoerath is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-26-2013, 05:30 PM   #777
CamaroFS34
Scooby Guru
 
Member#: 6850
Join Date: May 2001
Chapter/Region: MAIC
Location: SoBWI, MD
Vehicle:
1996 Camaro Z28 1LE
& 2006 IAG WRX

Default

Decided to swing by IAG to see if the exhaust leak Pat recognized yesterday could be fixed. Managed to hit a sweet spot of down time and got the car on the lift right away.
CamaroFS34 is offline   Reply With Quote
Old 06-26-2013, 06:21 PM   #778
Smurftastic
Scooby Guru
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
02 | BLOD Founding
Member | TopScoob 031

Default

Quote:
Originally Posted by EvileyeZ88 View Post
I see what you did there

The sneak peek I got looks great!
Thanks man... the changes really highlight a lot of imperfections I need to work on before the meet :\ Oh well I have some time.

PS: that sheet metal I'm giving you would also work well for a rad shroud *wiggily eyebrows*
Smurftastic is offline   Reply With Quote
Old 06-26-2013, 08:38 PM   #779
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2015 WRB WRX Limited
2007 WRX Limited (sold)

Default

Quote:
Originally Posted by CamaroFS34 View Post
Decided to swing by IAG to see if the exhaust leak Pat recognized yesterday could be fixed. Managed to hit a sweet spot of down time and got the car on the lift right away.
Anytime is a sweet spot for you there
96accord is offline   Reply With Quote
Old 06-26-2013, 08:59 PM   #780
pkoep002
Scooby Newbie
 
Member#: 355506
Join Date: May 2013
Chapter/Region: MAIC
Location: Newport News, Va
Vehicle:
2013 WRX Hatch
WRB

Default

Installed some supertones. Pretty satisfied with the volume increase. Loud horns are a must in Hampton Roads.
pkoep002 is offline   Reply With Quote
Old 06-26-2013, 10:02 PM   #781
jewbaru42
Scooby Newbie
 
Member#: 265098
Join Date: Nov 2010
Chapter/Region: MAIC
Location: virginia beach virginia
Vehicle:
2003 wrx
silver w/ blk enkei rims

Default

New process west TMIC knock off. I've heard horror stories with these but honestly, not too bad. About a 4 hour install due to some fabrication/[email protected]&$ up repair/excuse to use j-b weld hahahaha.
Started with this:

Then went to this:

Then did this:

End result was this:

Very satisfied with it. Huge spool time and idle boost level difference
jewbaru42 is offline   Reply With Quote
Old 06-26-2013, 10:16 PM   #782
carnz-pj-410
Scooby Specialist
 
Member#: 110994
Join Date: Mar 2006
Chapter/Region: MAIC
Location: Atlantic
Vehicle:
2x 95 Impreza 2DR
one swapped, one DD

Default

fixed the AC in my outback finally
carnz-pj-410 is online now   Reply With Quote
Old 06-26-2013, 10:38 PM   #783
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2015 WRB WRX Limited
2007 WRX Limited (sold)

Default

Quote:
Originally Posted by carnz-pj-410 View Post
fixed the AC in my outback finally
Hope you didn't just fix it at 10pm.. Today was one of the hottest days in a while..
96accord is offline   Reply With Quote
Old 06-26-2013, 10:44 PM   #784
carnz-pj-410
Scooby Specialist
 
Member#: 110994
Join Date: Mar 2006
Chapter/Region: MAIC
Location: Atlantic
Vehicle:
2x 95 Impreza 2DR
one swapped, one DD

Default

Quote:
Originally Posted by 96accord View Post
Hope you didn't just fix it at 10pm.. Today was one of the hottest days in a while..
lol nah, stayed after work and fixed it. i have an electrical problem with my hvac control panel, bypassed most of it so i now have the fan speed control and a/c on/off control.

i need to goto a junkyard and get an old outback hvac panel that works properly, def not buying one new after checking my price on it
carnz-pj-410 is online now   Reply With Quote
Old 06-27-2013, 11:50 AM   #785
CamaroFS34
Scooby Guru
 
Member#: 6850
Join Date: May 2001
Chapter/Region: MAIC
Location: SoBWI, MD
Vehicle:
1996 Camaro Z28 1LE
& 2006 IAG WRX

Default

Quote:
Originally Posted by 96accord View Post
Anytime is a sweet spot for you there
Not during the week before a tuning weekend, it isn't!
CamaroFS34 is offline   Reply With Quote
Old 06-27-2013, 04:17 PM   #786
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2015 WRB WRX Limited
2007 WRX Limited (sold)

Default

Quote:
Originally Posted by CamaroFS34 View Post
Not during the week before a tuning weekend, it isn't!
Well most of the time
96accord is offline   Reply With Quote
Old 06-27-2013, 09:14 PM   #787
Bluemachine
Scooby Specialist
 
Member#: 302496
Join Date: Nov 2011
Chapter/Region: MAIC
Location: Gaithersburg
Vehicle:
2016 STI LIMITED
WRB

Default

Finnaly detailed after 1 month no bath,plus generator installed was gonna color match. Flat black grew on me

Last edited by Bluemachine; 06-28-2013 at 01:43 PM.
Bluemachine is offline   Reply With Quote
Old 06-27-2013, 09:30 PM   #788
carnz-pj-410
Scooby Specialist
 
Member#: 110994
Join Date: Mar 2006
Chapter/Region: MAIC
Location: Atlantic
Vehicle:
2x 95 Impreza 2DR
one swapped, one DD

Default

Installed my new cp pistons in my new shortblock today. Hope to have the engine in by the weekend
carnz-pj-410 is online now   Reply With Quote
Old 06-27-2013, 11:46 PM   #789
yuephoria
NASIOC Supporter
 
Member#: 64624
Join Date: Jun 2004
Chapter/Region: MAIC
Location: Kensington, MD
Vehicle:
2008 FS XT
WR Blue Pearl

Default

Andrewtech installed a new Koyo radiator, Samco radiator hoses, and performed an oil change on my Forester. Great guys!
yuephoria is offline   Reply With Quote
Old 06-28-2013, 09:05 AM   #790
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Ordered brake motive F/R drilled slotted rotors, stop tech brake pads, stop tech F/R ss brake lines, and fog lights for the Wrx.

Ordered a front fender for the 99 outback sport, and am now on the hunt for a front passenger door.

~Evil

Last edited by EvileyeZ88; 06-28-2013 at 12:14 PM.
EvileyeZ88 is offline   Reply With Quote
Old 06-28-2013, 03:46 PM   #791
Matt_H
Scooby Guru
 
Member#: 107000
Join Date: Feb 2006
Chapter/Region: MAIC
Location: Bristow, VA
Vehicle:
2015 BMW X1

Default

That feeling.

Matt_H is offline   Reply With Quote
Old 06-28-2013, 07:09 PM   #792
tnguyen600
Scooby Newbie
 
Member#: 284699
Join Date: Jun 2011
Chapter/Region: Tri-State
Location: Philadelphia, PA
Vehicle:
2013 Impreza WRX STi

Default

I just got back from IAG today. Drove down yesterday so they could install my ewg, downpipe, injectors, fuel pump, ebcs, and fuel reg. Protune earlier today with Jorge. Assuming nothing blows up...I couldn't be happier =]
tnguyen600 is offline   Reply With Quote
Old 06-29-2013, 12:54 AM   #793
Oaf02Z
Scooby Specialist
 
Member#: 263219
Join Date: Nov 2010
Chapter/Region: MAIC
Location: NOVA
Default

Oaf02Z is offline   Reply With Quote
Old 06-29-2013, 12:58 AM   #794
locozildjiangodx
Scooby Newbie
 
Member#: 355323
Join Date: May 2013
Chapter/Region: MAIC
Location: Fairfax, VA
Vehicle:
2013 WRX Limited HB
WR Blue

Default

attempted installing SWC and HU....didnt go great. Need to troubleshoot the ASWC-1...blech
locozildjiangodx is offline   Reply With Quote
Old 06-29-2013, 06:49 AM   #795
Louie
Scooby Guru
 
Member#: 43393
Join Date: Sep 2003
Chapter/Region: MAIC
Location: Middle River
Vehicle:
2014 Audi a6
Daytona Gray

Default

Quote:
Originally Posted by locozildjiangodx View Post
attempted installing SWC and HU....didnt go great. Need to troubleshoot the ASWC-1...blech
I bought mine per programmed. If you don't have use of your hands free buttons for phone use...that's normal, you'll never get them back (for phone use).
Louie is offline   Reply With Quote
Old 06-29-2013, 10:21 AM   #796
13MRCWRX13
Scooby Newbie
 
Member#: 341686
Join Date: Dec 2012
Chapter/Region: MAIC
Location: Bowleys Quarters MD
Vehicle:
2013 Swagon
WRB WRX 6 speed swap

Default

at IAG right now getting ready for a new pump and race fuel tune
13MRCWRX13 is offline   Reply With Quote
Old 06-29-2013, 11:02 AM   #797
locozildjiangodx
Scooby Newbie
 
Member#: 355323
Join Date: May 2013
Chapter/Region: MAIC
Location: Fairfax, VA
Vehicle:
2013 WRX Limited HB
WR Blue

Default

Quote:
Originally Posted by Louie View Post
I bought mine per programmed. If you don't have use of your hands free buttons for phone use...that's normal, you'll never get them back (for phone use).
Right now some other things are wonky. When I try to manually program it, I can't get the solid red light, it goes solid green. I checked the wire flashes and HU flashes codes and theyre good. The Mode button puts my Pioneer into "ATT Mode" for a second (I think that is because it's trying to mute it, but Pioneer doesn't mute? Same with the PTT button). Mainly if I can get it into manual program mode I think I'll be ok. Going to fiddle more today. This thing is a jerk to fiddle with though.
locozildjiangodx is offline   Reply With Quote
Old 06-29-2013, 12:10 PM   #798
lilblue619
Scooby Specialist
 
Member#: 288292
Join Date: Jul 2011
Chapter/Region: MAIC
Location: arbutus md
Vehicle:
2004 sti
wrb. the blue one.

Default

Changed my oil.
lilblue619 is offline   Reply With Quote
Old 06-29-2013, 12:15 PM   #799
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Quote:
Originally Posted by lilblue619 View Post
Changed my oil.
That reminds me I need to do that as well. Off to the driveway.
EvileyeZ88 is offline   Reply With Quote
Old 06-29-2013, 12:17 PM   #800
roccer
Scooby Specialist
 
Member#: 113674
Join Date: Apr 2006
Chapter/Region: MAIC
Location: Fairfax, VA
Vehicle:
2006 WRX Limited
WRB, 358whp/387wtq

Default

This:


+ patience, an old t-shirt, some microfiber cloths =

this:


most of the road rash on the front of the hood is gone. still need to go to town with the tiny brushes to do the other chips around the car (but not today as i only prepped the hood. rest of the car needs to be washed first).

at some point, if i have enough left, ill tackle the road rash on the bumper.
roccer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.