Welcome to the North American Subaru Impreza Owners Club Sunday December 9, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-06-2018, 01:23 AM   #1
RNFNR
Scooby Newbie
 
Member#: 366956
Join Date: Aug 2013
Chapter/Region: E. Canada
Location: NL, Canada
Vehicle:
2013 Impreza Sport
Crystal Black

Default EPS Problem.

Good evening folks.
Iíve been searching (NASIOC, YouTube, google etc) on and off for quite some time now without finding a solution. Nobody seems to have the same issue Iím having. 2013 Impreza Sport.
-While parking, or starting the car in the morning, the steering wheel cranks itself fully to the left, and is hard to turn right.
-While driving, I can let go of the wheel and the car will track perfectly straight. However Still hard to make a tight right turn.
Itís been doing this for a while, and Iíve just learned to cope with it. However my wife is driving the car more often now and Iíd like to fix it for her, but as itís EPS, not mechanical steering, Iím stumped. Any help or suggestions is greatly appreciated. Thanks.
* Registered users of the site do not see these ads.
RNFNR is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-06-2018, 04:27 AM   #2
Commander Keen
Scooby Specialist
 
Member#: 319157
Join Date: May 2012
Chapter/Region: MAIC
Vehicle:
2012 Impreza 4DR 5MT

Default

Maybe you can try for a goodwill repair.

Considering how dangerous this could become, I'm guessing Subaru would be very interested.

Think about pulling the fuse until you can get it looked at.

Last edited by Commander Keen; 07-06-2018 at 04:35 AM.
Commander Keen is offline   Reply With Quote
Old 07-06-2018, 07:17 PM   #3
RNFNR
Scooby Newbie
 
Member#: 366956
Join Date: Aug 2013
Chapter/Region: E. Canada
Location: NL, Canada
Vehicle:
2013 Impreza Sport
Crystal Black

Default

It’s a long shot, but not a bad idea. Hoping I can figure it out before it comes to that. I’m sure they’d find a way to charge me for something. Lol. But I think I will try pulling the fuse, just in case.
RNFNR is offline   Reply With Quote
Old 10-27-2018, 11:46 AM   #4
FFWD
Scooby Newbie
 
Member#: 450778
Join Date: Jul 2016
Chapter/Region: E. Canada
Vehicle:
2012 Impreza Sedan

Default

Did you ever resolve this, and what was the problem?
FFWD is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:11 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.