Welcome to the North American Subaru Impreza Owners Club Monday February 19, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-25-2003, 06:34 PM   #1
SPeeDSiN
Scooby Specialist
 
Member#: 4667
Join Date: Mar 2001
Location: Asheville, NC
Vehicle:
2002 WRX
Black (well kinda)

Default My STI injectors aren't STI injectors???

I have been trying to diagnose some troubles with my car.
Basically, I have stg2 + injectors + uppipe.
So when I went to get my car tuned at Knowledge, instead of taking out fuel, they were adding it. Weird huh?
So we started tryint to figure out why. Maybe the MAF was bad. So I replaced that, and still got the same voltage readings.
So TXS and Knowledge told me to check my fuel pressure, cause the STI's shouldn't really even idle that well on a stage 2 map.
Well I checked the fuel pressure, and it was between 45 and 47 psi.
So they told me that there have been a few cases where the STI injectors weren't 560cc but actually stock (or something to that affect)

I wanted to know if anyone else has run into this problem.
* Registered users of the site do not see these ads.
SPeeDSiN is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-25-2003, 08:33 PM   #2
alltractionWRX
Scooby Newbie
 
Member#: 14819
Join Date: Jan 2002
Location: SoCal
Vehicle:
2002 WRX
WR Blue

Default

hmm that's interesting where did you buy your injectors from. Was the box an authentic subaru box?
alltractionWRX is offline   Reply With Quote
Old 04-25-2003, 10:00 PM   #3
Si2WRX
Scooby Specialist
 
Member#: 13173
Join Date: Dec 2001
Location: Atlanta, GA
Vehicle:
309 hp on 93 + W/I
on Dyno Dynamics

Default

Here's the p/n from my injector box: 1611AA510 These are definitely the 565cc (also have seen as 550cc) STi injectors.

Perhaps you still have the packaging as a cross-reference.

Lots of good info here too: http://www.northursalia.com/parts/partswrx.html

Notice the p/n 16611AA231 ... 480cc Legacy STi injectors. Would those fit an EJ20? Not much bigger than the stock 440cc ... hmm.
Si2WRX is offline   Reply With Quote
Old 04-26-2003, 01:21 AM   #4
Imprezd
Scooby Specialist
 
Member#: 3357
Join Date: Dec 2000
Chapter/Region: MAIC
Location: Gburg, Maryland (East Coast)
Vehicle:
2002 WRX
Black

Default

check the vaccum line going to the fuel pressure regulator. It is likely that your fuel pressure is not be raised because your regulator vaccum line is severed or disconnected. Worth a shot...

Imprezd~
Imprezd is offline   Reply With Quote
Old 04-26-2003, 05:35 AM   #5
alltractionWRX
Scooby Newbie
 
Member#: 14819
Join Date: Jan 2002
Location: SoCal
Vehicle:
2002 WRX
WR Blue

Default

Quote:
Originally posted by Si2WRX
Here's the p/n from my injector box: 1611AA510 These are definitely the 565cc (also have seen as 550cc) STi injectors.

Perhaps you still have the packaging as a cross-reference.

Lots of good info here too: http://www.northursalia.com/parts/partswrx.html

Notice the p/n 16611AA231 ... 480cc Legacy STi injectors. Would those fit an EJ20? Not much bigger than the stock 440cc ... hmm.
Yeah that's weird because Ninos auto accessories sold me 550cc and they are a reputable shop so they wouldn't rip me off. Maybe he just wrote the wrong number on the boards.
alltractionWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB: STi pink injectors/ 07 STI injectors/ 06 WRX injectors bwco VIC Private Classifieds 8 06-19-2013 11:40 PM
how will my WRX run on STi injectors w/stock ECU (no piggyback/reflash, etc) annointed Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 13 04-10-2004 10:14 AM
How do i adjust my utec to 565 Sti injectors? kdogpenny1 Newbies & FAQs 2 02-10-2004 11:45 AM
Why aren't Sti springs and 04 wrx sedan springs compatible? kitbar Brakes, Steering & Suspension 16 10-16-2003 01:02 PM
My Tail lights aren't working CerealKilher Interior & Exterior Modification 2 06-13-2002 06:08 PM

All times are GMT -4. The time now is 09:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.