Welcome to the North American Subaru Impreza Owners Club Saturday June 23, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-15-2017, 10:52 AM   #51
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by shook187 View Post
It's for a 2016 premium with a 6.2 starlink.

Talking about this harness
https://uploads.tapatalk-cdn.com/201...1382df197d.jpg
Since you already have the Metra AX-SUB28SWC-6V, you don't need that other 28-pin harness (from autoharnesshouse).

The AX-SUB28SWC-6V has the correct rear camera wiring for cars with the OEM 6.2" HUs. You'll need to cut off the integrated 12-pin plug intended for an ASWC-1, and connect the 3 SWC wires from the 28-pin to the Maestro's harness. The Maestro will also need 12V power and ground from the 70-1761.

However, since you got the Maestro RR, you won't need the 6V power converter in the AX-SUB28SWC-6V either. If you can return that, there is an alternate 28-pin harness without the ASWC portion or 6V converter, and which doesn't have the problem with the terminals being too long (that many people have complained about -- search for the numerous posts on NASIOC about that).
* Registered users of the site do not see these ads.
SVXdc is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-15-2017, 12:56 PM   #52
shook187
Scooby Newbie
 
Member#: 418049
Join Date: Apr 2015
Default

Quote:
Originally Posted by SVXdc View Post
Since you already have the Metra AX-SUB28SWC-6V, you don't need that other 28-pin harness (from autoharnesshouse).

The AX-SUB28SWC-6V has the correct rear camera wiring for cars with the OEM 6.2" HUs. You'll need to cut off the integrated 12-pin plug intended for an ASWC-1, and connect the 3 SWC wires from the 28-pin to the Maestro's harness. The Maestro will also need 12V power and ground from the 70-1761.

However, since you got the Maestro RR, you won't need the 6V power converter in the AX-SUB28SWC-6V either. If you can return that, there is an alternate 28-pin harness without the ASWC portion or 6V converter, and which doesn't have the problem with the terminals being too long (that many people have complained about -- search for the numerous posts on NASIOC about that).
Where can I get this alternative harness without the PIN issue?
shook187 is offline   Reply With Quote
Old 01-01-2018, 02:22 AM   #53
nz suby 1996
Scooby Newbie
 
Member#: 479939
Join Date: Jan 2018
Default

Quote:
Originally Posted by SVXdc View Post
There is an alternate AM/FM+XM antenna "feeder cord" you can use to retain the factory rooftop XM antenna, to use with an aftermarket SiriusXM tuner box. See my post in the huge 2016 WRX thread.
hey SVXdc, ive looked on your thread as ive installed a new jvc headunit, i have a 96 wrx wagon, ive cut the factory plug off to install the radio into it now, but since then the keyless entry doesn't work, does it need a certain wire to remain powered?
nz suby 1996 is offline   Reply With Quote
Old 01-05-2018, 08:07 PM   #54
sacricide
Scooby Newbie
 
Member#: 480180
Join Date: Jan 2018
Location: CA
Vehicle:
2015 WRX
black

Default

im looking for something like this, my stock nav unit has too many bluetooth compatibility issues on android 8.1. ive never done an install trying to retain steering controls, daunting isnt a encouraging word lol
sacricide is offline   Reply With Quote
Old 01-24-2018, 12:19 PM   #55
shook187
Scooby Newbie
 
Member#: 418049
Join Date: Apr 2015
Default

Quote:
Originally Posted by phd12v View Post
just an update: i finally got to see our RR harness for the new platform. It needed one little revision and we are looking at possibly early february for availability.
Any new info?
shook187 is offline   Reply With Quote
Old 01-25-2018, 11:03 AM   #56
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default

should be within a week or two
phd12v is offline   Reply With Quote
Old 01-25-2018, 03:04 PM   #57
knstyl
Scooby Newbie
 
Member#: 479979
Join Date: Jan 2018
Chapter/Region: Tri-State
Location: Brooklyn, NY
Vehicle:
2016 STi
WRB

Default

Quote:
Originally Posted by phd12v View Post
should be within a week or two
Can't wait!
knstyl is offline   Reply With Quote
Old 01-25-2018, 08:18 PM   #58
shook187
Scooby Newbie
 
Member#: 418049
Join Date: Apr 2015
Default

Quote:
Originally Posted by phd12v View Post
should be within a week or two
What's going to be the benefit compared to what we have now? I'm debating if I should just wait for this harness or go ahead and install what I have
shook187 is offline   Reply With Quote
Old 02-12-2018, 03:33 AM   #59
jonizzzle
Scooby Newbie
 
Member#: 457782
Join Date: Nov 2016
Chapter/Region: MAIC
Vehicle:
2016 WRX Limited
Ice Silver Metallic

Default

Quote:
Originally Posted by phd12v View Post
should be within a week or two


Any updates? Iím really interested in utilizing the RR!
jonizzzle is offline   Reply With Quote
Old 02-13-2018, 11:04 PM   #60
CXVninja84
Scooby Newbie
 
Member#: 438216
Join Date: Jan 2016
Default

Quote:
Originally Posted by ZsmithWrx View Post
That looks fantastic! I want to confirm that the diagram you made is for the pioneer 4200 nex correct
It looks like the diagram is generic for any radio. Normally the wires for speakers/+12V/ground on the Metra 70-1761 will match the colors on the harness of the unit you're installing (I'm sure this is the case for Pioneer)

I will note that this harness is handy if you're installing a Pioneer. It has the Pioneer connector already wired in for you:
https://www.amazon.com/dp/B078GBDRVX
(It worked great for my Pioneer AVIC-5200NEX)
CXVninja84 is offline   Reply With Quote
Old 02-14-2018, 10:30 AM   #61
knstyl
Scooby Newbie
 
Member#: 479979
Join Date: Jan 2018
Chapter/Region: Tri-State
Location: Brooklyn, NY
Vehicle:
2016 STi
WRB

Default

Quote:
Originally Posted by CXVninja84 View Post
It looks like the diagram is generic for any radio. Normally the wires for speakers/+12V/ground on the Metra 70-1761 will match the colors on the harness of the unit you're installing (I'm sure this is the case for Pioneer)

I will note that this harness is handy if you're installing a Pioneer. It has the Pioneer connector already wired in for you:
https://www.amazon.com/dp/B078GBDRVX
(It worked great for my Pioneer AVIC-5200NEX)
What other connector did you use for the backup camera? I assume backup cam and aux inputs are the only connectors missing from this harness.
knstyl is offline   Reply With Quote
Old 02-14-2018, 11:56 PM   #62
CXVninja84
Scooby Newbie
 
Member#: 438216
Join Date: Jan 2016
Default

I used the AutoHarnessHouse.com 28-pin harness which includes wires for the steering wheel buttons, the backup camera setup, and a couple other things. You'll also need a separate USB adapter and AM/FM adapter.

You can connect the Maestro SW directly to the wires on the 28-pin harness and to the power wires on the harness from my link above.
CXVninja84 is offline   Reply With Quote
Old 04-22-2018, 06:37 AM   #63
Chemguy34
Scooby Newbie
 
Member#: 484988
Join Date: Apr 2018
Default

Great information here. I just got a 2016 OB and the Starlink is just terrible. Appreciate you posting this.
Chemguy34 is offline   Reply With Quote
Old 05-27-2018, 01:55 AM   #64
traiviet
Scooby Newbie
 
Member#: 486466
Join Date: May 2018
Default

Quote:
Originally Posted by SVXdc View Post
Possibly. What car year and model do you have? (please add that to your profile here). What is the model number printed on the front of the factory HU?

If you have one of the 7" OEM HUs, you'll need a separate 5-pin harness to retain your OEM rear camera.

I don't know where you heard anything about a 32-pin connector, but none of the recent Subaru models have anything for the HU with that many pins.

In any case, you can remove the blue wire from that Metra antenna adapter (your car does not use that pin). You can also remove the short blue loop wire on the 70-1761 (be careful to not damage the longer blue wire that it's crimped onto).
Hi SVXdc,

I have a 2018 Forester Premium with 7" screen with Starlink, Model of HU is FF679UM. My replacement unit is Pioneer AVIC 8200NEX . I tried to install the Maestro SW with all the parts that shook187 has, and it came up with 2 issues:

1 - There is no backup camera signal (OEM Camera)
2 - No front speakers sound

You mentioned "If you have one of the 7" OEM HUs, you'll need a separate 5-pin harness to retain your OEM rear camera." Where does this harness connect to? Do you think AutoHarnessHouse has it?

Regarding the sound issue, Do you think the harness is defective? Is the Blue loop wire the culprit?

Please advise. Thank you so much.

Last edited by traiviet; 05-27-2018 at 10:57 AM.
traiviet is offline   Reply With Quote
Old 05-29-2018, 11:04 PM   #65
Furlybird
Scooby Newbie
 
Member#: 459433
Join Date: Dec 2016
Default

This is an amazing post,

I did the Apex V2 Headunit, and juiced it up with an Alpine Power Pack 445u.
Polk Audio DB Components front,
JBL GTO Rears

JL Audio 10 inch ported sub.
Furlybird is offline   Reply With Quote
Old 05-30-2018, 11:30 AM   #66
Altitude909
Scooby Newbie
 
Member#: 481712
Join Date: Feb 2018
Default

Quote:
Originally Posted by traiviet View Post
..

1 - There is no backup camera signal (OEM Camera)
2 - No front speakers sound

...
Check the voltage requirements for the camera, the harness i got from autoharnesshouse had a voltage converter for the camera built in
Altitude909 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.