Welcome to the North American Subaru Impreza Owners Club Wednesday May 22, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-10-2019, 10:14 PM   #1
pyraxv
Scooby Newbie
 
Member#: 493972
Join Date: Nov 2018
Vehicle:
2002 built wrx/sti
grey

Default No Oil Pressure!!

Hey guys. i just finished my hybrid wrx build with an 11mm Orbit pump.

I have tried almost everything including filling the bottom of the pump through the bolts with assembly lube, cranking the engine over for 30 seconds to a minute, and taking off the oil filter.

I installed the pump completely dry. no lube whatsoever. Ive tried over and over again but nothing. Its a brand new pump. How can i get oil pressure?

heres a video

* Registered users of the site do not see these ads.
pyraxv is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-16-2019, 01:36 AM   #2
Fierysun
Scooby Guru
 
Member#: 82745
Join Date: Mar 2005
Chapter/Region: SCIC
Location: So Cal
Vehicle:
2005 Subaru STI
2003 EJ207 S204 Wagon

Default

Fierysun is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:35 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.