Welcome to the North American Subaru Impreza Owners Club Tuesday July 25, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > FA Series Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-22-2017, 01:37 PM   #376
tANNERRRR
Scooby Newbie
 
Member#: 246620
Join Date: May 2010
Chapter/Region: SCIC
Location: Southern CA
Vehicle:
2017 WRX
CWP

Default

Quote:
Originally Posted by dimaevt View Post
I have a question in regards to not hitting boost until the car is up to temperature:

What if I hit minimal boost, like 2, 3 or 4 psi? I try not to go above 3k RPM when my oil temp is below 180, but I ocasionally shift slightly above 3k and end up hitting a couple psi of boost. Is that at all bad? If so, i'll really try to shift at around 2500, even though its obnoxious for me to shift at such a low rpm
You're fine. I usually shift 3-3.5k before its warmed up but I usually don't even get into boost. As long as youre not going WOT and hitting 18 psi, you're good.
* Registered users of the site do not see these ads.
tANNERRRR is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-22-2017, 06:04 PM   #377
fuegodeth
Scooby Newbie
 
Member#: 65249
Join Date: Jun 2004
Location: Conroe, TX
Vehicle:
2016 WRX Premium
WRC Blue

Default

16 WRX all stock so far. 53,000 miles so far. Only issue I've had is a couple of times it didn't want to start this summer. battery was acting weak, and it was right after driving it, and then had a short stop at a store. No lights left on. Read around and it seems the ECU likes to reduce alternator output when the engine is pulling hard. That sounds about right, as I flog on this car daily. I have since the first miles. Anyway the fix is to run the headlights on all the time as it forces the alternator to keep working. I'll get a new batt in the near future. However, other than that the car has been perfect. I have had all services done at dealership, and kept it stock. Dealer keeps putting different mileage intervals on my sticker. Previous one was 8000, the next was 6,000, and this one is showing 7,000 miles to service. Do they do that on purpose, or are they making an error there. I usually get it done at 6000 regardless, but I have gone 7500 miles between oil changes a couple times. Subaru synthetic oil each time. Every time I've checked it before going in, and the oil level before the change has been full, and the color has looked good. I drive the car pretty hard. I don't speed all that much, but from the range of 0 to 80 I'm usually pushing the gas pretty hard if the opportunity arises. I don't redline it because it does seem to fall off a little over 5000. I try to shift at 5200 but sometimes go a little over or a little under. I drive it pretty hard right from the cold start, but do try to keep it under 4K for the first couple of minutes. So far, I think this car has been great, and it's not showing any issues from my treatment. She just seems to like to be driven, rather than babied in my opinion.
fuegodeth is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:28 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.