Welcome to the North American Subaru Impreza Owners Club Monday March 30, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-08-2020, 08:51 PM   #1
joea99
Scooby Newbie
 
Member#: 483823
Join Date: Mar 2018
Location: Stone Ridge, NY 12484
Default 06 forester key fob programming

06, "premium package", 5 speed, will not go into programming mode to add a key fob.

Tried the procedures in the owners manual, provided by the fob seller, and a couple I found on the internet, all similar, but somewhat different.

Yet, no success hearing the "tone" or the flashy lights thing.

I checked with local dealers and they range between $35-$60 to do it, I guess using the Subaru tools. Seems outrageous, to me.

Any suggestions? I live near Kingston NY if anyone in the area can help me out with this, for a reasonable cost.
* Registered users of the site do not see these ads.
joea99 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-21-2020, 10:21 AM   #2
Jp925
Scooby Newbie
 
Member#: 510046
Join Date: Dec 2019
Default

For what itís worth my 06 STi exhibited no sounds or flashing when I did this a few days ago. The giveaway that it was in programming mode was pressing the lock button and the locks didnít respond. I programmed the fob as the instructions say; and when I opened and closed the door again my fob worked.
Jp925 is offline   Reply With Quote
Old 01-21-2020, 10:37 AM   #3
joea99
Scooby Newbie
 
Member#: 483823
Join Date: Mar 2018
Location: Stone Ridge, NY 12484
Default

Thanks for the tip. I finally got it done last week.

Seems the key, pardon the pun, was to do the ignition key "dance" more than the 10 times it says to do. How many more seems to be a question, but probably less than 15. I was not going to cancel and start over at that point. But I did hear a "tone" I had not heard before and quit there to follow the rest of the procedure.

I think the issue is that on older vehicles, the ignition key, lock, contacts, whatever, are worn down and not all the "make and breaks" are recorded by what ever electrics are monitoring it.

Dunno, maybe lubricating the switch with some lock lube before hand might help also help.
joea99 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.