Welcome to the North American Subaru Impreza Owners Club Tuesday March 31, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-03-2020, 05:27 PM   #1
ebrosz
Scooby Newbie
 
Member#: 510357
Join Date: Jan 2020
Chapter/Region: RMIC
Location: Colorado
Vehicle:
2002 Wrx Wagon
Sedona Red

Default Boost oscillation

I'm sure this has been covered but most of the solutions I've found weren't applicable to my situation. So I've owned my 2002 wrx wagon for six or so months now. In the last 4 months it has been getting boost oscillations in 3rd-5th gear at anything over 3500 rpms. And has gotten worse in the last month or so. Here's a list of mods
STI VF39 turbo
STI blue injectors
New intake manifold gaskets
STI intercooler
New hoses throughout (silicone)
Newer 04 wrx transmission
Grimspeed headers
Grimspeed y-pipe
STI up pipe
Hks downpipe
Apexi cat back
New intake manifold gasket
Gfb respons hybrid bov
Cobb 3 port EBCS
Aeromotive 340lph
Heat wrapped SPT intake

I've smoke tested and sealed a couple leaks and inspected vac lines. I have a hunch it might be a boost leak but can't find anything obvious. Any help would be greatly appreciated as I've tried a ton of things to no avail
* Registered users of the site do not see these ads.
ebrosz is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-04-2020, 01:33 AM   #2
supermarkus
Scooby Guru
 
Member#: 6971
Join Date: May 2001
Location: Edmonds, Washington, USA
Vehicle:
2008 WRX STi
SSM

Default

Does the Cobb EBCS require the removal of the restrictor pill from the vacuum line?
supermarkus is offline   Reply With Quote
Old 01-04-2020, 04:40 AM   #3
NutBucket
Scooby Specialist
 
Member#: 90804
Join Date: Jul 2005
Chapter/Region: SCIC
Location: SFV
Vehicle:
2005 WRX

Default

Have the injectors been removed/replaced? That's where I had leaks on mine. It can hold about 10psi before it leaks and goes s**t. Might want to check it out.
NutBucket is online now   Reply With Quote
Old 01-04-2020, 10:59 AM   #4
Therumblebox
Scooby Newbie
 
Member#: 477751
Join Date: Nov 2017
Default

Proper tune for the 3 port? I had issues in higher gears with oscillation when I was running a grimmspeed 3 port on a cobb ots tune
Therumblebox is offline   Reply With Quote
Old 01-23-2020, 09:51 PM   #5
ebrosz
Scooby Newbie
 
Member#: 510357
Join Date: Jan 2020
Chapter/Region: RMIC
Location: Colorado
Vehicle:
2002 Wrx Wagon
Sedona Red

Default

I do have a proper tune and this is a fairly recent issue that has developed. It does not have a restrictor pill but it has been that way since I bought the car and hadn't been an issue until recently. And injectors don't appear to have an issue
ebrosz is offline   Reply With Quote
Old 01-24-2020, 12:01 AM   #6
subaru_gc8
Scooby Specialist
 
Member#: 29292
Join Date: Nov 2002
Chapter/Region: SCIC
Location: Orange County CA
Vehicle:
2004 WRX wagon
silver

Default

how does it oscillate? its it like a hesitation? I would say first disconnect the wategate and see if it still does it. if iou can do a datalog and capture it so we can see what the ecu is doing
subaru_gc8 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:49 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.