Welcome to the North American Subaru Impreza Owners Club Monday October 22, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-15-2018, 11:50 PM   #1
Mack199
Scooby Newbie
 
Member#: 488390
Join Date: Jul 2018
Default 2009 WRX DANGER ZONE (Bad Bearings/motor failure)

Hey guys!

Looking at picking up a 09 WRX for a commuter. After doing some research it seems that some of the 09's had a bad batch of bearings causing motor failure.

From what I could find this only effected cars produced between 06-08 to 09-08. Im curious to hear if anyone with later production models encountered the same issue or has a definitive answer as to when Subaru fix the problem as I couldn't find one. The car I am looking at has a build date of 02-09 so I feel I should be in the clear but just wanted to do some DD to put my mind at ease before committing to the sale.

With this anyone with any other issues I should be on the lookout for would be greatly appreciated.

Cheers
* Registered users of the site do not see these ads.
Mack199 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-16-2018, 04:25 PM   #2
meebs86
Scooby Newbie
 
Member#: 236467
Join Date: Jan 2010
Default

Quote:
Originally Posted by Mack199 View Post
Hey guys!

Looking at picking up a 09 WRX for a commuter. After doing some research it seems that some of the 09's had a bad batch of bearings causing motor failure.

From what I could find this only effected cars produced between 06-08 to 09-08. Im curious to hear if anyone with later production models encountered the same issue or has a definitive answer as to when Subaru fix the problem as I couldn't find one. The car I am looking at has a build date of 02-09 so I feel I should be in the clear but just wanted to do some DD to put my mind at ease before committing to the sale.

With this anyone with any other issues I should be on the lookout for would be greatly appreciated.

Cheers
I think most of the cars that were affected would have had the motor replaced by now, as the motors started going out within a year or two of when the cars were made.
meebs86 is offline   Reply With Quote
Old 07-18-2018, 02:57 AM   #3
chino_487
Scooby Specialist
 
Member#: 209156
Join Date: Apr 2009
Chapter/Region: SCIC
Location: San Gabriel, CA
Vehicle:
2009 WRX Sedan
SSM

Default

Don't worry about it, that car is well past the affected dates.

The only other thing I'd look at is the clutch-firewall spot welds. Plenty of threads here complaining about those.
chino_487 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.