Welcome to the North American Subaru Impreza Owners Club Saturday January 20, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-20-2017, 05:30 PM   #4076
chillin
Scooby Newbie
 
Member#: 123123
Join Date: Aug 2006
Chapter/Region: MAIC
Location: Cheapeake, VA
Vehicle:
2003 WRX

Default

My clutch burned out, getting a new one, ACT, my first aftermarket clutch. The OEM went 166k miles, might be a record.
* Registered users of the site do not see these ads.
chillin is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-20-2017, 08:32 PM   #4077
Harry
Scooby Specialist
 
Member#: 23390
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2010 WRX STI SE
WRB

Default

Quote:
Originally Posted by chillin View Post
My clutch burned out, getting a new one, ACT, my first aftermarket clutch. The OEM went 166k miles, might be a record.
Changed the oil, washed it, and started fitting the side plates from the OEM under tray to my Primitive skid plate - motor is getting pretty dirty with just the skid plate on.

I’m at 132K on my original STI clutch, probably get IAG to swap in a OEM-equivalent clutch and do some bodywork next spring.

- Harry

Last edited by Harry; 12-21-2017 at 01:44 PM.
Harry is offline   Reply With Quote
Old 12-20-2017, 10:23 PM   #4078
carnz-pj-410
Scooby Specialist
 
Member#: 110994
Join Date: Mar 2006
Chapter/Region: MAIC
Location: BALTIMORE
Vehicle:
2x 95 Impreza 2DR
one swapped, one DD

Default

Installed STi Pink lateral links, new rear diff bushings, trans crossmember bushings and all new hardware throughout the entire rear end of the car.

Overhauling the rear axles next week (new boots/clamps inner and outer, and new grease in the joints)
carnz-pj-410 is offline   Reply With Quote
Old 12-29-2017, 10:15 AM   #4079
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Quote:
Originally Posted by Patrick Olsen View Post
- Today I replaced both ball joints on the Impreza with new ACDelco ones. As I said a couple weeks ago when I did the outer tie rods, for as long as I've had the car, I've heard/felt a pop/clunk from the front end when turning. I figured it was the tie rods, but the noise didn't go away when I replaced those, so that left the ball joints as the next culprit. The old ones came out easier than I expected, and were definitely worn out - I could move them around by hand without much effort. Front end feels tighter and quieter over bumps, probably some placebo effect there, but I think there is a genuine difference.
My steering is not returning to center as it should. In the past, when I've had this symptom on one of my other cars, it was due to sticking ball joints (because somebody had failed to lube them properly when he put them on the car ). I haven't actually checked anything on the Impreza yet, so it could be something else, but I'm gonna be pretty pissed if the ACDelco ball joints only lasted 4 months!
Patrick Olsen is offline   Reply With Quote
Old 12-30-2017, 11:03 AM   #4080
blackfang
Scooby Guru
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

At work, we are replacing the timing belt and tensioner pulley for the 2nd time. This time the water pump, idler pulleys, cam and crank seals, resealing oil pan, rear main seal, valve cover gaskets, headgaskets(been leaking oil for a while now), spark plugs/wires and torque converter seal. Legacy has 215k on it and this should be good for another 150k.
blackfang is offline   Reply With Quote
Old 01-11-2018, 10:58 PM   #4081
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

- After months of ignoring it, finally got cruise control to work on the beater. Figured out that I had a misconception regarding the brake pedal switch based on something I had read in an old thread while I was initially gathering parts. Turned out the non-cruise Brighton didn't have the proper switch, so I borrowed the one from the still-not-running Legacy and voila! Functional cruise control!

- Dropped off the driver's seat back at a local upholstery shop to have them fix the side bolster where it has worn through.



There's enough fabric there to fix it without needing any new fabric or a new cover. I proved that to myself last night by doing a Frankenstein fix, just to see if it was possible:



Should have that back tomorrow, so this weekend I can reassemble the seat, reinstall it, and add a switch to the center console for the seat heater that I installed while everything was apart.
Patrick Olsen is offline   Reply With Quote
Old 01-16-2018, 12:24 AM   #4082
corona672
Scooby Newbie
 
Member#: 262902
Join Date: Nov 2010
Location: Arlington, VA
Vehicle:
'04 WRX Hybrid
It's a wrap!

Default

Currently swapping wimpy 04 WRX front knuckle and bearings for 05-07 STi ones. Did not realize the holes for my current Quantum Motorsports duct plates do not fit on the newer year knuckles. Surprise - The 05-07 plates are now discontinued from LIC and Quantum has gone rogue.

Time to bust out the welder? To McMaster Carr, and the 3D printer first!

corona672 is offline   Reply With Quote
Old 01-16-2018, 07:26 PM   #4083
corona672
Scooby Newbie
 
Member#: 262902
Join Date: Nov 2010
Location: Arlington, VA
Vehicle:
'04 WRX Hybrid
It's a wrap!

Default

Dang McMaster is quick. Rev1 printed - a few small optimizations needed.

corona672 is offline   Reply With Quote
Old 01-16-2018, 10:40 PM   #4084
Msmith678
Scooby Newbie
 
Member#: 433425
Join Date: Nov 2015
Default

Don't have a photo, but I knocked off a boat load of rust behind the bumper that I never knew was there. The dermal tool almost burnt out.
Msmith678 is offline   Reply With Quote
Old 01-17-2018, 08:37 AM   #4085
tramp
Scooby Specialist
 
Member#: 459629
Join Date: Dec 2016
Chapter/Region: International
Location: Knobbley Mountain
Vehicle:
2017 WRX base
WR Blue

Default

Last night I drove it from Morgantown to just south of Cumberland in the snow. Man people are idiots. 11MPH w/blinkers on or 70MPH no fookin' sense whatsoever.
tramp is offline   Reply With Quote
Old 01-17-2018, 09:50 AM   #4086
Smurftastic
Scooby Guru
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
02 | BLOD Founding
Member | TopScoob 031

Default

Just did this to my new set of fenders.

Smurftastic is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.