Welcome to the North American Subaru Impreza Owners Club Friday April 16, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-18-2020, 10:09 PM   #35
kscoob
Scooby Newbie
 
Member#: 513600
Join Date: Apr 2020
Location: New York, NY
Post p2096, p0137 on Stock 2008 Impreza Sedan

2008 Subaru Impreza 2.5i Sedan stock, 113k miles

Codes: p2096, p0137

My exhaust was leaking at multiple points. After I got this fixed, the codes came back after a few days. When cleared, the CEL will illuminate after a few mins driving on the highway.

I believe that the Upstream AF sensor has a rich bias. About 5 minutes after the car warms up, it produces a consistent negative current (-0.05-0 mA). Its voltage is 2.1-2.2 V. In that time the LTFT drops from 0 to -4%.

The downstream O2 sensor provides reasonable values at first, in the 1.2-0.4 V range. However this gradually drops to 0.01-0.02 V.

The MAF sensor appears to be responsive, increasing with engine RPM.
2 g/s at idle, 10 g/s at 3000RPM.

I dont hear any vac leak whistles while the engine is being revved with the hood up.

Any ideas?
kscoob is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Subaru 360 Thread SIL01 Member's Car Gallery 29 09-19-2006 09:21 PM
Subaru impreza CEL thread dominiond Service & Maintenance 3 04-25-2004 01:00 AM
The Subaru Upscale Thread SUBE555 News & Rumors 46 10-18-2003 09:16 AM

All times are GMT -4. The time now is 10:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.