Welcome to the North American Subaru Impreza Owners Club Friday December 15, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-16-2004, 11:50 PM   #1
Robin2
NASIOC Supporter
 
Member#: 390
Join Date: Oct 1999
Chapter/Region: E. Canada
Location: Ottawa, Ontario, Canada
Vehicle:
2018 WRX sedan
Dark Grey

Default Coolant leak from water pump (99RS)?

Can anyone confirm this from this pic.....



My friend in NH is looking at this used 99RS.... I have also a 99RS but haven't had this problem.....

Is this a coolant leak from the water pump as it failed (on the seal)?

Tks

Robin
* Registered users of the site do not see these ads.
Robin2 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-17-2004, 10:39 AM   #2
ImprezaVA
Scooby Specialist
 
Member#: 32846
Join Date: Feb 2003
Chapter/Region: MAIC
Location: Elkton, VA
Vehicle:
1998 Impreza L-SOLD
Arcadia Green

Default Coolant leak

It definitely has a leak in the water pump/thermostat housing area. What stumps me is that there is coolant all the way on the other side of the oil pump. Do you see coolant any further north than the area in picture (e.g. around the exhaust manifold)?

How many miles are on the car? Maybe someone botched a water pump install and the bolts worked loose or didn't install the seal properly.

-Charles-
ImprezaVA is offline   Reply With Quote
Old 10-18-2004, 12:05 AM   #3
Foz
Scooby Newbie
 
Member#: 1776
Join Date: Jun 2000
Chapter/Region: W. Canada
Location: Calgary, AB, Canada
Vehicle:
2000 2.5RS
BRP

Default

Quote:
Originally Posted by Robin2
Can anyone confirm this from this pic.....



My friend in NH is looking at this used 99RS.... I have also a 99RS but haven't had this problem.....

Is this a coolant leak from the water pump as it failed (on the seal)?

Tks

Robin
Hey Robin,

Definately doesn't look good. I was losing coolant slowly due to a leak in my water pump as well. Didn't look that messy though as I couldn't even find any leakage. I was lucky to have it done before my 5 year warranty expired this week as it's a pretty pricey repair. If it is the water pump, try to get them to replace the timing belt while they're at it (I didn't know this until searching the forums after my water pump was replaced).

Good luck.
Foz is offline   Reply With Quote
Old 10-18-2004, 12:25 PM   #4
Robin2
NASIOC Supporter
 
Member#: 390
Join Date: Oct 1999
Chapter/Region: E. Canada
Location: Ottawa, Ontario, Canada
Vehicle:
2018 WRX sedan
Dark Grey

Default

Tks.....

I received this from subaru friend.... it seems it the thermostat....

"I got this leak before, and all I had to do was replace the thermostat and gasket around the thermostat.

The plastic inlet has a lip on it that prevents it from being tightened over the thermostat. After a few years the rubber gasket around the thermostat dries out and the water inlet / thermostat housing starts to rock."

Robin
Robin2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS (PA) Coolant crossover pipe, water pump, ac compressor [email protected] Engine/Power/Exhaust 4 08-03-2011 03:39 AM
Coolant leak, maybe water pump? KanosWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 08-12-2007 11:06 PM
Leak at Water Pump Gasket ITWRX4ME Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 4 04-21-2006 10:58 PM
where does my coolant leak from? haszlan Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 12-31-2003 06:40 AM
coolant leak, from near thermo(pics) biggreen96 Normally Aspirated Powertrain 26 06-21-2003 02:53 PM

All times are GMT -4. The time now is 09:25 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.