Welcome to the North American Subaru Impreza Owners Club Tuesday June 2, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-17-2020, 10:39 AM   #1
alfadoc
Scooby Newbie
 
Member#: 492454
Join Date: Oct 2018
Location: Lynchburg VA
Vehicle:
2005 FXT

Default Trying to solve P0021 code

I guess I’m looking for confirmation that I’m on the right track. 05 FXT. Has a brand new factory short block. I cleaned and properly resurfaced the heads which only had 130k on them. New oil cooler, everything cleaned meticulously on assembly. All oil screens removed. P0021 shows up, and then will clear on its own, only to reappear. I swapped OCV side to side, no change. Factory oil filter, running Rotella T6, oil change is fresh. When I pulled the AVCS gears apart for cleaning, I noted a fair bit of scoring, and recall one worse than the other, though don’t recall which one. I’ve reached the conclusion that I just need to replace the left AVCS gear. Everything is box stock, no mods. Car runs great, no rough idle or other driveability Issues. Did I miss anything?
* Registered users of the site do not see these ads.
alfadoc is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-25-2020, 08:36 PM   #2
CGM/WRX
Scooby Newbie
 
Member#: 87133
Join Date: May 2005
Chapter/Region: SCIC
Location: SoCal
Vehicle:
1998 2.5RS V7 EJ207
Brilliant Red

Default

Any time I do a engine rebuild
For a bearing failure and metal debris is throughout the engine oil. I would replace both avcs cam sprockets, oil pump, oil feed pipe filter banjo bolts, oil cooler, and avcs solenoids. Because those are non serviceable parts. And you can get everything out and once scored they will not function properly. Which is why you will chase avcs codes until those are replaced. I have seen it all of times because of trying to short cut or do on the cheap. But it always bites back. Just my experience. Good luck.
CGM/WRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:18 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.