Welcome to the North American Subaru Impreza Owners Club Monday December 18, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 02-18-2004, 10:32 AM   #1
Puckaveli
Scooby Specialist
 
Member#: 1518
Join Date: May 2000
Location: Stow, OH
Vehicle:
00 2.5RS
Silver

Default EJ20G wiring issues.

Brief summary of what I got: 93 JDM WRX EJ20G w/ tranny and complete drivetrain going into 2000 RS. I downloaded wiring diagrams from the jimclarkeracing.co.uk site for a pre 96 Impreza. Well after going over them they are about 95% correct. I have the ECU, complete engine harness, front harness, and a cut up bulkhead harness. Here are some issues.

The pinouts are in the pic below, but after going through my ECU plugs pin by pin I found that these pins have wires in them but they are not on the sheets below. I followed them all and this what I found:
B44-16 is cut but the wiring diagrams show it as the power steering oil pressure switch. Even stranger is it's in the wiring diagrams but not in the pinout page.
B43-4 pressure sensor
B43-5 goes to unknown plug.
B96-11 is cut and not in the wiring diagrams so?
B43-12 is cut and not in the wiring diagrams so?

So if anyone has pinouts for an EJ20G could you please look for those.

pinout page 1
pinout page 2

Figured out the "EGT" plug.
* Registered users of the site do not see these ads.

Last edited by Puckaveli; 03-01-2004 at 05:49 PM.
Puckaveli is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-18-2004, 05:48 PM   #2
rob
n00b Moderator
Moderator
 
Member#: 811
Join Date: Jan 2000
Location: WA
Vehicle:
2000 RS-Ej20G
It tastes like burning

Default

Sorry, I can't be much help, but I am very interested in your results as I will likely be doing a very similar swap later this year.

I have some questions that may help point in the right direction...or maybe they are completely useless

It sounds like you only need to figure these out (the other two appear to be solved).
B43-5
B96-11
B43-12

Where are they cut at?

For the mystery sensor, which connector(s) and pins does it connect to? Can you trace it back to the ECU? Can you take a pic of the sensor?

You could just ignore these for now and see if the ECU diagnostics can give you insight when you try to start it.

-Rob
rob is offline   Reply With Quote
Old 02-19-2004, 11:20 AM   #3
Puckaveli
Scooby Specialist
 
Member#: 1518
Join Date: May 2000
Location: Stow, OH
Vehicle:
00 2.5RS
Silver

Default

The wires are cut where the bulkhead harness divides and goes through the firewall and continues under the dash toward the driver's side.

The second wire from the unknown plug goes to the ECU and guess what pin it is? That's right B43-5 one of the pin missing from my pinout sheet. I have to get the sensor back from a friend, once I get it i'll snap a pic of it.
Puckaveli is offline   Reply With Quote
Old 02-19-2004, 12:24 PM   #4
rob
n00b Moderator
Moderator
 
Member#: 811
Join Date: Jan 2000
Location: WA
Vehicle:
2000 RS-Ej20G
It tastes like burning

Default

Ok, then only 2 more left
B96-11
B43-12

Can you identify which bulkhead connector and pins those are on?

BTW, you said B43-5 was cut, so how did you trace it out to the sensor?

-Rob
rob is offline   Reply With Quote
Old 02-19-2004, 01:04 PM   #5
Puckaveli
Scooby Specialist
 
Member#: 1518
Join Date: May 2000
Location: Stow, OH
Vehicle:
00 2.5RS
Silver

Default

Both B96-11 and B43-12 are cut about one foot from the ECU so I can't tell where they should go.

I miss read my notes on B43-5 I checked it again last night it goes to the supposed EGT probe.
Puckaveli is offline   Reply With Quote
Old 02-19-2004, 07:50 PM   #6
granteeton
Scooby Newbie
 
Member#: 53529
Join Date: Jan 2004
Chapter/Region: TXIC
Location: Lewisville, TX
Default

i have a pinout for a my97 LHD ej20t if your interested.
granteeton is offline   Reply With Quote
Old 02-20-2004, 09:46 AM   #7
Puckaveli
Scooby Specialist
 
Member#: 1518
Join Date: May 2000
Location: Stow, OH
Vehicle:
00 2.5RS
Silver

Default

Quote:
Originally posted by granteeton
i have a pinout for a my97 LHD ej20t if your interested.
So do I and it really doesn't reveal anything but I do appreciate the offer, thanks.
Puckaveli is offline   Reply With Quote
Old 03-01-2004, 05:49 PM   #8
Puckaveli
Scooby Specialist
 
Member#: 1518
Join Date: May 2000
Location: Stow, OH
Vehicle:
00 2.5RS
Silver

Default

So no one else has the pin out for a EJ20G?
Puckaveli is offline   Reply With Quote
Old 03-02-2004, 04:45 PM   #9
rob
n00b Moderator
Moderator
 
Member#: 811
Join Date: Jan 2000
Location: WA
Vehicle:
2000 RS-Ej20G
It tastes like burning

Default

Puck,

Did you get this figured out?

-Rob
rob is offline   Reply With Quote
Old 03-03-2004, 03:36 PM   #10
Puckaveli
Scooby Specialist
 
Member#: 1518
Join Date: May 2000
Location: Stow, OH
Vehicle:
00 2.5RS
Silver

Default

Well it appears the diagrams I have are for the UK model and I have a JDM model. So I'm enlightened but I'm still in the dark about the ECU pins.

The "EGT" plug is just a "your cat is not working" sensor. Most of the UK guys with imports just unplug it and leave it be when they up grade downpipes, so no issue there.
Puckaveli is offline   Reply With Quote
Old 03-03-2004, 04:00 PM   #11
Structure828
*** Banned ***
 
Member#: 50488
Join Date: Dec 2003
Location: Orlando, FL.
Vehicle:
1999 GC8 ej20g!
Black

Default

Welcome to my world

Looks like we are in somewhat of a similar wiring hell. My mechanic might have to tow my car 300 miles to Subaru of Jacksonville to some guy that can get the car out of DIAG mode. Or have some hardcore VW wiring expert look at it. Im going on week what... 18 now.... 4 and 1/2 months
Structure828 is offline   Reply With Quote
Old 03-06-2004, 04:51 AM   #12
AWJunkies
Scooby Specialist
 
Member#: 32934
Join Date: Feb 2003
Location: Dallas
Vehicle:
99 2.5RS JDM WRX
silver

Default

I deleted my comment sorry....

Last edited by AWJunkies; 08-24-2005 at 04:12 AM.
AWJunkies is offline   Reply With Quote
Old 08-23-2005, 06:19 PM   #13
rob
n00b Moderator
Moderator
 
Member#: 811
Join Date: Jan 2000
Location: WA
Vehicle:
2000 RS-Ej20G
It tastes like burning

Default

Trying to close the loop on an old thread.... I have found these two pins listed in the JDM manual.
B96-11 goes to some switch under the dash. Not sure what it's for, I have a listing that it's an accelerator switch on the pedal shaft? I'll hunt around and find it on my clip.
B43-12 goes to some warning bulb in the cluster. Since I sold my cluster, I can't check on this directly.

-Rob
rob is offline   Reply With Quote
Old 08-24-2005, 03:39 PM   #14
rob
n00b Moderator
Moderator
 
Member#: 811
Join Date: Jan 2000
Location: WA
Vehicle:
2000 RS-Ej20G
It tastes like burning

Default

The B96-11 switch is indeed on the gas pedal. It's normally closed with the throttle at 0%. Now what in the world does the ECU do with this?

B43-12 is confirmed to go to the Exhaust Gas Temp warning light in the cluster.

-Rob
rob is offline   Reply With Quote
Old 08-25-2005, 01:36 AM   #15
Storm
Scooby Guru
 
Member#: 5218
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: SAUL'S Motorsports
Vehicle:
96L Most Over-
Developed Beater

Default

Quote:
Originally Posted by rob
The B96-11 switch is indeed on the gas pedal. It's normally closed with the throttle at 0%. Now what in the world does the ECU do with this?

B43-12 is confirmed to go to the Exhaust Gas Temp warning light in the cluster.

-Rob
Could possibly be a WOT switch to cycle out the A/C....

[/hijack]
Jay Storm
Storm is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB: EJ20G Wiring Harness and ECU scarless ronin Private 'Wanted' Classifieds 0 08-23-2009 05:42 PM
Noob Question and Problem.... tjwilke UTEC 8 07-04-2006 01:14 AM
Oil change question and problem tubular031 Service & Maintenance 23 09-13-2005 04:49 PM
Wheel Bearing question and problems? ImprezedRS Service & Maintenance 3 05-01-2003 02:02 PM
fog light wiring question and pics. zeke21 Interior & Exterior Modification 0 02-14-2002 10:00 PM

All times are GMT -4. The time now is 01:13 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.