Welcome to the North American Subaru Impreza Owners Club Thursday September 19, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 06-22-2019, 03:44 PM   #3151
Supraru
Scooby Specialist
 
Member#: 23313
Join Date: Aug 2002
Location: Collegeville,Pa
Vehicle:
99' 2.5Rs
black

Default

Quote:
Originally Posted by Kostamojen View Post
Make: 2018 Subaru STI Type-RA

Mileage: 3600

Time Out Of Use: 3 weeks

Problem And Likely Cause: 3rd-4th gear grinding, 4th gear syncro worn, other parts found worn/damaged during inspection.

Modifications: AOS and 91 Octane tune (Type-RA ECU runs terrible on 91 octane)

Submitted For Warranty Work (Yes/No): Yes

Reason Given For Denial: Modifications

Your Story:

Bought the Type-RA last year October. Has had minor issues with 3rd gear since day one, occasionally not wanting to go into gear. Haven't missed shifts or over-revved (not my first manual Subaru, have had manual Subaru's since 2001). 3rd-4th completely failed last month, would grind every time shifting even at low speeds and any RPM. Took it in for warranty claim at the dealer I used to work at, they went to bat for me but ultimately Subaru Corporate denied the claim...

Probably have to sell the car because I was laid off recently too. Bill is over $5000. Car is paid off.
That blows. Not for nothing but the only one who would report that you had it tuned is the mechanic. Then from there the writer had to have documented it, filled out a mod report, then sent it into Subaru. If they were still cool with you they’d never turn it in or fill it out in the first place. It sucks. We’ve warrantied a lot of stuff we shouldn’t have because they would rather not deal with a bad review.
* Registered users of the site do not see these ads.
Supraru is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-25-2019, 09:00 PM   #3152
elislider
Scooby Specialist
 
Member#: 133923
Join Date: Dec 2006
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
03 Legacy GT wagon
I love goooollllllllddddd

Default

Name: Eliot

Make: '13 Crosstrek

Mileage: 130k

Time Out Of Use: n/a

Problem And Likely Cause: excessive oil consumption (known issue) and click/whirring noise from CVT

Modifications: None

Submitted For Warranty Work (Yes/No): Yes

Reason Given For Denial: Mileage over 100k so all extended service claims denied. Called SoA and they confirmed it.

Your Story: Bought the car with about 131k on it. Drove great. On a road trip around 133k I noticed the low-oil light came on, even though it had 3k left until it needed an oil change. Took it in to the dealer and they said they could do an oil consumption test but since it was over 100k miles then it wouldn't qualify for any coverage. I paid for them to do an oil change, came back 1500 miles later, they said it was consuming a normal amount of oil, nothing alarming, not close to what would normally qualify under the oil consumption recall. Also started noticing a clicking/whirring noise from the transmission at low speed, they checked it and said it was coming from the transmission and would be $6000+ to replace it.

They did the valve spring recall (which includes another oil change) and brake switch recall and I went on my way. At this point it had 135,500. Just last week at 137k the low oil light came on again. That's only 1500 miles since it just had new oil after the valve spring recall repair. Making another appointment with them this week regarding the oil consumption.

Regarding the transmission, the noise is getting louder. Might try another dealer to see what they say.
elislider is offline   Reply With Quote
Old 06-25-2019, 09:12 PM   #3153
Supraru
Scooby Specialist
 
Member#: 23313
Join Date: Aug 2002
Location: Collegeville,Pa
Vehicle:
99' 2.5Rs
black

Default

Quote:
Originally Posted by elislider View Post
Name: Eliot

Make: '13 Crosstrek

Mileage: 130k

Time Out Of Use: n/a

Problem And Likely Cause: excessive oil consumption (known issue) and click/whirring noise from CVT

Modifications: None

Submitted For Warranty Work (Yes/No): Yes

Reason Given For Denial: Mileage over 100k so all extended service claims denied. Called SoA and they confirmed it.

Your Story: Bought the car with about 131k on it. Drove great. On a road trip around 133k I noticed the low-oil light came on, even though it had 3k left until it needed an oil change. Took it in to the dealer and they said they could do an oil consumption test but since it was over 100k miles then it wouldn't qualify for any coverage. I paid for them to do an oil change, came back 1500 miles later, they said it was consuming a normal amount of oil, nothing alarming, not close to what would normally qualify under the oil consumption recall. Also started noticing a clicking/whirring noise from the transmission at low speed, they checked it and said it was coming from the transmission and would be $6000+ to replace it.

They did the valve spring recall (which includes another oil change) and brake switch recall and I went on my way. At this point it had 135,500. Just last week at 137k the low oil light came on again. That's only 1500 miles since it just had new oil after the valve spring recall repair. Making another appointment with them this week regarding the oil consumption.

Regarding the transmission, the noise is getting louder. Might try another dealer to see what they say.
What do you expect will happen taking it to the dealership again? You bought a used Subaru with over 100k mikes on it. They aren’t going to hand you a free engine and trans. Bust out the check book or drive it till it goes....
Supraru is offline   Reply With Quote
Old 07-01-2019, 11:08 AM   #3154
KalamazooSaabaru
Scooby Newbie
 
Member#: 462388
Join Date: Feb 2017
Default 2017 WRX Base Clutch Master Cylinder Failur

Name: Abe

Make: '17 WRX

Mileage: 49k

Time Out Of Use: 10 days and counting

Problem And Likely Cause: Clutch pedal went to the floor while driving and stayed there; Maple Hill Subaru says it's the clutch master cylinder but I haven't been able to get anyone to tell me whether or not the part failed or if it was something the previous owner or myself may have done.

Modifications: Coilovers, previous owner installed

Submitted For Warranty Work (Yes/No): Yes

Reason Given For Denial: The shop did not indicate that the part was defective, so SoA denied the warranty claim. No reason for the part failing has been given to me yet.

Your Story: I bought the vehicle about a month ago with 48k miles on it, decently clean with all the service history at a Subie dealer. Love the car, coming off of an 05 Saabaru. Been babying it trying to get the most mpg's possible, currently seeing 30+mpg dailying it to work. LOVE the car, hate the sound system. Anyway...

I leave work on a Friday, stop at a light, get the car into 1st no problem, second I notice a faint click but dismiss it as I assume it was my foot hitting something. Go into third, definitely a noticeable click. I go to shift into 4th and the pedal sticks to the floor. I pull off into the middle lane, wait two hours for a tow because Friday, and drop the car to Maple Hill at around 5pm. I call back Monday to see if they scheduled the inspection, get told I'll get a call back Tuesday with the info. Get the call Wednesday afternoon, clutch master cylinder failed, won't warranty because over 36k miles, tell them to sit on it til I hear from Subaru of America. I get a call back from Subaru telling me the car is over 36k miles, so sorry, I tell them I thought defective parts were covered. Peter at Subaru of America tells me no, they only cover defective parts within the 36k mile warranty. Doesn't seem right to me, but OK, let's have a supervisor call me so I can make sure. I speak with Virgil(not a pleasant experience), and he eventually informs me that if the part were defective, SoA would cover it, but since the dealer didn't indicate that the part was defective, they wouldn't be doing anything for me. I ask what the dealer said caused the part failure, Virgil informs me that they did not provide any information as to the nature of the failure. I ask him to inquire with the dealer as to why the part failed, he says he'll ask them to reach out to me. I am still waiting to hear back from Maple Hill at this time, and I expect that I'll be paying for this out of pocket.
KalamazooSaabaru is offline   Reply With Quote
Old 08-14-2019, 11:44 AM   #3155
ZoomZoomRex
Scooby Newbie
 
Member#: 505071
Join Date: Aug 2019
Default 2019 WRX Base Manual Transmission

Name: Mike
Make: 2019 WRX base model 6MT
Mileage: 30,000
Time out of use: 41 days and counting
Problem and likely cause: Hole found in top of short block caused by damaged piston and connecting rod.
Modifications: None
Submitted for warranty work: Yes
Reason for denial: "Operated vehicle outside of its intended parameters."
I asked what specifically was operated outside of its intended parameters. They said engine speed and boost were outside of intended parameters. When I asked for the report showing when it happened and what the engine speed and boost numbers were they refused to show me/tell me saying it was an internal Subaru document. Subaru is covering under goodwill but not warranty.
ZoomZoomRex is offline   Reply With Quote
Old 08-14-2019, 02:32 PM   #3156
2018wrx_newbie
Scooby Newbie
 
Member#: 477489
Join Date: Nov 2017
Chapter/Region: MWSOC
Vehicle:
2018 WRX Limited
CWP

Default

Quote:
Originally Posted by ZoomZoomRex View Post
Name: Mike
Make: 2019 WRX base model 6MT
Mileage: 30,000
Time out of use: 41 days and counting
Problem and likely cause: Hole found in top of short block caused by damaged piston and connecting rod.
Modifications: None
Submitted for warranty work: Yes
Reason for denial: "Operated vehicle outside of its intended parameters."
I asked what specifically was operated outside of its intended parameters. They said engine speed and boost were outside of intended parameters. When I asked for the report showing when it happened and what the engine speed and boost numbers were they refused to show me/tell me saying it was an internal Subaru document. Subaru is covering under goodwill but not warranty.
That's strange that they would not share more details on it. But at least you are getting it replaced free of cost.

Did you at any time push the car too hard?
2018wrx_newbie is offline   Reply With Quote
Old 08-14-2019, 02:42 PM   #3157
ZoomZoomRex
Scooby Newbie
 
Member#: 505071
Join Date: Aug 2019
Default

Quote:
Originally Posted by 2018wrx_newbie View Post
That's strange that they would not share more details on it. But at least you are getting it replaced free of cost.

Did you at any time push the car too hard?
I never (knowingly) redlined or pushed the car too far. I may have missed a shift here or there but nothing that should have caused this. It seemed sketchy that they wouldn't give me more details and has left a really bad taste in my mouth. If they legitimately showed me where I screwed up then by all means I'd say thank you and move on, but I really don't think I ever went beyond redline. I had a 2012 WRX before this which I brought to 155,000 miles (would have been more if I didn't get rear ended) so I am aware of the limits of the car.
ZoomZoomRex is offline   Reply With Quote
Old 08-14-2019, 04:15 PM   #3158
2018wrx_newbie
Scooby Newbie
 
Member#: 477489
Join Date: Nov 2017
Chapter/Region: MWSOC
Vehicle:
2018 WRX Limited
CWP

Default

Got it. Perhaps ask the tech or advisor again nicely when you pick up the car, after they have fixed it. Maybe they will share some more information then.
2018wrx_newbie is offline   Reply With Quote
Old 08-14-2019, 04:29 PM   #3159
Waddlz
Scooby Specialist
 
Member#: 395275
Join Date: Jul 2014
Chapter/Region: RMIC
Location: Brighton, CO
Vehicle:
2012 STi
SWP

Default

subaru must be losing their ass with WRX/STi warranties to fight these with those silly "you redlined/started/drove the car in a manner we disagree with" and yet prove nothing to you.
Waddlz is offline   Reply With Quote
Old 08-19-2019, 09:22 PM   #3160
Windsor14STI
Scooby Newbie
 
Member#: 505473
Join Date: Aug 2019
Location: New England
Vehicle:
2014 STI
Plasma Blue Pearl

Default

Thought I would add one to the connecting rod bearing class action issue. 2014 STI only 10K miles, was denied because car was modified, In my case the rod was not bent, just a cylinder 4 bad connecting rod bearing.

I didn't make a stink and ended up going with IAG stage 2.
Windsor14STI is offline   Reply With Quote
Old 09-06-2019, 11:23 PM   #3161
rodhotter
Scooby Newbie
 
Member#: 405104
Join Date: Oct 2014
Location: pennysylvania
Vehicle:
2001 audi TT 225Q
black roadster

Default

most cars today use 400 grade stainless that corrodes a protective layer THEY say!! if a magnet sticks thats what you got, unlike nonmagnetic 304 grade stainless borla uses that only discolors in its lifetime aka forever!
rodhotter is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble/Warranty Denial Report Thread: Electrical (Lighting, ECU, Sensors, Etc.) North Ursalia Warranty Issues & SOA Problems 138 09-17-2019 09:14 PM
Trouble/Warranty Denial Report Thread: Braking System North Ursalia Warranty Issues & SOA Problems 96 09-12-2019 09:10 AM
Trouble/Warranty Denial Report Thread: Body/Exterior of Vehicle North Ursalia Warranty Issues & SOA Problems 146 03-02-2019 12:31 PM
Trouble/Warranty Denial Report Thread: Interior North Ursalia Warranty Issues & SOA Problems 71 11-14-2018 08:18 AM
Trouble/Warranty Denial Report Thread: Suspension North Ursalia Warranty Issues & SOA Problems 56 03-21-2018 11:09 PM

All times are GMT -4. The time now is 04:56 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.