Welcome to the North American Subaru Impreza Owners Club Thursday August 6, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-01-2020, 10:04 AM   #1
TheZedric
Scooby Newbie
 
Member#: 517218
Join Date: Aug 2020
Chapter/Region: VIC
Location: British Columbia, Canada
Vehicle:
2003 WRX Wagon
Silver

Default Bolt size for Invidia N1 02-07 WRX exhaust

What the title says!

I just got my Invidia N1 exhaust installed and used the new included bolts+nuts because the factory bolts I took off the OEM exhaust broke due to the rust when I tried taking them off. I was thinking of going to Home Depot to get some longer bolts the same size as the bolts included with the new exhaust system because I'm having trouble getting enough of the bolt to slot through for me to thread the nut on. I drilled out the holes bigger where the factory bolts had went on past the cat where the rest of the new exhaust connects to the old rest of the old factory piping towards the cat+DP and the new bolts aren't poking through enough for me to thread the nut on easily.

Can't find the info anywhere so I'd really appreciate the help!
* Registered users of the site do not see these ads.
TheZedric is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-01-2020, 11:17 AM   #2
cdska
Scooby Newbie
 
Member#: 458809
Join Date: Nov 2016
Chapter/Region: NESIC
Location: Boston
Vehicle:
2005 wrx wagon

Default

Buy two of these. Don't use the spring. https://www.amazon.com/dp/B00068OLC4

Even gone depot grade 10.9 will rust
cdska is offline   Reply With Quote
Old 08-01-2020, 12:14 PM   #3
TheZedric
Scooby Newbie
 
Member#: 517218
Join Date: Aug 2020
Chapter/Region: VIC
Location: British Columbia, Canada
Vehicle:
2003 WRX Wagon
Silver

Default

Quote:
Originally Posted by cdska View Post
Buy two of these. Don't use the spring. https://www.amazon.com/dp/B00068OLC4

Even gone depot grade 10.9 will rust
Thank you for helping!
TheZedric is offline   Reply With Quote
Old 08-01-2020, 12:31 PM   #4
cdska
Scooby Newbie
 
Member#: 458809
Join Date: Nov 2016
Chapter/Region: NESIC
Location: Boston
Vehicle:
2005 wrx wagon

Default

Home depot, not gone depot lol. If that bolt ends up being too long then use the factory spring. Hope that works for you!
cdska is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:45 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.